Skip navigation
Nanda_KP
Currently Being Moderated

Blu-ray image build fails with LPCM error

Jul 22, 2012 11:01 AM

Tags: #of #blu-ray #encore #32 #sample #bits #per #cs6 #build #bluray #is #code: #14 #lpcm #illegal.

hello,

 

Using CS6 Encore

I have created H.264 files (.264, .264.Stereo1) for a 1:04hr sequence using Matrox

- 1920x1080p 23.98fps

- both 27.0 and 30.0 target data rate, Constant Bit Rate CABAC, H.264 level of 4.1

 

and when I try to build a Bluray image using them, the build fails with the message:

EncoreCS6_error.png

 

Error: "invalid format", Code: "14", Note: "Bits per Sample of LPCM is illegal. 32"

 

I first got this error using target data rate of 30 (default) - then I dropped it to 27.0 and still got the error.

 

 

 

I then tested with a 1min H.264 file created using the same above settings and the image was successfully created.

 

In CS5.5, when I had similar errors, I dropped the target data rate to 27.0/27.1 and the build would complete without errors.

 

I can't find any discussion of the above error on the web or on these forums - perhaps my search terms were not good.

 

Any help would be greatly appreciated.

 

I was able to successfully build another 1hr blu-ray image with default settings (target data rate 30) a few days back.

 

In both successful and unsuccessful cases,the source sequence is a 1920x1080i 29.97fps Matrox AVI file, which I convert to 1920x1080p 23.98 fps in AME using Matrox to create the .264/.264.Stereo1 files, which I then import into CS6 Encore and create the image.

 

Encore CS5.5 was a pain in that it would hang on source files larger than 2GB - I came across a Adobe forum/support thread suggesting using the workaround of importing to the Encore timeline files <= 2GB in size.

 

-Nanda

 

-Nanda

 
Replies
  • Currently Being Moderated
    Jul 22, 2012 11:19 AM   in reply to Nanda_KP

    My best guess on this one, give the specifics of the error message, is that you're trying to write LPCM audio to disk that isn't Blu-ray legal.

     

    Acceptable bit-depths for LPCM audio are 16, 20 and 24.  It looks like your LPCM audio is 32.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 22, 2012 9:43 PM   in reply to Nanda_KP

    Did you try looking at the property of the file in question? Sometimes, depending on the file content, the encoding process might overshoot the assigned bit values for bitrate or sample rate etc. For 1 min clip, the content might not require that high bit values but it might be true for 1 hour movie file.

     

    -Ramesh.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2012 6:40 AM   in reply to Nanda_KP

    i think MediaInfo should be good for this.

     

     

    -Ramesh.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2012 10:51 AM   in reply to Nanda_KP

    Hmm... I did not save a link to my notes file, so not 100% sure about this, but I *think* I remember a discussion of big-vs-little endian sound... and problems with one of them

     

    You might do a forum search for "little endian" (without the " ") marks to see what results

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2012 11:09 AM   in reply to Nanda_KP
    Both the 1min and the 1hr .Stereo1 WAV files show the same 32-bit bit depth as per MediaInfo.

     

    Odd.  You'll probably have to find a way to fix that.  Maybe open the .wav in Audition and resave, making sure it's at 16, 20 or 24.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 4:56 PM   in reply to Nanda_KP

    Well, there certainly does seem to be something wrong with that file.

     

    Try brining it into PP as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 5:16 PM   in reply to Nanda_KP

    The fact that this solution worked to me indicates that the audio file was out of spec (despite the target settings appearing to be set within spec in Matrox). The data provided by MediaInfo seems to validate this. Despite setting the bit depth to 24-bit the file seemed to be detected as 32-bit. Assets that are compliant should be detected as such by Encore. It looks like we have improved the compliance detection between Encore CS5.5 and CS6. I would be curious to get the specs of the .Stereo1 file after it gets transcoded with the Automatic setting. You should be able to manually initiate the transcode process prior to the Build/Burn in Encore. Maybe see what settings are geting applied and see if setting these as the target in Matrox makes any difference? Another interesting test might be to try a bit depth of 16-bit instead of 24-bit in Matrox.

     

    My two cents,

     

    -Dave 

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points