Skip navigation
Steven::WebBees
Currently Being Moderated

Illustrator crashes on new document

Jul 3, 2012 11:05 AM

Hi guys,

 

AI cs6 crashes all the time when I try to change the 'Profile' in the new document window.
It just freezes. I can't make a file for the web.

 

Very annoying

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Jul 3, 2012 11:10 AM   in reply to Steven::WebBees

    What OS are you running? If a Mac at 10.7.4, you may be out of luck as there are lots of reports of problems with that particular combination.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2012 11:24 AM   in reply to Steven::WebBees

    The following folder needs Read & Write access:

    Macintosh HD:Users:(Your User Name):Library:Application Support:Adobe:Adobe Illustrator CS5

     

    You can change this access by selecting "Get Info" on this folder, then adjust the Sharing & Permissions options so everyone can Read & Write.

     

    Can you try the above steps and then check.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2012 11:48 AM   in reply to Steven::WebBees

    the solution didn't work or the the permission is not correct. ?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 22, 2012 11:33 PM   in reply to Steven::WebBees

    I have the same problem; I can load up AI for the first time, change New Document profile to web and work as normal, but once I exit AI and open it again, it freezes whenever I try to start a New Document - and it only happens when I last worked in web document profile.

     

    The only workaround I've found so far is holding down Command+Option+Shift while clicking the AI dock icon to open the program, which apparantly wipes the preferences file, and allows me to actually use AI and start a New Document.

     

    It really is annoying, I hope Adobe fixes it sooner rather than later...

     

    (Running CS6 on OSX 10.7.4)

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 4:18 AM   in reply to C Rzepa

    I've had the same problem in both Lion 10.7.4 and 10.8 with Illustrator CS6.

     

    Illustrator will freeze on creating a new document when chaning the profile. This started happening when I moved from a 2007 Mac Pro to a 2012 Mac Pro (simply moved hard drives over).

     

    I uninstalled Illustrator and reinstalled it with the remove proferences option.

     

    That worked for a time.

     

    I've upgraded to Mountain Lion. All apps work except Illustrator will now sometimes freeze on certain files (which open just fine in AI CS5.5 on 10.8 same machine).

     

    If I resaved them in CS55 and then opened them in CS6 they would work again. Very strange. They were only ever CS6 files - not complex.

     

    I've just read Beltine Grey's tip to hold down Command+Option+Shift while opening AICS6 and that FIXED the issue with the files which wouldn't open. I'll use that until Adobe fixes the issue properly.

     

    What's strange is that up until last week and I have been on 10.7.4 from the day it was out I have not had the issue at all. I've definitely got it now!

     

    All other apps I've tried in the CS6 suite are working fine with Mountain Lion. But since I had the problem on Lion with Illustrator then that's not a Mountain Lion issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 8:05 AM   in reply to C Rzepa

    for the record, i've narrowed it down to the EXACT file that causes the issue of the crash. When i delete it and start it, it runs great. but then when i close it and start it up again, it causes issues.

     

    the file is

    /Users/trza/Library/Preferences/Adobe\ Illustrator\ CS6\ Settings/en_US/Adobe\ Illustrator\ Prefs

     

    its got seemingly fine permissions. i've taken screenshots of it all here

    http://forums.adobe.com/thread/1031030

     

    we've gotta figure this out. its so frustrating. upgrading to mountain lion is one idea, but i dont even like the way os x has been heading lately, i dont want to upgrade. im on 10.7.4 right now   

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2012 11:52 AM   in reply to trzown-SLxMG9

    The folder itself might have the problem check the Sharins and Oermissions for the Adobe illustrator Settings folder

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 7:10 AM   in reply to Wade_Zimmerman

    I can give everyone, <user>, and administrator to read & write, but how many folders back should i do that? naturally it's not good to do it to /

    I suppose i can just try everything and revert back slowly. My /Users/trza/Library/Preferences/Adobe\ Illustrator\ CS5.1\ Settings is set the same as cs6. ugh this suck

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 8:36 AM   in reply to trzown-SLxMG9

    You do change the Sharing and Permissions for the folder and then use the feature to apply to all items within the folder.

     

    Screen Shot 2012-07-30 at 11.35.56 AM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 9:01 AM   in reply to Wade_Zimmerman

    Thanks so much for being so helpful with this.

     

    Here is what I've done, I deleted the whole /Users/trza/Library/Preferences/Adobe\ Illustrator\ CS6\ Settings folder to start clean.

     

    i started / closed illustrator cs6.

     

    i changed permissions for everyone read&write and applied to enclosed items on /Users/trza/Library/Preferences/Adobe\ Illustrator\ CS6\ Settings

     

    i started illustrator, still same problem. when i change from print to web, the app locks up (not responding) :\

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2012 7:17 PM   in reply to Steven::WebBees

    Having the same issue. I've tried deleting the prefs, cache, and app support files. nothing has helped.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2012 7:26 PM   in reply to kidhack

    I've also tried holding down Command-Option-Shift > Quit > opened Permissions > Opened Illustrator > Create New Document > Profile: Web = Crash

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2012 9:12 PM   in reply to kidhack

    So it is then possible that the file for the Web Document Prrofile has the permissions problem

     

    it is located here in the User/Username/Library directory

     

    Screen Shot 2012-08-14 at 12.08.33 AM.png

     

    Screen Shot 2012-08-14 at 12.08.59 AM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2012 10:01 PM   in reply to Wade_Zimmerman

    Yup. Didn't seem to help.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 8:53 AM   in reply to kidhack

    The Cmd-Opt-Shift is used when you start AI to force a rebuild of the Preferences to the default.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 9:13 AM   in reply to Larry G. Schneider

    yup. thats when i did it. Illustrator seems to change the permissions of the file after i've changed them.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 4, 2012 11:52 AM   in reply to Larry G. Schneider

    This is great that it works but.. what the hell. How do i prevent this from having to happen every time i close and reopen?

     

    So basically I need to delete the preferences each time i open it. beacuse when i close it, it's writing it as sudo or something.

     

    So can I either set up a custom launcher that launches it with that shortcut that rebuilds? Or can i make it so it doesnt screw with my preferences file when i close it?

     

    There's gotta be at least a half automated way to get this working.

     

    What do these preference files hold? what will i lose every time i keep deleting them? So far it doesnt look like it's changing much (Still same layout / presets / brushes etc stay)

     

    thanks for the fix so far. much obliged.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2012 8:32 AM   in reply to Larry G. Schneider

    Bumping my answer for hopes that I can automate this in some way with some sort of custom launcher

     

    If i knew what flags I could run it from terminal and then make it into a little bash script or something and make that a shortcut in my dock? thoughts on that anyone?

     

    I don't even know what technically CMD+OPT+Shift is doing to try to find what flags to raise in the custom launcher   

     

    thanks again

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2012 12:19 PM   in reply to trzown-SLxMG9

    You are on a Mac, right? You will have to make sure that the permissions are properly set on the folder HD/Users/<yourusername>/Library/Application Support/Adobe/Adobe Illustrator CSx Settings. In OSX10.7.x and above the Library folder is hidden. Do a Google search for instructions to unhide it. Select the folder a do a Get Info. In the dialog box, change the permissions to read/write for everyone on the list and check apply to enclosed items. This should clear the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2012 1:01 PM   in reply to Steven::WebBees

    Having to trash the preference file every time I open up illustrator was super annoying but I found a solution that seems to work for me.

     

    Open illustrator with  cmd+opt+ctrl+shift to trash preferences.

    Create a new document. (file->new or cmd+n)

    ***important part**** switch the document profile to "Basic RGB"

    Create the new document with the new profile.

    Quit Illustrator.

    When you open illustrator back up you should be able to create a new document without the program hanging.

     

    Not sure why this works but beats having to perform finger contortions every time I need to use the program.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 1:38 AM   in reply to PROA Group

    This actually works, but seems to stop working after a restart. Is there a reason so few reports of this problem are found online?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 2:01 AM   in reply to wimdehert

    Not every user has the same problems. Some even don't have any problems at all.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 2:49 AM   in reply to Monika Gause

    You sound like a real person, Monika, and affiliated to Adobe, too. Please tell us if this issue is being addressed by Adobe, or if we're just out of luck to have bought a piece of software that doesn't work for us.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 3:03 AM   in reply to wimdehert

    I'm a real person, but not affiliated to Adobe. This mainly is a user-to-user forum and there are only few Adobe staff discussing here.

     

    If you need help configuring your system in order to rule out any issues that might be caused by your setup, you should start by telling the details.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 3:10 AM   in reply to Monika Gause

    Fair enough. Current system settings is Mac OS 10.7.5, 2,93 Ghz Intel Core i7 and 16 GB 1333 MHz DDR3. Illustrator CS6 on this machine is part of the upgrade from the CS5.5 Master Collection. So far, I tried the manual override with CMD-opt-shift, adjusting the library settings to allow permissions and a reinstall.

     

    The problem seems to occur when changing the new document profile to web, on which Illustrator invariably hangs.

     

    My setup could well be at fault. If this information allows you to pinpoint the problem, I'd be much obliged.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 4:58 AM   in reply to wimdehert

    Are you running your system in an admin account?

     

    As this includes this kind of settings problems: have you already tried setting up a new user account with admin privileges and run Illustrator from that account?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 5:42 AM   in reply to Monika Gause

    I'm running from an admin account, but I did what you suggested and created a new user account with admin privileges. That new account had no trouble creating a new document as a web document, so you were right about the settings problem. Is there any way you know of I can use this information to fix illustrator on my regular admin account?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 6:08 AM   in reply to wimdehert

    I'm sorry, no, I don't know of a way to even retrieve the settings of your new account. Let alone the differences between it and your existing account. Maybe they know it in some Mac-centric user forums.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 6:30 AM   in reply to Steven::WebBees

    Steven::WebBees wrote:

     

    Completly ridiculous from Adobe to lack the comptability with Mac OS 10.7.5

     

    [x] you haven't even read the latest posts.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 7:08 AM   in reply to Steven::WebBees

    I don't know if a Mac has the option to start an application as an Admin or not. On Windows, one can right-click and choose that option. That can cure a lot of ills with applications that need to set permissions.  Starting an application on Windows for such things is a one-time deal. Once the application is running, then one would exit and start normally.

     

    Take care, Mike

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 7:12 AM   in reply to Steven::WebBees

    Steven::WebBees wrote:

     

    Yes, I did...

     

    why should I make a new user on my system to get a feature that should be standard. I'm an admin on my system and would like to stay an admin.

     

    Have you ever watched "House, MD"?

     

    Well, that's what we're doing here: diagnosis. Setting up a clean account serves to rule out factors. If Illustrator works in a new account, then there is proof that the culprit is somewhere in your existing account.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 7:27 AM   in reply to Monika Gause

    Well, if I'm correct we've narrowed it down to permissions of the main admin account. (Thank you, Monika, BTW, for both addressing the issue AND finding at least the root cause). That said, I do agree with Steven when he states this deserves at least some attention from Adobe. This issue prohibits even basic functioning. As for now, we still haven't fixed anything, and suggestions are more than welcome.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 13, 2012 11:01 AM   in reply to wimdehert

    What Monika has been able to focus on are some common causes, damaged preferences, permissions, yet the underlying issue can be something directly related to the actual account that is damaged. When a new user account is working and you have already tried things such as preferences or addressing general permissions, then we would normally recommend a migration from one account to another. Apple has some documentation to help with transfering files to a new account: http://support.apple.com/kb/HT3309

     

    It's not that our software is incompatible with the version of OS but something became corrupted within the account itself. We try to address what we can, as well as some common causes as mentioned earlier but at this point creating a new admin account and migrating the files is the approach we would recommend.

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points