Skip navigation
Michael Sanora
Currently Being Moderated

Pre Compositions and Disappearing Objects

Jul 30, 2012 10:40 AM

Hello all. This is a tricky problem to explain. I'll try my best to articulate what's happening.


This project involves two stages of pre-comps before being loaded into the master comp. The steps are as follows.


Pre comp 1: A basic animation


Pre comp 2: Time Remapping


Master comp: Run for the duration of Pre comp 2


In one of my set ups, I have a .png image of a stack of up-right books (sketched and exported from Illustrator). Pre comp 1 contains an animation of the books falling over. It's one second in duration. I then load Pre comp 1 (1 second in length) into Pre comp 2 (5 seconds). Using Time Remap, I hold the inital frame of Precomp 1 for 2 seconds, let the animation play for it's normal length of time (1 second), and then hold the last frame for the remaining 2 seconds. Nothing tricky is done with the Time Remap (no expressions and no loops). I loaded Pre comp 2 into the Master comp. In the Master comp, I have Pre comp 2 positioned off screen. It moves into sight right as the books fall over and holds for two more seconds before I have it's opacity setting set to 0%. Everything worked great when I did the initial set up.

Here is the problem: On a different day, I reloaded my project and wanted to make some changes. I noticed that my Pre comp 2 was disappearing prematurely (i.e. before its opacity begins to decline from 100%). I checked Pre comp 2 thinking that my time remapping was incorrect. It turns out it worked just fine except that it would also disappear after about 3 seconds. There are no opacity setting changes in Pre comp 2, so I moved to Pre comp 1. In Precomp1, everything disappears prematurely at exactly the same time. I don't see any settings that are making these objects disappear. I've even checked my layer positioning to make sure everything was in order and it was.


I found that if I changed the opacity of the first layer in Pre comp 1 from 100% to 99% everything works correctly. I don't understand why this would fix the problem and don't understand what happened to cause it. Any ideas?


Thank you for whatever input you can offer.



  • Currently Being Moderated
    Jul 30, 2012 11:29 AM   in reply to Michael Sanora

    Is this in CS6? I'm thinking it may be a cache issue. Try purging all cache and emptying the disk cash if you have one.

    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 2:15 PM   in reply to Michael Sanora

    I'd love to see the project even without footage. The behavior should be the same.


    Please file a bug on this if it's repeatable in another composition.

    Mark as:
  • Currently Being Moderated
    Jul 31, 2012 1:08 PM   in reply to Michael Sanora

    I don't recall that you mentioned the amount of memory on your machine.  If it's in the 8 gig neighborhood, turn off multiprocessing in AE and give it a shot.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points