Skip navigation
Currently Being Moderated

Cannot disable snapping to artboard edges

Aug 2, 2012 5:43 AM

Tags: #illustrator #bug #snapping #artboard

I'm creating SVG icons, and due to the removal of SVG as an output format for Save for Web, I've switched to having a series of 16x16 artboards for my icons. Problem is, no matter what snapping features I disable, my artwork still snaps to the artboard edges when I move it around (regardless if I use the mouse or the arrow keys). This makes it impossible to align artwork to such a small artboard, and it also seems like pixel snapping shuts off, causing mis-aligned artwork.

 

Failed solutions

  • View menu >> Snap to Pixel disabled
  • View menu >> Snap to Point disabled
  • View menu >> Smart guide disabled
  • Transform palette >> Align to Pixel Grid disabled

 

Workarounds

  • Set Keyboard increment to 0.5px, which will round up to 1px in Pixel Mode. Keyboard nudging now behaves as expected, but mouse behavior is still erratic.
  • Use the Free Transform tool. It behaves slighly less erratically than the Selection and Direct Selection tool.

 

Steps to reproduce

  • Create a new document, 16x16 px
  • Verify that you're in pixel mode
  • Create a 14x14 px square
  • Try and position it in the center of the artboard using the mouse or keyboard increments
  • Observe the artwork snapping to the edges of the documents, or bypassing snapping altogether

 

Hope this helps.

 
Replies
  • Currently Being Moderated
    Aug 2, 2012 5:59 AM   in reply to Teetow1

    Turn ON Smart Guides and all other snap settings to OFF.

     

    Yup.. it's a bit backwards. You have to have smart guides active in order to prevent snapping to artboard bounds.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points