Skip navigation
kathleenmarie90
Currently Being Moderated

Hypertext in PDF Issue

Aug 3, 2012 10:55 AM

Tags: #error #pdf #toc #table #of #page #hypertext #contents

Hi all,

 

I am experiencing an error when trying to add hypertext to my FM Book. In the first iteration of this book, I had successfully added hypertext as to "click" and bring up a different page of the book, a page being a FM Document.

 

Now, I have added an addendum. When I added the Addendum to the table of contents, I intiated a hypertext navigaion as before, stating to navigate to the Addendum. However, when I export the Book to PDF, "Addendum" in the ToC is clickable, however, it does not navigate to the page.

 

I have checked and double checked everything. I even tried changing an existing, working, hyperlink, then changing it back exactly to how it was. After these changes (and change back) were made, the same thing occured: Clickable, but does not navigate in PDF.

 

FM, however, does retain the hyperlink addresses in the FM Book document. But the hyperlinks are not retained in any PDF export.

 

I can only concur that there is some sort of error when saving documents in FM. I have tried reinstalling FM, but to no avail.

 

Has anyone else experienced this issue?

 

Any suggestions as to where to continue troubleshooting this issue?

 

 

**Also, when I do [CTRL]+[ALT] and click on the new "Addendum" hyperlink in FM, it brings me to the Glossary even though it states "Addendum."    ... "Glossary," which is the link I changed then changed back, goes to the Glossary....however, does not go anywhere in the PDF.

 
Replies
  • Currently Being Moderated
    Aug 3, 2012 11:10 AM   in reply to kathleenmarie90

    > Now, I have added an addendum.

     

    Is this a component file of the .book, or something in such a file?

     

    > I intiated a hypertext navigaion as before ...

     

    And how was that done?

     

    Simple cross-references in Frame automatically become hyperlinks in the PDF, when the link and target are in the same PDF.

     

    If you are using Hypertext Markers, you're doing it the hard way, unless the Addendum is an external PDF. Getting that to work is bt trickier.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 1:02 PM   in reply to kathleenmarie90

    How are you creating the table of contents?

     

    If you use FrameMaker's Add > Table of Contents, in the dialog select Create Hypertext Links. When you create the PDF, select Generate Acrobat Data. Click PDF Setup and select Create Named Destinations in the Links tab. The resulting PDF should have clickable entries in the TOC.

     

    Van

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 1:07 PM   in reply to kathleenmarie90

    I tried creating a FM-generated ToC, and that has given me an abundance of error reports trying to do that. Perhaps I should just try to rework the document from scratch?

    FrameMaker's tools for creating tables of contents are very straightforward and should not generate errors. What kinds of errors are you getting? I would wait on creating the document (which document, the whole  book?) from scratch until you are sure you are using Frame's tools correctly.

     

    Van

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 1:21 PM   in reply to kathleenmarie90

    You'll need to fix those book errors up before you try updating the book. Make sure your .fm files are all fully accessible & not locked. Set the Show/Hide settings on all parts of the book to override the individual document settings & then fix those unavailable fonts. If you don't care about them missing, just switch off the "don't remind me" flag - open the offending files; save them; then turn the option back on again. FM should have done a font substitution for you.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 4:34 PM   in reply to kathleenmarie90

    > ... it says my "Master Pages Contain No Mapping" ...

     

    Are you electing:

    [*] Apply Master Pages

    when you Update Book?

     

    If so, don't, or alternatively, do an AMP in each file once, first. The MasterPageMappingTable doesn't (and the Ref Page it's on) don't exist by default. You have to create them by doing an AMP, which throws an error on the first try, and that error is apt to be sufficient to send a book Update off the rails.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points