Skip navigation
Sorack01
Currently Being Moderated

Stopping from command line help

Oct 28, 2009 10:28 AM

Hi all.

I am running fmlecmd.exe to start from a batch file. Works great. But I am following the instructions on getting a batch file to stop the application.

It's not working.

Instructions:

"When the session is streaming to a server, use the format fms_URL+stream_name for fmle_UID. For example, to stop an encoding session that is running on the server fms.myserver.com with the application named live, and the stream named livestream, you would enter the following: FMLEcmd /s rtmp://fms.myserver.com/live+livestream

Note: When using the /s parameter, the stream_name portion of fmle_UID cannot contain a plus sign (+), because + is used as a delimiter in fmle_UID."

 

I can't find where my 'application' name is to enter into the path. Here is what my stop.bat file looks like:

"C:\Program Files\Adobe\Flash Media Live Encoder 3\FMLECmd.exe" /s rtmp://p.ep9729.i.akamaientrypoint.net/EntryPoint/live/WNEP-FLASH-LIV E-1@9729

 

Here is the only info I can find: (no 'application' name, so the above stop.bat file has /live/ in the path)

 

Stream to Flash Media Server :-

FMS URL    : rtmp://p.ep9729.i.akamaientrypoint.net/EntryPoint

Backup URL  : rtmp://b.ep9729.i.akamaientrypoint.net/EntryPoint

Stream Name : WNEP-FLASH-LIVE-1@9729

 

Where do I find the application name to enter into the path?

Thank you for any help in advance.

Chris

 
Replies
  • Currently Being Moderated
    Oct 28, 2009 10:32 PM   in reply to Sorack01

    Chris,

     

    Your FMLE UID is wrong.

     

    For your FMLE session, the fmle uid should be "rtmp://p.ep9729.i.akamaientrypoint.net/EntryPoint+WNEP-FLASH-LIVE-1@9729"

     

    Hence the command you give to stop the FMLE session should be :-

     

    "C:\Program Files\Adobe\Flash Media Live Encoder 3\FMLECmd.exe" /s rtmp://p.ep9729.i.akamaientrypoint.net/EntryPoint+WNEP-FLASH-LIVE-1@9729

     

    Please try this and let us know if you face any more problems.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 4:16 PM   in reply to Vineet Mahajan

    I am having problems stopping from a batch file as well. I can start from a  batch file just fine, but the batch file to stop just doesn't work. The strange thing is that I can open a command line window and enter the exact same text and get the encode to stop (so I know I'm entering the UID right), but as soon as I put it into the batch file it doesn't work. Ideas? FMLE is streaming multiple files at the same time, but no DVR and no archiving.

     

    FMLE 3.2 on Win XP (SP3).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 4, 2012 10:00 AM   in reply to gstrudler

    I am experiencing the same issue above.

     

    I can start, stop, and unregister streams from the command line with no problems. If I then check FMLEcmd /dvrstate I get the correct results.

     

    However, if I put start, stop, and unregister in a BAT file, the session is not unregistered and I have to either delete the fmesessions.dat file to clean up the error OR I have to rerun the same uid, start, stop, and unregister it from command line.

     

    Just to be extra clear - the session can be stopped from the BAT file. The person above might think that just because an uid appears in the registry that the stream is running and that is not the case.

     

    I am running all of my BAT files as Administrator so I don't think permissions is the issue. This seems like a bug, but I dont know the back end rules about how fmesessions.dat and OsLaunch.dat work together. It seems like the OsLaunch is correct, but fmesessions is not. FMLEcmd is reading from fmesessions.

     

    Any thoughts on how to successfully unregister a uid from a BAT file?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points