Skip navigation
Currently Being Moderated

PE10 will not display video, audio only (see details).

Aug 3, 2012 12:00 PM

Tags: #video #drivers #didplay #audio-no

When starting up PE10, after not having used it in about 4 months, I received an error message that read approximately:


"We have detected an incompatible display driver--please update. Intel Bear Lake B 1.4.0 - Build"


When I went to an Intel download site I was unable to download this driver.


I have noticed no problems other than with PE10.


In any case, PE10 starts up, but when I bring up a finished project from the past, it will play audio, but not video. I am dead in the water.

  • Currently Being Moderated
    Aug 3, 2012 12:26 PM   in reply to DrDtMM

    What happens when you try to download the newer driver from the Intel Web site?


    What are your browser's security settings?


    Do you have a software firewall running?


    Even a simple OS update can render a display driver obsolete. PrE (and some other programs, but not most), rely heavily on the display driver to fully function. That is why companies, like nVidia, and ATI/AMD issue driver updates at least monthly.


    Good luck,



    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 3:17 PM   in reply to DrDtMM

    What is the model of your ATI/AMD video card?


    What is the number/date of the installed video driver?


    Good luck, and please let us know a bit more.



    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 7:28 AM   in reply to DrDtMM

    There is several discussions on this problem on this forum :

    search by keywords : incompatible display driver

    One solution (which works in my case with Elements 9) is to delete the file

    badDrivers.txt, in directory C/ProgramData/Adobe/Premiere Elements/10.0 (or version number)

    Restarting Prel after this action works for my PC Vista. And I need to do this once or twice a year.

    It seems to be related to windows updates, according to Steve Grisetti, one of the experts on this forum.

    Bon courage

    JM from France

    Mark as:
  • Currently Being Moderated
    Aug 9, 2012 9:13 AM   in reply to DrDtMM

    Did you try to delete this badDrivers.txt file ?

    For many users this solved the issue, you can check in this forum.

    Bon courage.

    Mark as:
  • Currently Being Moderated
    Aug 9, 2012 11:27 PM   in reply to DrDtMM

    If you look at the content of this  file , you will find 'true' or 'false'.  So it's a switch used by

    PREL when starting the session I think.

    What changes this content is not clear, and apparently not easy to solve, if you consider this problem

    is following PREL versions.

    If you look at your BadDrivers file, you will see it has been rebuilt with a good value.

    I am happy this worked for you, it's the most important. I tell my own experience on this forum, because I

    was very glad to have this method as an answer on my first question, 1,5 year ago !


    JM from France

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points