Skip navigation
fxcomputers
Currently Being Moderated

Flash Builder 4 Run Problem

Dec 15, 2010 11:49 AM

When I Run a project in FB4 sometimes I have this weird problem where the changes I have made do not show up in the project I have just ran.  I can do something as simple as changing a label or complex as changing some AS code and it still has this problem.  I am not sure if it is random or what the issue is.  Has anyone else encountered this or have an answer as to why it might be happening?  Thanks in advance!

 
Replies
  • Currently Being Moderated
    Dec 15, 2010 11:59 AM   in reply to fxcomputers

    I've seen this too occasionally, seems to be a bug in Flash Builder. Even a full Refresh / Clean & Build All doesn't always fix it. Have to exit, restart Flash Builder and do another Clean & Build All.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 1:41 AM   in reply to fxcomputers

    I had a similar problem, for which I post the link below, but I never found a solution, so please don't expect too much insight from reading the discussion.

     

    http://forums.adobe.com/thread/601971?tstart=0

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 11:38 AM   in reply to TomBurgundy

    I occasionally run into this as well. Very frustrating.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 23, 2010 4:06 AM   in reply to John Wolfsteiner

    Is the SWF hosted on a web server? It may be getting cached by the browser.

     

    Can you post your Flash Builder log the minute after you run into this problem the next time? The log is at workspacedir/.metadata/.log

     

    Usually when Flash Builder performs an incremental compilation and something goes wrong, "An internal build error occurred" will appear in the Problems view.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 10:13 AM   in reply to Anirudh Sasikumar

    I've recently been experiencing an abnormal number of occurrences of this error and Google directed me to this thread. In response to your question, here's the Error Log message that gets added when the "internal build error" occurs:

    null

    Error

    Mon Aug 06 13:11:03 EDT 2012

    Uncaught exception in compiler

     

    java.lang.NullPointerException

              at com.adobe.flexbuilder.project.ui.utils.ANE.AppXMLFileANEExtensionHand ler.addToAppXmlFile(AppXMLFileANEExtensionHandler.java:74)

              at com.adobe.flexbuilder.project.ui.utils.ANE.AppXMLFileANEExtensionHand ler.addToAppXmlFile(AppXMLFileANEExtensionHandler.java:46)

              at com.adobe.flexbuilder.project.ui.utils.ANE.ANEController.applyWorking Copy(ANEController.java:720)

              at com.adobe.flexbuilder.project.ui.utils.ANE.ANEController.projectIsBui lt(ANEController.java:904)

              at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.in formProjectBuildListener(FlexProjectBuilder.java:156)

              at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.bu ildItem(FlexProjectBuilder.java:616)

              at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.bu ild(FlexProjectBuilder.java:382)

              at com.adobe.flexbuilder.project.compiler.internal.FlexIncrementalBuilde r.build(FlexIncrementalBuilder.java:187)

              at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java :728)

              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)

              at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager .java:199)

              at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager .java:239)

              at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java :292)

              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)

              at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager .java:295)

              at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildMan ager.java:351)

              at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java :374)

              at org.eclipse.core.internal.resources.Workspace.buildInternal(Workspace .java:513)

              at org.eclipse.core.internal.resources.Workspace.build(Workspace.java:42 2)

              at org.eclipse.ui.actions.GlobalBuildAction$1.run(GlobalBuildAction.java :180)

              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

     

    My particular project is a Flex Mobile project with a couple of ANEs. I have to restart Flash Builder every couple of times I launch my project though because of this type of error.

     

    Any ideas? Could I provide you with any more information to help track down the problem?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2012 8:51 AM   in reply to Brian Vaughn

    I am experiencing the same exact error as Brian above. Does anyone have any clues as to what's wrong here? It's only happening when I try to compile an AIR application for mobile development, and I'm running FB 4.6. I've tried using different versions of the Flex/AIR SDK to no avail.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points