Skip navigation
Currently Being Moderated

Copy pasting keyboard problem on MacBookPro

Aug 3, 2012 7:16 AM

Hi all,

I was wondering if anybody else has experienced the following problem. On my current and previous MBP, in Fireworks in 80% of the case where I hit CMD+v (to paste something I've copied) there is no result. When I start moving something I always end up moving the original object, because I haven't pasted anything. I always thought this was probably a result of ramming on those keys made my keyboard somewhat inresponsive, but guess what, it's still the same on my new rMBP and whil discussing this with colleagues I found out some of them have the same annoying problem.

I'm so used to doing this that it has become hard for me not to hit cmd+c three times and after that press cmd+v really hard. Even in different programs where it causes me to paste something more than once.

Anyone else experiencing the same problem or am I and my collegues just seeing something that isn't there?

 
Replies
  • Currently Being Moderated
    Aug 3, 2012 12:00 PM   in reply to Pieter070

    I wonder if the copy-and-paste problem is actually an issue with not having successfully selected the item in question. I've had occasional copy-and-paste problems, but nothing specific to Fireworks. The trackpad on my MacBook is set to one-finger "Tap to Click" and "Dragging", and this causes major issues with cursor placement within text (on Snow Leopard, anyway). Occasionally, it may also cause me to think I've selected something that I haven't.

     

    There's shouldn't be any need to trigger a Copy command multiple times, or ram the keys when using the Paste command. As an alternative within Fireworks, you could try the Clone command (under the Edit menu).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 12:45 PM   in reply to Pieter070

    You're not the only one. I've seen the same thing, and to me it appears to happen randomly. One thing I do know about copying from Illustrator to Fireworks (which is not your question) is that if the item you're trying to copy is outside of an Illustrator artboard it won't paste into Fireworks.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 1:35 PM   in reply to Pieter070

    Pieter070: I wasn't suggesting your problem was due to "Tap to Click", per se, just explaining my own observation that when I've experienced a copy-and-paste problem, it's often been a selection error. Also, I couldn't quite tell from your original post whether the problem was exclusive to Fireworks or not. (Apparently, it is.)

     

    Keep in mind that the Clone command can be triggered by a keyboard shortcut, too.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 3:21 PM   in reply to Pieter070

    Yeah, and if any Fireworks developers see this, I can definitely verify that sometimes I have to press twice in order to paste the item.

     

    Repro steps:

    Select an item (a group of two text fields and a graphic in my case)

    cmd+c to copy

    cmd+v to paste

    wait several seconds, nothing happens

    cmd+v to paste again, and then it works.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 11:06 AM   in reply to Petros_

    So Pieter070, you're saying that the Paste command (Cmd+V) fails 80% of the time in Fireworks. You also mention that you often hit the Copy command (Cmd+C) up to three times, to avoid the problem. Meanwhile, Petros is verifying that he sometimes must press twice to paste an item, perhaps even waiting in-between presses (and also mentions a pasting problem with Illustrator).

     

    It sounds like the problem is with the Paste command, not the Copy command. The reason I say this is that if the Copy command were failing, you'd likely find yourself pasting previous items from the Clipboard, but that's not been described here.

     

    Neither of you has specified your operating system(s), or what versions of Fireworks are being affected, which is good info to include. It may be time for each of you to file a bug report with Adobe:

     

    https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 12:00 PM   in reply to Pieter070

    Entered a bug report for the non-Illustrator-related copy/paste bug.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 12:25 PM   in reply to Petros_

    @Petros: Sounds good!

     

    @Pieter070: Man, that is a long list of versions and operating systems! It's weird because I haven't experienced this problem in CS5/6 on Snow Leopard... but it's something I'll watch out for.

     

    Rethinking my previous statement, I suppose it could be a problem with the Copy command if the application was taking an unusually long time to process that command and that was causing the delay in the Paste command. But then again, I'd kind of expect it to paste a previous item from the Clipboard in the meantime... So I still suspect the Paste command. I wonder if the problem occurs when pasting an old item (without copying first).

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points