Skip navigation
Currently Being Moderated

stream will not play in browser

Aug 6, 2012 7:22 AM

Whenever my web page attempts to play a live stream using the Strobe Media Player, the video always returns an error msg. The F4M document contains errors. Error parsing f4m file.

The F4M file is correct.

 

If I look in my C:\Program Files\Adobe\Flash Media Server 4.5\logs\edge.00.log file.

I get these two log entries each time a player attempts to view the live stream.

 

2012-08-0610:10:035432(w)2641213Connection rejected by server. Reason : [ AccessManager.Reject ] : [ code=403 need auth; authmod=adobe ] :-

 

 

2012-08-0610:10:035432(w)2641213Connection rejected by server. Reason : [ AccessManager.Reject ] : [ authmod=adobe ] : ?reason=needauth&user=web&salt=KxMAAA==&challenge=j3MAAA==&opaque=p3M AAA==-

 

 

I have a crossdomain.xml in the webroot of the Flash server that permits the Web server hosting the Strobe Media Playback player to access the video stream.

 

Thanks,

Dave

 
Replies
  • Currently Being Moderated
    Aug 7, 2012 1:50 AM   in reply to Mr.Dave

    Edge logs don't make sense in case you are viewing the HDS stream (f4m request). Only rtmp connections goes through the auth module inside FMS.

     

    Can you please share the F4m url. Are you sure you are getting these logs at the same time you tried to access the stream(F4m).

     

    Thanks

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points