Skip navigation
Currently Being Moderated

delete datasource failed

Aug 8, 2012 12:30 AM

Hi,

 

I installed CF9 without a licence (developer Ediition) and created some datasources

using the Oracle Driver. Everything works fine.

 

Then I updated CF9 with a Licence Key (CF9 Standard Edition) and now the datasources are not running,

because Standard Edition does not have the Oracle Driver. I try to edit or delete the datasources, but I get a server error 500.

 

Can I delete the datasources manually?

 

Environment:

CF Standard 9,0,2,282541

Windows Server 2008 R2

 

regards Claudia

 
Replies
  • Currently Being Moderated
    Aug 8, 2012 5:27 AM   in reply to biene22

    Yes. You can manually edit the neo-datasource.xml file found in the cfusion/lib folder.

     

    They will be listed individually in that file starting with:

     

    <var name='DATASOURCE NAME'>

    < then a series of <var> tags with the connection details>

    </var>

     

    You can just delete the one that is causing you issues.  Also, there may be a neo-datasource.bak file in there with the original settings.  Open that file and look to see if your offending datasource is in it.  If not, rename it to neo-datasource.xml  and rename the other to .old or something else.  Restart Coldfusion and the new datasource information should be picked up.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2012 5:32 AM   in reply to RobertAOwen

    Sorry, I gave you a bad location for that xml file.  In Coldfusion 9 Standard the neo-datasource.xml  file is in the lib folder in the root of the installation location.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points