Skip navigation
Yves Apel - IC
Currently Being Moderated

Scrollable content inside an MSO bug

Aug 10, 2012 1:05 AM

Hi,

 

after some previous errors with the new v22 tools, I was now able to finaly continue my tests on my project.

But now, scrollable content inside an MSO is shifted by 15px (iPad 1-2)/30px (iPad 3) to the right.

 

Here are some screenshots:

2012-08-10_09-57-44.png2012-08-10_09-59-13.png

 

 

I have created new folios with the latest version of the plugins and InDesign CS6. The folio is v20!

 

Does anybody have the same problem? Please help

 

–Yves

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Aug 10, 2012 2:37 AM   in reply to Yves Apel - IC

    Hi, Yves!

     

    Does it make a difference, if you are doing PDF, PNG or JPEG folios?
    Can you see the same bug if using InDesign CS5.5?

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 3:13 AM   in reply to Yves Apel - IC

    hi... also just tested the different formats... PDF, PNG, JPEG.... Automatic.... no difference

     

    i dont have CS 5.5 anymore!!!... or the time for these tests!!!

     

    ADOBE DO SOMETHING!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 4:31 AM   in reply to Yves Apel - IC

    @Yves && toutoungi:

     

    I'll do some tests with MSOs and the v22 Folio Builder (v20 folios) together with CS5.5 and Overlay Creator v20 in the afternoon.

     

    I still hesitate using CS6 for production purposes until at least v8.0.1 is out.
    But I'm sorely tempted to do so…

     

    Though this totally seems to be a DPS issue…
    Just building a test scenario with an MSO and scrollable frames, that consist of table objects, scrolling direction: vertical.

     

    Just a question to Yves:
    Is the width of your scrollable frame container object smaller than the individual state in your MSO?
    Maybe you can provide a screen grab of your InDesign page where all frame borders of all objects are selected or made visible…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 5:05 AM   in reply to Laubender

    hi.

    thanks. looking forward to hearing from you about that.

    like u said, this must be a DPS related issue... before the update i only had very bad performace issues on the new and old iPad(2).

    with the update i just have more problems to deal with.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 5:32 AM   in reply to toutoungi

    @Yves && toutoungi –
    first tests with a really simple MSO and scrollable frames inside all states controlled by a button outside of the MSO are showing that there is NO shifting of contents.


    My testing configuration:

     

    InDesign CS5.5 v7.5.3 Build 333

    OSX 10.6.8

     

    MacBook Pro (MacBookPro5,1 from the end of 2008)
    iPad3

     

     

    Scenario 1:

    Folio: JPEG Maximum Quality

    Folio size 1024x768
    Folio Page Direction: horizontal only

    No of articles: 1 (no of pages: 1)

     

    Scenario 2:

    Folio: PDF

    Folio size 1024x768

    Folio Page Direction: horizontal only

    No of articles: 1 (no of pages: 1)

     

    Scenario 3:

    Folio: PDF

    Folio size 1024x768

    Folio Page Direction: horizontal and vertical

    No of articles: 1 (no of pages: 1)

     

     

    Tested in Adobe Content Viewer on the Mac

    Tested in Adobe Content Viewer on the iPad3

    (via USB cable attached)

     

    The ACV on the iPad is the one that was freely released along with DPS v20.

     

    Adobe DPS version:

    plug-in version

    7.5.5.20

     

    folio format version

    2.0.0

     

    plist version

    1.3.0

     

    ExtensionBundleVersion

    12.3.1.20120730_m_695362

     

     

    Hope, that helps…

     

    Uwe

     
    |
    Mark as:
  • Bob Bringhurst
    4,651 posts
    May 29, 2007
    Currently Being Moderated
    Aug 10, 2012 6:05 AM   in reply to Laubender

    Yves, do you have Use Document Position selected in the Overlays panel?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 6:11 AM   in reply to Bob Bringhurst

    Hi Bob,

    im also having the same problems with MSO since the last update. I am not using document position. Its set to top left. Also its not only the content of the scrollable frame that is shifting. The whole MSO is shifting except for the frame in which the scrollable content is placed in - the content is shifted.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 6:21 AM   in reply to toutoungi

    Hi bob,

    just changed the settings to "Use Documet Position". Still shifting.

     

    The shift is not only in Scrollabel MSO's - i have similar shift problems in MSO with simple buttons that change the staus of the MSO. In that case it shifts one of these buttons up 6 px when you tap it and back down when u go to the next status (in some of the MSO's with 4 status)

     

    These MSO's all used to work fine untill the update - CS6 with the latest DPS updates (08.08.2012) on both a windows PC and a Mac.

     

    Versions:

    12.3.1.20120730_m_695362

    8.0.8.22

     

    Hope you have some infos for us...

     

    thanks

    mo

     
    |
    Mark as:
  • Bob Bringhurst
    4,651 posts
    May 29, 2007
    Currently Being Moderated
    Aug 10, 2012 6:22 AM   in reply to toutoungi

    Is this happening on both the iPad viewer and the desktop viewer?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 6:24 AM   in reply to Bob Bringhurst

    hi

    it is... or beter said it was.... the last test i could not upload...

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 7:05 AM   in reply to Bob Bringhurst

    @Bob – for my tests in InDesign CS5.5 where all went fine for "Scrollable Contents" * inside an MSO I used:

     

    "Vertical scrolling only" * and
    "Document Position" *

    selected,


    "Scroll bars visible" *
    not selected.

     

    *I'm on the german tools, so cannot tell exactly the right terms…

     

    The following screen grab shows:

    1. the frame for "Scrollable Contents" is selected

    2. the green frame is just a position indicator in the background of the page

    3. the huge frame not filled with color is the MSO

    4. the cyan frame is the button that controls the MSO

     

    ScrollableContents.png


    Hey, I really don't mind, but don't confuse me with Yves ;-)

     

    I will do more tests with scrollable frames, where the width of the contents is smaller than the container frame itself.
    Maybe that could be the culprit?

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 7:37 AM   in reply to Yves Apel - IC

    @Yves:

    Bob in #7  replying to me (#6) and addressing you ?!

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 7:58 AM   in reply to Yves Apel - IC

    I think, I give up testing for a  bug that is not there (CS5.5)…

     

    @Yves – what you could try is exporting your InDesign CS6 file to IDML, reopen it, building a new Folio and testing again.
    In one strange case, I cannot recall exactly (it was a file by one of my students), that was the remedy for a problem…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 8:22 AM   in reply to Laubender

    hi.

    just tried using "go to next status" and "go to prevus status"...

    still the same issue. On both the new iPad and the iPad 2.

     

    I use automatic and not PDF to export the folios although it is not recomended. But with PDF format i had major problems already before the updates. That is a seperate case that i have already filed 2 weeks ago with the european support team.

     

    Bob, have you been able to reconstruckt the problem?

     

    Im going to continue testing....

     

    ciao

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 9:40 AM   in reply to toutoungi

    nothing seems to be working with these MSO anymore... Is there way to avoid these MANDATORY UPDATES!!!! or can i at least there a way to re-install the older version!!!!!

     

    I can basicly throw the last 4 weeks of work in the trash!

    i am definalty not happy with this!

     

    THANK YOU ADOBE!!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 11:31 AM   in reply to toutoungi

    Toutoungi,

     

    You can set your folio version in the Foilo Builder Panel to v21, which will give you folio output that matches the previous version.

     

    For this specific shifting issue, what document units are you using for the InDesign document? Are you in points/picas or pixels?

     

    Neil

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 12:16 AM   in reply to Yves Apel - IC

    @Yves – hm. You tested in InDesgn CS5.5 and the bug was still there… Not good at all…

     

    Let's break that down to a reasonable test case.

     

    Note (from my knowledge of scripting overlays):

     

    1. To "inject" an overlay effect to a page object a method is used that is exactly or is similar to apply "labels" with the JavaScript method insertLabel("keystring","valuestring") to that object.
    2. You cannot see thiese "labels" in the UI (unlike the script labels you can apply with the UI; that's a totally different thing)
    3. The "labels" stick to the object until you choose to click the "trash bin" in the "Scrollable Frame" palette of the Overlay Creator.

    4. The Folio Builder is reading out the "valuestring" part by extractLabel("keystring") and acting upon the values to build the overlay effects

    5. The key/value pairs still stick to the object even when exported to IDML or to IDMS.

     

    Trying a solution for InDesign CS5.5 assuming the bug is not there:

    Note: This is highly speculative or are  assumptions, I  still have to verify:

     

    1. If you open the IDML exported from InDesign CS6 in CS5.5 the overlays do not work anymore, because InDesign CS5.5 works with different key/value pairs, even if you work in the same version of DPS of FolioBuilder and OverlayCreator

    2. Important here: the key/value pairs are still there, they were never trashed!

    3. If you apply new key value pairs (did you use the "trash bin" of your overlay panel in InDesign CS5.5 or CS6 before? If not:) you send new key/value pairs of properties to the object (the scrollable frame) on top of those which are already there (from the toolset of InDesign CS6)

     

    4. Now, and this is really a wild guess, DPS on CS5.5 is reading both and acting on both: the old key/value-pairs (CS6) and the new ones (CS5.5)

     

    => The bug is still there!

     

    Conclusion for a new test case with a single MSO:


    CS6:

    Use the "trash bin" of your "Scrollable Frame" Palette to strip all key/value-pairs from the container frames of the scrolling contents.

    Then export that MSO to IDML or try IDMS (Snippet)

     

    CS5.5

    Open the IDML or place the IDMS,

    apply the appropriate features with your "Scrollable Frame" Palette

     

    If the bug is still there, we can make the wake assumption, that the bug is also present in CS5.5 DPS FolioBuilder v22.

     

    I say "wake", because it could be that using the "trash bin" does not strip out all possible "key/value" pairs of the object, but only a few, so that the Overlay Creator cannot recognize the object as an overlay.

     

     

    If you like, you can send me a test case of a not working single MSO in InDesign CS5.5 (an IDML or better a IDMS snippet) by E-Mail. Strip out all text values out of the MSO, if you like.

    I will test the thing in my own configuration and will look more deeply into the IDML for "key/value" pairs present.

     

    Another observation with an older version of DPS (I think it was v19):
    I had a crash with InDesign CS5.5 when using tables in an complex MSO. But that crash is not happening any more with the newer version (v20 and above). Still – your bug could be triggered by using tables with certain properties (maybe cell styles). But this is really a wild guess…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 12:28 AM   in reply to Neil Enns - Adobe

    tried that also--- v20, v21, and v22 - although 22 only on the desktop ACV.

     

    My publication also has over a hundred MSO's that have all been approved by our client! changing everything is not an option!

     

    here some screen shots of how it should be (in indesign):

    in indesin - 1.png

    in indesin - 2.png

     

    and here is what they look like in the content viewer (desktop):

    in Desktop ACV - 1.png

     

    in Desktop ACV - 2.png

    Note that the Button is shifted to the right. The content of the scrolable frame is also shifted to the right, but the scrolable frame itself is the right position. The content of the scrolable frame extrudes out of the frame it is in on the right side. See next screen shot:

     

    in Desktop ACV - 3.png

     

    This started happening after the last manditory update.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 12:57 AM   in reply to Neil Enns - Adobe

    Hi Neil,

    to your question about the units - im using pixel as the document units. Have always had that setting...

     

    Are we the only two people (Yves and me) having this problem?

     

    One more thing... that no one has mentioned - the Bug is not related to scrolable frames. Normall scrolable frames funktion properly. It only occurs in MSO regardles of them being scrollable or not. I did some test with empty frames and there was no problem... as soon as i added text in to the buttons (open and close) that controll the MSO's the error occured again.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 1:24 AM   in reply to toutoungi

    @toutoungi – interesting! Are the buttons inside or outside the MSO?

     

    I will test again with CS5.5 with text inside the buttons…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 7:04 AM   in reply to Yves Apel - IC

    Sorry to hear that, Yves. It is really bad that this is introduced with the

    newest tools, and there is no way to go back with cs6, yes, that separation

    was introduced to et around all this.

     

    Looks like what Neil was suggesting saving as v21 is not working either.

     

    Somewhere above you mentioned to use a 2048px indesign document. I am

    guessing that this might break the producer tools who are responsible for

    downsizing and folio creation. Is the same happening if you scale down the

    document yourself?

     

    If course, this might not an option as well because you cannot scale down

    an indesign document the simple way.

     

    —Johannes

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 8:12 AM   in reply to Yves Apel - IC

    @Yves – what can I say, your files are working in CS5.5. For my configuration see post #6 in this thread.
    An E-Mail with the working folios (2048x1536px AND 1024x768px) is sent to you…


    Of course, I had a missing font error after opening the IDML from you (CS6) and did  not substitute with the original fonts, but that hardly could be the culprit…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2012 3:25 AM   in reply to Yves Apel - IC

    Hi all.

    after a few more tests... beter results but not fixed...

     

    I converted all text elements in buttons to outlines (vectors) and the result is that the Shifting is now -1px!

     

    I am using v20 at the moment (CS 6 and the last manditory DPS update)

     

    like i said beter but not FIXED!

     

    @ Uwe - the Buttons are inside the MSO's.

     

    I hope ADOBE gets a HOT FIX for this problem!!!

     

    This is going to put a lot of us in troubel! I have a major presentation on Wednessday and the realeas a few days after that!!!

     

    @ Niel (or anyone from Adobe) - When can we expect a FIX!

     

    talk to you all soon!

    mo

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2012 5:55 AM   in reply to Yves Apel - IC

    @Yves – I'm sure you tested my folios that came along with the IDML, and they are showing no shifting…

    That's very strange…

     

    So, I think we have to look for differences in:

     

    1. Installed 3rd party PlugIns or Extensions on your side; I have some installed, but obviously they do not affect DPS:

    In-Tools "Create Hex Swatch" and "ScriptBay" and a not activated version of Rorohiko's "FramedWeb" together with the free APID ToolAssistant.

     

    Oh, and btw. according to Adobe Extension Manager my Digital Publishing plugIn of CS5.5 is on version 7.2.9.

     

    2. Other system differences (I'm on a MacBook Pro with OSX 10.6.8), what is your OS exactly?

    3. I'm using the German version of CS5.5 7.5.3 build 333, you are working on a different language version…

     

    Hm, You think it's the installation of InDesign CS6 together with CS5.5. Currently I have CS6 8.0.0 Trial installed, but still not used that, so I did not installed the latest DPS tools for InDesign CS6…

     

    Could that really be the culprit?
    If that's true, I really should not use InDesign CS6 for DPS workflows until the bug is fixed…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 1:44 AM   in reply to Yves Apel - IC

    @Yves – Hm. For InDesign CS5.5 I had v20 of DPS installed (both Folio Builder and Overlay Creator), switched to other tasks not involving DPS, did not updated when DPS v21 came out and finally installed DPS v22 (Folio Builder only).

     

    In that period of time until now I did not uploaded any folio to my acrobat.com account or even made connection through folio builder to acrobat.com. I  never checked the "Angemeldet bleiben (Stay logged in ??)" button of the login procedure in Folio Builder…

     

    Currently my focus of work is not on DPS, but on re-designing a "paper-version" of a magazine and scripting a catalog production workflow. I did a bit scripting of creating MSO workflows regarding DPS, but that did not involve using acrobat.com. The last weeks I always tested with local folios and the iPad3 connected by USB.

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 1:54 AM   in reply to Yves Apel - IC

    @Yves – what's really crazy, that not more people see this bug with MSOs. At times it seems it's only toutoungi and you…

    And totoungi had a different amount of shifting pixels than you.

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 2:01 AM   in reply to Laubender

    Hi Guys.

    i spoke with support yesterday. they said they had a few other customers with the problems. They also said the only "work around" at the moment was to use CS5. The tests i did looked sucessfull when i converted all text in buttons to vectors the shift went from 6-7px down to 1px. But as soon as i applied these changes to the rest of the document, the problem came back...

     

    I am basicly sitting here with my team converting all our documents (over 200) back down to CS 5.5!!! and thats not all... a lot of interactivity seetings are not working anymore - need to check every single thing and with most they did not convert properly!

     

    We are very HAPPY right now!!!

     

    mo

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 2:45 AM   in reply to toutoungi

    @toutoungi – was it CS5 or CS5.5 they recommended?
    And how about the bug experience Yves had even in CS5.5 (as you can see in his little movie at #29)?

     

    Note: in converting a CS6 file to CS5.5 or CS5 by using IDML you do not get any DPS functionality with overlays.
    This is due to the different scripting labels.

     

    I digged deep in the IDML Yves sent me for testing.

     

    Labels ("Keystring","Valuestring") applied to a Scrolling Content frame in CS6 by Yves after opening the IDML in CS5.5:

     

    kAdobeDPSInteractivity_ScrollDirection    0
    kAdobeDPSInteractivity_WebViewOverlayContainer    false
    kAdobeDPSInteractivity_ShowScrollIndicators    true
    kAdobeDPSInteractivity_UseInitialDesignView    false
    

     

    I don't know, but I think Yves tried to reset all values in the Overlay Creator panel and used the "trash bin" icon before sending over the IDML.
    But that did NOT eliminated the key/value pairs but set their properties differently.

    C'mon Adobe, you could do better! Using the "trash bin" for overlay features should result in removing all relevant key/value pairs and not in setting some values in a different way…

     

    I then applied new values to the Scrollable Content frame in CS5.5 and got the following key/value pairs:

     

    //Comment by Uwe Laubender:
    //AFTER reapplying the overlay in CS5.5:
    //Keystring<tab>Valuestring
     
    kAdobeDPSInteractivity_WebViewOverlayContainer    false
    kAdobeDPSInteractivity_ScrollDirection    0
    kAdobeDPSInteractivity_ShowScrollIndicators    true
    kAdobeDPSInteractivity_UseInitialDesignView    false
     
    Type    WebView
    ScrollableFrameScrollDirection    2
    SS_WebViewOverlayContainer=    true
    ScrollableFrameUseInitialDesignView    true
    ScrollableFrameShowScrollIndicators    false
    

     

    The last five key/value pairs define the overlay functionality in CS5.5, the first four are leftovers from CS6.

     

    So, if you will open the CS5.5 file  in CS6 the first four key/value pairs define the overlay. Since you can hardly spot them in CS5.5 or even delete them alltogether or cannot change them so easily in CS5.5 (not without scripting or exporting to IDMS and strip them out with a text editor) you got something like a "time bomb" here, exploding when you like to work on in CS6 in the future… You can see that effect in the movie by Yves in #29.

     

    That is the biggest drawback when "labels"  are used for triggering effects and there is no mechanism to really delete them altogether!

     

    IMPORTANT:

    We can conclude now, that you cannot retain DPS overlay functionality when you switch between CS6 and CS5.5, even if you have the "same" tools installed.

     

    So it's definitely a very big decision to use inDesign CS6 over CS5.5:

    you cannot go back without loosing functionality!

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 4:01 AM   in reply to toutoungi

    @toutoungi – Did customer support tell you, what exactly causes the issue?

    Before proceeding with installing anything new or updating or signing in, I'd like to know, if I possibly will be affected, too.

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 4:07 AM   in reply to Laubender

    Hi Uwe,

     

    im using CS 5.5 - version 7.5.3.

     

    Like i said i have to do all Overlay setting again.

     

    Grüße

    mo

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 4:10 AM   in reply to Laubender

    @ Uwe

     

    Support said they are working on it - HIGH Priority! No timeline - will inform me....

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points