Skip navigation
Currently Being Moderated

Cross Refs between chapters not hyperlinked (RH10/FM11)

Aug 9, 2012 8:34 PM

Tags: #css #robohelp #framemaker #styles #mapping #cross-references #framemaker_11 #robohelp_10

This week I installed ATS 4.0 to determine if it would resolve some issues I was having with my new single sourced project.  Happily it installed easily and I was eventually able to resolve all the mapping issues with nested bullets and numbered sequences.  The one issue I still cannot solve, though, I think is a bug. I wanted to post here to see if anyone else has encountered it because I cannot believe it's not popped already. It seems to be something that occurred in the past with structured FrameMaker and some other posters have mentioned similar cases that dont have resolution.

 

My project file is one book with a handful of chapters with output to WebHelp.  I have xrefs within each chapter and between the chapters.  This project, with RH9 and FM11, handled the between chapter links well (although it also has a problem I have not solved of not actually  mapping the style properly...cannot get rid of the page numbers in my xrefs).  The links within and between chapters worked fine.

 

I copied the project  to a new location (the RH source and the FM source files) so I'd be working with a separate set for the new RH/FM versions. I opened the files fine in the new versions and spent about a day or two learning about the new versions and redoing style mappings.  The only sticking point is the xrefs which now dont work between chapters in the same book. The style in FM is the same for either tag type, I've mapped them all to just <paratext>.  Oddly, the mappings work nicely now in the new version ...the page numbers go away and I only get <paratext>. But this is only true for within chapter links.  The cross chapter links get an <a> tag without the href and they still have the source styling including page number. 

 

I've gone around in circles trying to figure out what I could have done to cause this and cannot figure it out.  I've even tried removing the "<Blue>" tag that's in the FM style in case the span tag is messing things up. No change. It is consistently the cross chapter links. I've opened all the .apj files to see if _any_ of them offer a clue ...i remain clueless.

 

Attaching screenshots

 

CSS from previous version (RH9/FM10). Notice the <a> tag has a lovely href embedded.

prevRelease.png

 

 

Same source file with mappings redone mostly for bullets and lists. Double-checked that all my xref mappings are to <paratext> (a few xref styles that are not used are not mapped). Notice that the within chapter links are beautifully handled now - i get just the <paratext>.  The href tag is now missing from the between chapter links thruout the project.

 

CSS for same source files using RH10/FM11.

 

currentRelease.png

 

HELP.  So CLOSE!

 

Diana

diana.starr@netscout.com

 

PS: For reference, here is the other posting that seems to relate but was "fixed" a while ago.

 

http://forums.adobe.com/message/261847#261847

 

Message was edited by: starrd

 
Replies
  • Currently Being Moderated
    Aug 10, 2012 7:02 AM   in reply to starrd

    The thread you're pointing to deals with a bug in structured FM; it kind of sounds like you're working in unstructured FM, right?

     

    I've had the same experience in unstructured FM10 to RH9; some of my cross-refs (which come over formatted fine - no on page xx stuff) will work as proper hrefs, others don't. The only thing I can narrow it down to was the length of the file path to the other file when the cross-ref was made (through early FM ignorance, we've got really super-long folder paths on a network drive with this FM project).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2012 8:21 AM   in reply to starrd

    Replied to your PM too soon - I see you've already posted to the thread ;>)

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2012 9:47 AM   in reply to Jeff_Coatsworth

    Thanks to everyone investigating this issue.

     

    I've just spent several hours wrestling with the same problem with FM11 and RoboHelp 10. Moved the projects to my c:/ drive and the problem fixed itself.

     

    Adobe needs to fix this issue ASAP.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2012 10:07 AM   in reply to RobertDesprez

    Use the bug submission form to bring it Adobe’s attention - https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

    The more people who do, the more likely it will get a fix added for it.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points