Skip navigation
Currently Being Moderated

what am i doing wrong with data source?

Aug 10, 2012 7:06 PM

Tags: #app #web #data #template #source

Sorry, I've looked around to try to find the answer to this and I haven't been able to.

 

I have two web apps. One, "Locations," holds a list of addresses for several stores, with tags like {location_street_address}, {location_phone_number}. Another web app, "StoreGallery", holds items to be showcased at these stores, and in it i've defined Locations as a data source field. So that for each item, they can associate an item with a specific store.

 

So in the detail template for StoreGallery I added one of the tags from Locations, thinking that by having defined the data source, the tags from one would work in the other, but they don't. I was only able to find tutorials on how to create the data source field but not on how to actually apply them in templates.

 
Replies
  • Liam Dilley
    6,693 posts
    Feb 28, 2012
    Currently Being Moderated
    Aug 10, 2012 7:45 PM   in reply to kenneth_rapp

    Hi Kenneth,

    The current version of web apps does not work like that.
    When you define a data store all that does is provide a link to the other web app item you associate it with. You can not put tags you built from one web app in another.

    The Data source output which is a hyperlink is the only thing you have.

     
    |
    Mark as:
  • Liam Dilley
    6,693 posts
    Feb 28, 2012
    Currently Being Moderated
    Aug 10, 2012 8:24 PM   in reply to kenneth_rapp

    Check the BC Blog Roadmap Post.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2013 2:52 PM   in reply to kenneth_rapp

    For whoever is looking for a solution to this...

     

    If you are trying to figure out how to use "Data Source" fields to show more

    than just a simple link from one Web App to another Web App, see below.

     

    This might save you hours of looking around.

     

    Using Kenneths example (from above), you should do this:

     

    1) Inside Web App called "StoreGallery", create a "Data Source" field named "StoreLocation"

     

    2) In the "Detail Template" layout of the Web App "StoreGallery", insert this code: {module_webapps,123,i,{tag_StoreLocation_id}}

     

    3) Make sure to replace "123" above with the ID of Web App "Locations"

     

    4) In 'List Template' layout of "Locations" app, customize which details you'd like to show for each location

     

    (ie {location_street_address}, {location_phone_number}. etc.)

     

     

     

    Cheers!

    A

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2014 1:29 AM   in reply to palvanov

    Hi All.

     

    I have issue with Similar above article.

     

    I have create 2 Web APP the idea I want Multiple Promotion can add to a hotel,

     

    1- Hotels App (Name, Description)
    2- Promotion App (Promo_Name, Description, Hotel_name "using data source field from App1")

     

    After I finish all field above,
    - I have added items to App1(hotel1,Hotel2)
    - I have added items to App2(promo1 for hotel1,promo2 forhotel1, and promo3 for hotel2).

     

    Front End
    So can show all hotels list for app1
    And I can show promotions list for app2 with association link to hotel detail directly from the promotion detail,
    so in the hotel detail I would like to show all the promotion which belong to it's,
    Ex: hotel1 have promo1 and promo2, and hotel2 have promo3 so i use this tag {module_webapps,34898,i,{tag_itemid}}  in hotels layout detail
    but it not working, it shown me only one item with error promotions tag

     

    When i use this tag it work {module_webapps,34898,a} but i don't want all,

     

    please help
    TY

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points