Skip navigation
cooper1971
Currently Being Moderated

CSS links

Aug 14, 2012 5:41 PM

I'm pretty new to Dw so be gentle. My links have been styled up as black on my pages. They look black in design view, they have the hex value for black in my CSS in code view and they're black when I look at the pages in live view.

When I preview in safari or firefox the links behave as styled for hover etc but they appear in a blue colour otherwise.

Any hints would be handy. This is my first site so not too much technobabble please..

 

Thanks

 
Replies
  • Currently Being Moderated
    Aug 14, 2012 7:37 PM   in reply to cooper1971

    Links have the following states:

     

    Normal

    Visited

    Hover

    Active

    Focus

     

    Now you define your styles in the following order:

    a { }

    a:link { }

    a:visited { }

    a:focus { }

    a:hover { }

    a:active { }

     

    Now this should get you started and you can ask a follow-up to clarify anything that is not clear here.

     

    Good luck.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2012 10:21 PM   in reply to cooper1971

    Best if you upload the page to the web and post a link so we can view it in our browsers.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 12:41 AM   in reply to cooper1971

    Hello,

     

    in addition to the former hints, you could have a look at Nancy O.'s tutorials. I made a search for you, where you can see some of her fine advices:

     

    http://search.freefind.com/find.html?id=84095852&pid=r&mode=ALL&n=0&_c harset_=utf-8&bcd=%C3%B7&query=link+hover, or esp.

    http://alt-web.com/Tutorials/css_links.html and http://alt-web.com/Articles/Persistent-Page-Indicator.shtml.

     

    If these things should be too complicated for you, I also recommend that you load up your page to your server and give us a link, no matter how it looks like.

     

    Good luck!

    Hans-Günter

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 3:11 AM   in reply to hans-g.

    Thanks everyone,

     

    I'd seen the CSS link order on google and thought that might be the solution but it hasn't worked. My CSS on my index page looks like this:

     

    a:link {color: #000;text-decoration: none;}

    a:hover {color: #EEE;text-decoration: none;}

     

    I'm quite happy for the links just to turn white from black when they are hovered over. I tried putting:

     

    a:visited { } etc. in with no values but again this hasn't worked.

     

    My site is in the Gazzasite directory on www.neillyshand.info. I only bought this yesterday as I wanted to get an avalability calendar and that meant SQL databases et al. That was a laugh trying to get all that to work!

     

    If you have a look at the index page that's where I've tried to fix the CSS, it may be all over the place on the other pages. I've no doubt my code will look like a riot to you guys but I'm a firm believer that the best way to learn is to use the software in the real world. Any hints welcome though.

     

    Thanks for your help, it's very appreciated..

     

    PS: I'm a print designer, I badly need to learn to code properly..

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 3:27 AM   in reply to shandmedia

    Hello Garry(?),

     

    would you please open a new thread, cause there are some more questions to answer in your topic.

     

    Hans-Günter

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 3:31 AM   in reply to hans-g.

    Hi Hans-Gunter, I'm the same guy that opened the thread. For some reason when I logged on from my mac as opposed to my imac it asked me for a screen name again..

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 3:35 AM   in reply to shandmedia

    Hi ok, merhaba,

     

    wait a little mo, at the moment, right now the guests are coming, to my sweetheart's birthday celebration!

     

    Hans-Günter

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 7:48 AM   in reply to shandmedia

    If you want the links to go back to black after being clicked, you should probably put some values in the a:visited css and not leave it blank.

     

    This might help:

    a:link {color: #000;text-decoration: none;}

    a:visited {color: #000;text-decoration: none;}

    a:hover {color: #EEE;text-decoration: none;}

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 7:59 AM   in reply to Rik Ramsay

    That's done the trick Rik, thanks everyone for your help.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points