Skip navigation
icegood
Currently Being Moderated

adobe flash plugin under linux KDE

Aug 16, 2012 8:58 AM

I've just installed latest flash player plugin using tar.gz archive and just checked it via youtube.

Now i see that "global settings" menu now available (wasn't available before) but click returns

with message "library kcm_adobe_flash_player wasn't found" from kde shell. As i see in

/usr/share/kde4/services/kcm_adobe_flash_player.desktop

Exec=kcmshell4 kcm_adobe_flash_player

while kcm_adobe_flash_player not includded. So, where can i grub kcm_adobe_flash_player?

 

Other question: what means line

NotShowIn=KDE;

in

/usr/share/applications/flash-player-properties.desktop?

Is it smth unavailable in KDE?

--------------------

OS: kubuntu 12.04 x86-64

browser: 14.0.1 firefox

adobe plugin: 11,2,202,238

 
Replies
  • Currently Being Moderated
    Aug 17, 2012 10:30 AM   in reply to icegood

    i just tried on a fresh Fedora 17 KDE install and it worked fine. 

     

    did you make sure to uninstall all previous versions of Flash Player?  when you grabbed the tar.gz file how did you install it?  i followed the readme so i basically did the following:

     

    1. extracted the contents of tar.gz
    2. copied the libflashplayer.so binary to ~/.mozilla/plugins
      $: cp libflashplayer.so ~/.mozilla/plugins/.
    3. copied(as root) the contents of usr to /usr
      #: cp -r usr/* /usr

     

    i then launched firefox and right click on some flash content and selected "global settings..."  the native control panel launched as expected.

     

    please try the steps above.

     

    side note:  i just now realize you are on x86_64.  is your firefox 64-bit also?  is the flash player binary also 64-bit?  try the steps above while i setup a similar environment as yours.  thanks... 

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 17, 2012 3:11 PM   in reply to libflashplayer.so

    ok, i'm up and running on kubuntu 64-bit and i see the issue.  there are 2 things i think we need to do to resolve it.

     

    1. symlink the lib64 binary to the lib directory.  assuming you copied the files to /usr in my first response.  as root execute the command in a konsole/terminal window

    ln -s /usr/lib64/kde4/kcm_adobe_flash_player.so /usr/lib/kde/.

    2. install the libkutils4 package.  as root execute the command in a konsole/terminal window

    apt-get install libkutils4

    after those 2 things, the native control panel launch without errors.  hope that helps...

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 26, 2013 11:02 PM   in reply to libflashplayer.so

    That should be

    ln -s /usr/lib64/kde4/kcm_adobe_flash_player.so /usr/lib/kde4/

    and the dot is not necessary.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points