Skip navigation
mcallit82
Currently Being Moderated

Robohelp 10 Upgrade loses Resource Links

Aug 15, 2012 2:34 PM

As a test, I downloaded RoboHelp 10 today and upgraded one of our larger RoboHelp 9 projects. I was surprised, and discouraged, to find that all of the images and snippets that had been previously linked in RoboHelp 9 were no longer linked when I upgraded the project to RoboHelp 10.

 

I realized that I hadn't included the resource manager locations in RoboHelp 10's resource manager pod, so I added them. Then I made another copy of my RH9 project and upgraded. Again, I had the same outcome: The links were missing.

 

I checked the rhsharedresources.apj and I found that it was blank (there was the usual XML in the file for a blank shared resource, but all of my other resources were gone).

 

I also found that I could not simply drag the snippet from the resource manager into the newly upgraded project. It opened and displayed the snippet, but it did not link it. When I tried dragging other snippets (snippets not currently in the project) into RoboHelp 10, the dialog that displays states that the file was skipped because it's not html.

 

Any suggestions on what to do? I would have assumed Adobe would have planned the upgrade with resource manager and the linked resources in mind.

 
Replies
  • Currently Being Moderated
    Aug 16, 2012 5:08 AM   in reply to mcallit82

    Try copying the file from the Rh9 version to Rh10 and then reopening the project. Just a wild guess.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 8:17 AM   in reply to Peter Grainge

    Same issue here, too.  That was my first reaction, Peter, and unfortunately it doesn't work.  I did eventually find a solution.  Sorry for the wall of text that follows, but documented is exactly what I found and fixed.

     

    The *only* changes I can see in the rhsharedresource.apj from RH9 to RH10 are as follows (may be others, but I'm not seeing them):

     

    RH9

         <rhpml majorversion="4" minorversion="0">

     

    RH10

         <rhpml majorversion="5" minorversion="0">

     

    RH9 image links

         <type>3</type>

     

    RH10 image links

         <type>6</type>

     

    RH9 snippet links

         <type>10</type>

     

    RH10 snippet links

         <type>11</type>

     

     

    Below are my findings.

     

    If I upgrade a RH9 project to RH10, the rhsharedresource.apj is completely blank after the project upgrade, and it looks exactly like this.

     

    <?xml version="1.0" encoding="utf-8"?>

    <rhpml majorversion="5" minorversion="0">

    <links/>

    <syncoption>

      <mode>0</mode>

    </syncoption>

    </rhpml>

     

    if I replace the newly upgraded rhsharedresource.apj with the old version from RH9 (without changing a thing in it) then open the project, the links are still lost.  The old rhsharedresource.apj looks something like this (only two links are depicted below -- a snippet and an image):

     

    <?xml version="1.0" encoding="utf-8"?>

    <rhpml majorversion="4" minorversion="0">

    <links>

      <link>

       <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\ctrl_clmn_exception_reason _lvl4.hts</shr_path>

       <prj_path>ctrl_clmn_exception_reason_lvl4.hts</prj_path>

       <type>10</type>

       <checkSum>E696925804FFF20E9DC5C3302D265262</checkSum>

       <remoteModtime>1343660808</remoteModtime>

      </link>

      <link>

       <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\image\btn_tbar_assigned_ca seload.jpg</shr_path>

       <prj_path>image\btn_tbar_assigned_caseload.jpg</prj_path>

       <type>3</type>

       <checkSum>BC8765991C25A4C0335B4F98FBE9764B</checkSum>

       <remoteModtime>1324573797</remoteModtime>

      </link>

    </links>

    <syncoption>

      <mode>0</mode>

    </syncoption>

    </rhpml>

     

    If in RH10 I create links to an image and a snippet from my Resource Manager (and close the project to save the rhsharedresource.apj), the rhsharedresource.apj RH9 (above) that overwrote the RH10 version is completely cleared of all old <link>s and the new <link>s are added -- note also that the <rhpml majorversion="4" minorversion="0"> was not changed to <rhpml majorversion="5" minorversion="0">:

     

    <?xml version="1.0" encoding="utf-8"?>

    <rhpml majorversion="4" minorversion="0">

    <links>

      <link>

       <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\image\add_abuse.jpg</shr_p ath>

       <prj_path>add_abuse.jpg</prj_path>

       <type>6</type>

       <checkSum>D475EDA6B33A370E0EE2F2BFD43AB7CB</checkSum>

       <remoteModtime>1340649613</remoteModtime>

      </link>

      <link>

       <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\busrule_latepickup_general _lvl1.hts</shr_path>

       <prj_path>busrule_latepickup_general_lvl1.hts</prj_path>

       <type>11</type>

       <checkSum>D07E1BDE7672065A2DF183AD9A4DD894</checkSum>

       <remoteModtime>1340649391</remoteModtime>

      </link>

    </links>

    <syncoption>

      <mode>0</mode>

    </syncoption>

    </rhpml>

     

    If I then copy the other 1000+ <link>s from my old RH9 rhsharedresoruce.apj and paste them manually into the newly-created rhsharedresource.apj (above), without changing the <type>, close the project and reopen, the links are still all gone but the rhsharedresource.apj did not remove the <link>s I pasted into it.  Looks like this:

     

    <?xml version="1.0" encoding="utf-8"?>

    <rhpml majorversion="4" minorversion="0">

    <links>

      <link>

       <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\image\add_abuse.jpg</shr_p ath>

       <prj_path>add_abuse.jpg</prj_path>

       <type>6</type>

       <checkSum>D475EDA6B33A370E0EE2F2BFD43AB7CB</checkSum>

       <remoteModtime>1340649613</remoteModtime>

      </link>

      <link>

       <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\busrule_latepickup_general _lvl1.hts</shr_path>

       <prj_path>busrule_latepickup_general_lvl1.hts</prj_path>

       <type>11</type>

       <checkSum>D07E1BDE7672065A2DF183AD9A4DD894</checkSum>

       <remoteModtime>1340649391</remoteModtime>

      </link>

    ****Pasted in <link>s begin here****

        <link>

         <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\msg_e0006_mnuopt_lvl3.hts< /shr_path>

         <prj_path>msg_e0006_mnuopt_lvl3.hts</prj_path>

         <type>10</type>

         <checkSum>CE15BA171163E6646CA3A17582B1139B</checkSum>

         <remoteModtime>1343660870</remoteModtime>

        </link>

        <link>

         <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\image\btn_browse.jpg</shr_ path>

         <prj_path>image\btn_browse.jpg</prj_path>

         <type>3</type>

         <checkSum>D7A5810E88DAFD620A9EC575FEFF62C7</checkSum>

         <remoteModtime>1340800474</remoteModtime>

        </link>

    ****The rest has been removed to keep this thread shorter****

     

    If I then change all <type>3</type> to <type>6</type> and all <type>10</type> to <type>11</type> (the ones I pasted in from the old RH9 rhsharedresource.apj file to match the new RH10 <type>s), close the project and reopen:

     

    <?xml version="1.0" encoding="utf-8"?>

    <rhpml majorversion="4" minorversion="0">

    <links>

    <link>

    <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\image\add_abuse.jpg</shr_pa th>

    <prj_path>add_abuse.jpg</prj_path>

    <type>6</type>

    <checkSum>D475EDA6B33A370E0EE2F2BFD43AB7CB</checkSum>

    <remoteModtime>1340649613</remoteModtime>

    </link>

    <link>

    <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\busrule_latepickup_general_ lvl1.hts</shr_path>

    <prj_path>busrule_latepickup_general_lvl1.hts</prj_path>

    <type>11</type>

    <checkSum>D07E1BDE7672065A2DF183AD9A4DD894</checkSum>

    <remoteModtime>1340649391</remoteModtime>

    </link>

     

    <link>

    <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\msg_e0006_mnuopt_lvl3.hts</ shr_path>

    <prj_path>msg_e0006_mnuopt_lvl3.hts</prj_path>

    <type>11</type>

    <checkSum>CE15BA171163E6646CA3A17582B1139B</checkSum>

    <remoteModtime>1343660870</remoteModtime>

    </link>

    <link>

    <shr_path>C:\TechComm\rsrcmgr\SPIRIT\rsrcs\image\btn_browse.jpg</shr_p ath>

    <prj_path>image\btn_browse.jpg</prj_path>

    <type>6</type>

    <checkSum>D7A5810E88DAFD620A9EC575FEFF62C7</checkSum>

    <remoteModtime>1340800474</remoteModtime>

    </link>

    ****The rest has been removed to keep this thread shorter****

     

    THE LINKS ARE RESTORED!  HALLELUJAH! 

     

    There may be an easier way to get to this result, but I've spent enough time on it this morning.  Hope this helps.

     

    EDIT:

     

    I should also add that I went back into the rhsharedresource.apj and changed the

    <rhpml majorversion="4" minorversion="0"> to <rhpml majorversion="5" minorversion="0">, closed/reopened the project and nothing was broken (that I could see).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 8:33 AM   in reply to eeddings

    Okay, further testing reveals that if I change the rhsharedresource.apj <type>s before upgrade, all is fixed instantly after the upgrade.

     

     

    Before upgrading, in the rhsharedresource.apj, change all <type>3</type> to <type>6</type> and all <type>10</type> to <type>11</type>, then upgrade the project.

     

     

    Hope this helps.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points