Skip navigation
Replies 1 2 Previous Next
  • Currently Being Moderated
    Jun 15, 2012 9:19 AM   in reply to Bert Devriese

    And on top of all that, you're sudo'ing into Illustrator which is insane. You'll almost certaintly run into permission issues if you create folders or maybe even files from within a sudo/superuser Illustrator.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 15, 2012 1:52 PM   in reply to Brian_W12

    Indeed, I had some issues because of that when working with illustrator today

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 15, 2012 2:30 PM   in reply to Ivan David

    It's still not working. This is a bit ridiculous.  It would seem as if Illustrator wants to set a ulimit of its own, but can't?  Any updates?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2012 12:09 PM   in reply to anandcpatel

    I don't think this has been suggested yet.

     

    I don't have SMART drivers installed and don't have the config files, either. But I found a solution that worked for me for Illustrator CS6:

     

    Go into your user/library/preferences/

     

    Delete/rename all of your Illustrator preferences files (there should be a folder) and also the com.adobe.plist file (note: this will lose your preferences).

     

    Restart the computer.

     

    This worked for me on multiple launches of Illustrator and I restarted a few times since as well - still working.

     

    I know this is an easy solution, but it worked for me perfectly. Didn't want to have to launch a script just to run a program everytime.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2012 3:27 PM   in reply to Bloodyelle

    I tried this previously but I never thought to Restart the computer afterwards. For whatever reason, restarting after removing the preferences actually worked for me and I don't get that message anymore.

     

    Evidently there is something else going on there with the Restart part.

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:08 AM   in reply to Bloodyelle

    @bloodyelle & Ian Kelleigh: Unfortunatly, this did not work for me. Even after restarting I still get the same message.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2012 6:01 PM   in reply to Bloodyelle

    this really work for me!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 29, 2012 6:08 AM   in reply to graphicillusion

    I guess this is the most up-to-date thread on this problem; for what it's worth, here's my (strange) experience:

     

    AI was working fine on Mac OS X 10.7; after I upgraded to 10.8 ('clean install') I started getting the error. I tried everything suggested on the forums and Adobe's official help page, to no avail. (sudo-ing didn't work either; it wouldn't let me save anything?!)

     

    Then today everything just went back to normal. The only change I made with the computer in the meantime was to re-install Parallels Desktop 7, and perhaps 3 restarts. There was no change in AI's behavior after the first restart. After the second restart, AI would run for only one session—after I quit and wanted to come back, I got the error, again. Now, it's 'back to normal'.

     

    I'm not confident that things will stay this way, though. This isn't exactly a 'crash' either, so there's no report to send to Adobe. I guess the best we can do is to keep these threads alive.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 29, 2012 9:20 AM   in reply to Alptekin Sanli

    Yeah the whole thing is seemingly random for me too. I could try it one hour and I get the error, next morning I try and it works fine. It is some conflict with another app or setting that is limiting maximum open files and it isn't always from the SMART drivers.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 29, 2012 11:12 AM   in reply to Ian Kelleigh

    I was getting this error randomly, too, but it seemed to be happening only when Illustrator CS6 was opened along with CS5.5 apps such as InDesign or Bridge. Now I open only apps belonging to the same suite at the same time -- don't mix and match -- and the error hasn't occurred since. May be just be a coincidence, but perhaps CS5.5 and CS6 don't play well together.

     

    Steve

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 29, 2012 4:26 PM   in reply to sboerner2

    Another thing I've noticed is that when I launch this without the error it seems like it's reading different preferences than when I run it through that script. For example, panel locations are different depending on how it launches.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 6:45 AM   in reply to medgno_43

    Such a frustrating error...

     

    I've just run repair disk permissions and restarted my iMac and hey presto the Illustrator is working without issue.

     

    Previously tried the Adobe official solution which would get it started but there were some odd side affects on the interface.

     

    Hopefully this might help some of you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 12:15 PM   in reply to Guthrie.Watson

    After a day of stability, my Ai started acting up again.

     

    Unfortunately, repairing permissions doesn't seem to be the solution either. I've done that numerous times (redundantly) both with Disk Utility, and Onyx, and neither helped.

     

    I didn't try booting into the recovery partition, and running Disk Utility from there; but I doubt that that will help.

     

    Not that I really 'understand' these things, but considering that Adobe suggests editing launchd.conf (for those who have it), I thought that this whole thing may have something to do with messed up 'launch daemons', or 'launch agents'. I went rummaging through all of my Library folders today (system, root, user) looking inside .plist files that might be relevant, but couldn't find anything related to Ai.

     

    If there are any *nix-savvy folks out there—does any of this ring a bell?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 17, 2012 12:17 PM   in reply to Ivan David

    I was getting this error and didn't have any of the files or settings listed in Ivan David's post. I downloaded the file he provided and ran it to use Illustrator briefly, until an unrelated keyboard issue forced me to restart. After that, Illustrator seems to be back to normal.

     

    So, if nothing else, try a reboot? I'll repost if the issue crops back up; it may be related to a process or app that was running on my system before the reboot.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2012 12:40 PM   in reply to beaglemedia

    This works for me !!!

    1 - Try deleting font database (I use Fontexplorer X Pro)

    2 - Stick to Firefox

     

    Good luck!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 7:58 AM   in reply to diegos77

    I was having the same issue and I stumbled into this discussion and i had no luck with the script nor with the file search. Then I tried bloodyelle solution, to delete Adobe preferences file (com.adobe.plist) : i tried this myself before but forgot to restart my mac after...this time it worked like a charm with the only minor issue of my preferences loss. Just a reminder for Lion users: by default library folder is hidden (user/library/): to reveal it just open Terminal and type:

     

    chflags nohidden ~/Library

     

    et voilà, it will show up.

     

    Anyway, it's really sad Adobe could not provide this solution before and that they didn't even try to fix this problem, only suggesting a poor workaround which, in my case, didn't even work (Illustrator would boot but i wasn't able to save my files).
    Hope this will help.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 16, 2012 9:16 AM   in reply to lindoferretti

    The issue is fixed in the recent update of the Illustrator CS6 ,

     

    http://helpx.adobe.com/illustrator/release-note/illustrator-cs6-0-1-re lease-notes.html

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 11:45 AM   in reply to medgno_43

    Just open the terminal and run the following string:

     

    sudo sysctl -w kern.maxfiles=15000

     

    It will simply raise de number of maxfiles and illustrator will open without any other additional script or anything else.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points