Skip navigation

"RAM Preview needs 2 or more frames" error back in CS6

May 7, 2012 2:14 PM

  Latest reply: Marc Lucas, Jul 10, 2013 3:25 AM
Branched to a new discussion.
Replies 1 2 Previous Next
  • Currently Being Moderated
    Jul 30, 2012 2:14 AM   in reply to Todd_Kopriva

    Hello Todd

    Your solutions did not fix my problem:

     

    - Operator "error" - it doesn't matter where the timline or work area is.

    - plugins - dont have any

    - purging memory - if i restart my machine the problem reappears after a few mins of working in after effects.

     

    Megumi

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 5:08 AM   in reply to Megumi2

    Megumi2 wrote:

     

    Hello Todd

    Your solutions did not fix my problem:

    I'm not sure if this will help or not but I had this problem on a MacBook with 4GB ram. I had a bunch of other software installed on the MB and the error popped up very often. To make a long story short I ended up passing the computer down to my daughter. I just dropped a new HD in the machine, installed Mountain Lion, and then did an install of CS6. AE now works fine. My conclusion is that there was something installed, some other software or codec, that was contributing to the rendering error. I don't have any idea what it was, but when I boot my new MBPro from the HD that came out of the Old computer AE has no problems at all. The biggest difference is that the new computer has 16GB of ram.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 8:28 AM   in reply to Rick Gerard

    Thanks Rick

    I dont have 16G of Ram, but 4G is listed as ok in the AE 6 system requirements.

    AE 5 runs fine with it, so i cant really blame my hardware setup.

    Megumi

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 10:06 AM   in reply to Todd_Kopriva

    None of this is helpful at all.  I can't believe this issue still hasn't been fixed.  I simply can't work with After Effects CS6 anymore.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2012 8:27 PM   in reply to The Scarlet Avenger

    I was having all the same issues with the '2 Frame preview' business. Turned out to be the lenscare 'out of focus' plugin.

    In fairness is was an older version from Frischluft.com (lenscare_AE_v1.44).  I updated to lenscare_AE_v1.46 and all the problems went away.

    This was not only causing me problems with playback, but was also providing me with black frames.  This turned out be the result of the old plugin being part of a masking operation.

    My comps are 1920x1080 if full res preview and playing just fine.

     

    I believe there has already been some discussion about plugins not working well with CS6.  Would be wise to be sure that all plugins being used were up to date.

     

    Hope this helps somebody.

     

     

    Cheers,

     

    Russ

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 2:39 AM   in reply to The Scarlet Avenger

    Im in the same situation as Scarlet above

    AE 6 is unuselable for me

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 12:40 PM   in reply to Megumi2

    OSX 10.6.1, 12 core mac pro with 48GB of ram and I get this message without using any plugins. The only plugin we've reinstalled for cs6 is trapcode particular, which is not even in the comp. Tried clearing cache etc, to no avail. After waiting a few minutes, it ram previewed 15 frames and stopped like ram filled up which is impossible with the amount I'm running. Very disappointed so far with cs6 all around, this just appers to be another annoyance.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 12:54 PM   in reply to oliphantscott

    Have you tried restarting? That helped solve it for me and several others here by clearing the system RAM. At least till it fills back up.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 1:12 PM   in reply to itswilder

    Tod Kopriva in post #36 has explained that one of the temporary solutions is to free up your memory.  There...he says....are number of ways, but does not give any specifics.

     

    Since my last post, I have found that Trapcodes Particular does not play well with the new caching.  It appears more about how Particular works then to unavailable memory, but yet another caching problem to worry about.

     

    I oversee the After Effects tools used for a large facility in Sydney, Australia.  The decision has been made to retreat back to the earliar version of After Effects.

     

    The application as it stands is unworkable for a collaborative environment.

     

    Ted Kopriva, who is representing Adobe has said that they are looking for answers. In the meantime it would be great to identify all plugins which have problems, and also some clear solutions to clear out cache.  Dumping all your cache should not have to be one of these solutions.

     

    I was really looking forward to this new caching, but it is just not happening.  Hopefully Adobe has a solution soon.

     

    Russ

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 18, 2012 1:26 PM   in reply to rmaehl

    (Be sure to read this post about all of the causes of this message.)

     

    To be very specific about why restarting the computer is useful in the case of the Mac OSX inactive memory case:

     

    The problem is that Mac OS is not releasing "inactive" memory and making it "free" memory. Restarting the computer is a crude but effective way of forcing the OS to free up "inactive" memory. As I said in a previous post, there are various little utilities that will free inactive memory that accomplish the same thing.

     

    Note that restarting the OS is not adequate; you need to restart the computer (turn it off and on).

     

    BTW, the reason that this is happening for After Effects CS6 is that we added a check for free memory in After Effects CS6 in an attempt to be more polite in sharing memory with other applications. Previous versions of After Effects would just stomp on the inactive memory, which could be inconvenient for applications that were counting on having quick access to that memory.

     

    We are investigating a way to mitigate this issue, both respecting the inactive memory and giving you the ability to use After Effects on Mac OSX without needing to restart your computer or use a third-party utility.

     

    Because this is a problem with Mac OSX memory management, the problem does not exist on Windows.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 5:24 AM   in reply to itswilder

    Restarting has no effect for me.

    i mean, the problem re-appears almost imediately when i begin work again.

    and i have zero plug-ins

    all sotware has bugs, but i cant belive it wasnt sorted in the patch update.

    ive had to revert to AE5

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 17, 2012 3:06 AM   in reply to EchoOut

    Gald you got sorted EchoOut.

    I dont think Lion 10.7 will fix it as Adobe has stated above the problem is a change to how AE6 handles the RAM.

    And im not about to remove AE 5 as its all ive got at the moment.

    Good Luck

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 17, 2012 5:18 AM   in reply to Todd_Kopriva

    Any chance Mountain Lion might improve upon this issue?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 17, 2012 5:48 AM   in reply to Sonix011

    There is a handy free app called FreeMemory that can be used as a simple work around to this problem. AE is not the only app that has this trouble. Apple has done a very good job on most of their OS but memory management still has some room for improvement.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2012 9:37 AM   in reply to rmaehl

    I have a project that uses Video Copilot's Twitch plugin a ton. It's currently crippling AE6. I originally built it using CS5 and opening it in CS6 brings up the same errors everyone else is having. Two frame error or it will just render three frames and stop. No playback, but only in comps that use Twitch. I definitely have enough RAM (64GB installed, only 8-10GB used at one time when the project is open). I'm able to open other comps in CS6 fine so I'm thinking it's a plugin issue. Sucks that this has to happen.

     

    I chose to go with Premiere on this project because I knew I could link into AE with Dynamic Linking. Now that my most used plugin on the project is taken out of the game, looks like Dynamic Link is out as well. I can't help but be pissed at Apple too for rendering all the power in my Mac Pro useless under these particular circumstances.

     

    *head desk*

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2012 12:25 PM   in reply to bdelillo

    I would immediately go to the Video Copilot website and contact their support. This twitch is the only plug-in that is causing you trouble, then the problems with the plug.  I'm not saying that memory allocation in the Mac is perfect. I'm just saying that it only stands to reason that if Twitch is the only plug-in that's causing your problem then the problem lies with twitch.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2012 12:28 PM   in reply to Rick Gerard

    Such a "no duh" thing to do, yet I didn't think of it. Thanks for the input Rick.

     

    I'm scheduled to get a suite of plugins soon. If any of those cause me problems I'll be sure to report back.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 10:41 AM   in reply to Todd_Kopriva

    To contribute another outlier case, I am seeing the "2 frames" bug in just one single comp in a project!

     

    The comp is simple, with a single footage item with about a dozen keyframe animated masks. No plugins or filters are in play. If I recreate the comp from scratch, it previews fine. If I use any element from the original comp, either the footage or the mask data, I get the "2 frames" bug (that is a copy-pasted version of the footage -- if I drag it fresh from the project window and start masking all over again the same clip is just fine!).

     

    If I precompose the comp it will not preview. I transfer the masks to a solid and precompose *that* it still will not preview. I can switch to any other comp in the project and it previews fine -- but as soon as I switch back to this one I get the dreaded dialogue box.

     

    Flushing memory apps and restarts do not seem to be affecting this particular instance of the problem.

     

    (I have previously seen the bug in other situations and cured it with a reboot and/or third party utility memory purge.)

     

    For the record, I'm running AE 11.0.0.378 under Mac OS 10.7.4 on a duodeca-core Mac Pro with 32 GB of RAM. AE has a dedicated SSD scratch disk. I really don't think fragmentation is my problem here.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 10:44 AM   in reply to MatthewHemming

    > For the record, I'm running AE 11.0.0.378 ..

     

    Is there a reason that you haven't installed the 11.0.1 update?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 8:47 PM   in reply to Todd_Kopriva

    Todd,

     

    My Adobe Application Manager doesn't know anything about it. I just checked now, but it says there's nothing new. I'm all set up with the Creative Cloud -- I thought these kinds of update notifications were supposed to be automagic.

     

    Thank you for the link, though. I'll go and download it directly.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 3:22 AM   in reply to MatthewHemming

    Hi Matthew

    ive had some sucess with freememory

    its a small app for the desktop (see post 54 above)

    the problem still appears but freememory knocks it on its head

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2012 10:32 AM   in reply to Todd_Kopriva

    I've got 24 GB of RAM; been using AE for about 15 years. In my case, I don't think it's user error, or even a plugin.

     

    It's pretty much the "problematic and technical issue" noted above that was created with AfterEffects CS6...

     

    Why not let end-users decide whether or not they want to "rude" about sharing RAM with other applications...When I'm working in AE, I need it to work with me, not against me.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2012 4:36 PM   in reply to GiantSimon

    Hi Simon,

    please, try one thing:

     

    Go to Preferences and then open Memory & Multiprocessing. Press on the Details button.

     

    Does the info shows anything weird on how the RAM memory is distributed?

     

    Cheers

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2012 8:55 AM   in reply to Atomickplaygrounds

    The After Effects CS6 (11.0.2) update was just released. It includes many bug fixes and adds some GPUs to the list of those that can be used for GPU acceleration of ray-traced 3D rendering.

     

    Details are here: http://adobe.ly/AE1102

     

    Note that one of the changes is the addition of a new Memory & Multiprocessing preference and an adjustment to memory handling on Mac OS to alleviate the problem seen when getting the message “After Effects error: RAM Preview needs 2 or more frames to playback”.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2013 9:09 AM   in reply to EchoOut

    I fixed it when I changed "Ram reserved for other aplications" from 3 to 1,5 (I have a MacBook Pro with 4 Gb Ram). I don´t know why.

     

    Javi

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2013 3:25 AM   in reply to Todd_Kopriva

    Just found that Videocopilot Twitch is also a culprit!

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points