Skip navigation
mework
Currently Being Moderated

'You cant open the application Adobe Photoshop CS6 because it may be damaged or incomplete'

Aug 21, 2012 5:06 AM

Tags: #installatio_failure

This Message appears after clicking on the icon after installing from creative cloud. Can't try installing again as AAM says that it is already installed.

 

Installed on iMac OSX 10.6.8

 

Screen shot 2012-08-21 at 11.30.40 PM.pngScreen shot 2012-08-21 at 11.26.52 PM.png

 
Replies
  • Currently Being Moderated
    Aug 21, 2012 9:47 AM   in reply to mework

    Please try uninstalling with the uninstaller located in Applications/Utilities/Adobe Installers.  If you have the same problem again then please try downloading and installing the trial of Photoshop CS6.  Once the trial is installed you can choose the License This Software option and enter the Adobe ID tied to your Creative Cloud account.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 5, 2012 7:46 PM   in reply to Jeff A Wright

    Hi Jeff,

     

    Was in the same situation and this advice worked for me.

     

    I have installed it as a trial yet am unable to find the License This Software" option.

     

    Could you please inform me where within Photoshop this option is located? (iMac 10.8.1)

     

     

    Thanks

     

    Aarron

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 5, 2012 8:21 PM   in reply to Aarron Chittock

    Close and re-open PS CS6 and then check if you get that option or not. If not, goto Help Menu and check is Deactivate option is greyed out or not. If it's not greyed out, it means your PS CS6 is activated. No need to worry.

     

    Just relax and enjoy the application.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 12, 2013 8:31 PM   in reply to mework

    After several days of this annoying me and trying various different things, I finally found the solution!!

     

    Open Terminal and run this command and it will reset the launch services to let it work properly.

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Framework s/LaunchServices.framework/Versions/A/Support/lsregister -kill -domain locat -domain system -domain user

     

    The problem began for me once I removed photoshop because the update kept failing.  So I uninstalled photoshop cs6 using their uninstall script, and then re-installed it with the creative cloud application manager.  From then on I could not "double click" on a .PSD to open photoshop directly, but "open with" would work.  Very strange.. but the above command fixed it.

     

     

    Here are some screenshots of the issue:

     

    Screen Shot 2013-03-11 at 7.57.41 PM.png

     

    Screen Shot 2013-03-11 at 7.57.51 PM.png

     

    Screen Shot 2013-03-11 at 7.57.59 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 12, 2013 8:34 PM   in reply to ryanwyler

    In the post it looks like the command is on two lines, but it's not.  It's on one line.

     

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Framework s/LaunchServices.framework/Versions/A/Support/lsregister -kill -domain locat -domain system -domain user

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points