Skip navigation
LensVisions
Currently Being Moderated

Unable to choose Photoshop CS6 as default app for jpegs, Win7

Aug 25, 2012 11:16 PM

Tags: #default_application

Suddenly I'm unable to choose Photoshop CS6 as the default "Open with" app in Win7 when I'm attempting to open jpegs.

I updated Adobe Application Manager and it says Photoshop CS6 is installed and I'm able to open Photoshop CS6 without getting the "trial version" error any more -- although that was a  problem until I updated AAM.

Len Cook

 
Replies
  • Currently Being Moderated
    Aug 28, 2012 12:35 PM   in reply to LensVisions

    Hi Len,

     

    This is a feature of Windows not the Adobe software but you should just be able to right click on a jpeg image go to Open with, select Photoshop CS6 as the default program, check the option to always use this program, and click OK.

     

    -Dave

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2012 1:42 PM   in reply to LensVisions

    I was able to change it successfully from the default of Windows Photo Viewer to Photoshop on my Win 7 machine. The steps I followed:

    1. Open the Control Panel from the Start menu.
    2. Mine is set in top right to 'View by' Category. I clicked on Programs (green link).
    3. Under Default Programs I clicked on the blue link for 'Make a file type always open in a specific program'.
    4. Wait for 'Loading..'. to finish. Make sure the list is sorted by Name and scroll down to '.jpg'. Select it and click the button for 'Change program...'.
    5. Do no see Photoshop listed in the Recommended Programs, so click on the small triangle to the right of Other Programs. Select Photoshop and click the OK button.
    6. Wait for the list to reload and confirm the association changed.

     

    Note that you will probably need to change this for .jp2, .jpe and .jpeg too in addition to just .jpg.

    jpeg_photoshop.png

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2012 7:54 PM   in reply to LensVisions

    I know exactly the problem you are having and exactly how to fix it! (For Windows 7 and possibly others) I spent an hour trying to figure it out, and it is all because of bad registry values.

     

    Cause:

    First off, it is caused by uninstalling a previous version of Photoshop and then installing CS6. (But lingering folders and registry values still remain)

     

    Symptoms:

    When you try to change a file type association with the Open With dialogue, Photoshop CS6 never appears! Choosing "Other Programs" does not bring up Photoshop CS6, and Browsing will not add it to the list!

     

    Workaround: (REAL FIX)

    Click on the Start button.

    Select the search programs and files. (You may need to enable this search field if you have it disabled.)

    Type regedit (regedit.exe will appear only after typing regedit completely)

    Select regedit.exe.

    Click yes to allow access to it.

    Be very careful with the following steps as editing the registry is dangerous!!

    Navigaate to HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command

    Double click on Default.

    In the value data section you may notice a path to the previous application that doesn't exist anymore (root of problem)

    Change it to the path of CS6 folder but keep the extra characters beyond Photoshop.exe

    Hit ok. Then close out of this window.

    NOW Photoshop CS6 will appear in the list! Enjoy!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 31, 2012 3:46 AM   in reply to pyrografix

    pyrografix - sorry that didn't work for me.

    My fix is as follows go to Adobe Bridge / Preferences / File Type Associations and there change all your relevant file types to CS6 or whichever programme you want to open them with.

    Regards

    NeilC

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 26, 2013 6:52 AM   in reply to Neweycoop

    that helps when you open files in bridge but it does not fix the problem when you try to open the files in win explore... but if you want to fix the problem for real you must use the regedit.exe.. as mentioned before, be careful to open the right file to reedit. confusion is easy in there... Anyway if you did the recomended instalation on the previous and the new version of the software you'll juste have to replace cs5 by cs6. 

     

    have fun

     

    Message was edited by: olan bowland

     
    |
    Mark as:
  • Currently Being Moderated
    May 1, 2013 11:23 PM   in reply to olan bowland

    I've got the same problem too but I solved it by using CCleaner software.

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2013 3:53 AM   in reply to pyrografix

    Thankyou!!! Finally an answer that actually works

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2013 4:11 PM   in reply to Sederholm1

    Agreed - this was the solution for me too. A registry clean with CCleaner allowed me to again add Photoshop to the Open With... options. Thank you!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points