Skip navigation
Currently Being Moderated

CF9 IIS 7.5 Setting up Application Problem

Aug 23, 2012 8:44 AM

I currently an running CF 9.0 Enterprise Edition running on Windows 2003 Server R2 SP2 converting to CF 9.0.2 Enterprise edition running on Windows Server 2008 R2 SP1 with IIS 7.5.

I was able to successfully install and configure the cfadmin without issue.

My problem is now that when I try and access my web application (which resides within the same directory structure as the cfide folder).  I know it is not a permissions issue - I wouldn't be able to get to the administrator.

 

I have my web application or custom code set up as an 'application' as apposed to a virtual directory.  When I try to access the application via the website, I receive the following error:

500 - Internal server error.

There is a problem with the resource you are looking for, and it cannot be displayed.

And in IIS, under the application, I go to edit application, basic settings, I try to 'test settings' I get:

There was and error while performing this operation. Details:  invalid application path.

 

Which I know is wrong.  And I know that permissions are correct.  I've followed many instructions regarding the application pool settings and .Net without success.

I did see on one of the blogs that someone noted that you needed a virtual directory under the application - which is something that wasn't needed in previous versions.  I haven't been able to confirm that either. 

 

I could revert to the IIS 6.0 Manager, but I'd have to have it re-installed (they installed it and made it operational only for the SMTP server).

 

Any ideas?  I've spent about 20 hours working just on this . . .

 

Thanks.

Libby H.

 
Replies
  • Currently Being Moderated
    Aug 23, 2012 10:08 AM   in reply to Libby H
    I have my web application or custom code set up as an 'application' as apposed to a virtual directory.

     

    I think this is the root of your troubles.   I'm not sure why you would set up a .Net application in IIS to point to your CF app, but I would start by deleting the IIS "application" you have set up, place the top level folder of your CF app directly beneath c:\inetpub\wwwroot in the file system (or wherever your IIS website is pointed to if not the default location), and start from there.  Maybe run the CF wsconfig tool again after you've removed the .Net stuff from your IIS config.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points