Skip navigation
surr3al
Currently Being Moderated

Flash not working with Firefox

Sep 12, 2012 4:41 PM

Every computer I have doesn't work with flash 11.3 or 11.4 (latest versions in each). I've tried Firefox 14 and 15.0.1

 

Flash 10 works... but that is just stupid. I'd rather not use Flash at all.

Branched from an earlier discussion.
 
Replies
  • Chris Campbell
    9,455 posts
    May 4, 2010
    Currently Being Moderated
    Sep 12, 2012 4:43 PM   in reply to surr3al

    @surr3al - Have you tried running through the troubleshooting steps in this FAQ?

     

    How do I troubleshoot Flash Player's protected mode for Firefox?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 10:21 AM   in reply to surr3al

    Sadly, it looks like were back to square one, as far as the two latest revisions to Firefox (15.0 & 15.0.1) go.  Ever since they updated it in late August, I started noticing another series of "silent" crashes recorded by Firefox.  Those are crashes that take place with no perceivable indication such as stalls or warning messages.    (Type about:crashes in the address bar to see a list of crash reports.)   BUT, unlike the crashes reported back when Flash Player's protected mode was introduced, these were "empty" in that no specific details about what caused the crashes were indicated.   Also, unlike the earlier crashes, they did not happen at a specific point, such as when a site containing a Flash video (YouTube, etc.) was exited.  Normally, though, they would happen when exiting SOME sites containing Flash content.

     

    After about a week of troubleshooting, such as enabling/disabling JavaScript, addons, plugins, etc., and about 50 crashes reported--all empty, I finally decided to disable Flash Player's protected mode to see if that made a difference.  As of 24 hours usage, there have been no crash reports generated.

     

    I should add I'm using Windows 7, Firefox 15.0.1, and Flash Player version 11.4.402.265.

     

    It seems that whatever Firefox did to their version 15 has caused the problem to resurface. 

     

    (Note, I've always kept hardware acceleration disabled for BOTH Firefox and Flash Player, so I haven't experienced the freezes, etc., reported by others on the Firefox help forums concerning hardware acceleration--just the silent, empty crashes. )

     

    Ortho_Fan

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 6:50 PM   in reply to Ortho_Fan

    I clicked that link but the steps are horribly complicated. I am not a computer whiz--I have had no formal training in computers, all I know I have learned the hard way, by trial and error and advice from friends in some cases. But Adobe should provide support directly for its customers.

     

    I don't know if I can manage to do all those steps; I have never used safe mode, for example, have no idea how to do it. And I also have no idea how to disable hardware acceleration specifically for Flash; I believe it is disabled for Firefox because I seem to remember someone told me to do that once, but obviously it has not helped. I also can't seem to figure out how to disable the protected mode--there is a sentence in blue on that page but it is not a link.

     

    The crashes that I get are not "silent"....they wipe out everything on the screen and leave it grey with just the text "Send crash report" and then "reload page". The trouble is that reloading Farmville (which is where the crashes always occur, but forget getting any help from them about it--they just pass the buck to Adobe.) is that you have to start over from scratch reloading the whole thing from the beginning and it takes forever to load every time; so when it crashes the minute I get the whole thing loaded and try to click on something in the game...well you can imagine the frustration. And this is the only game I play--the only one I can stand, for that matter. So it is my only diversion.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 6:57 PM   in reply to Ortho_Fan

    To: OrthoFan:

    OK, I got to the ms.cfg page but all it has on there is what you see on the screenshot, and it won't let me type anything into it.

    Capture.PNG

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 7:50 PM   in reply to Cristy13

    If I'm looking at that correctly, it looks like you've opened it with your browser, or your browser is running. 

     

    After closing your browser, to make sure Flash Player is not active, go to Windows Explorer, (or the Documents folder, and then click on the "C" or main drive) and following the path indicated in the linked post to locate the file. 

     

    Depending on how your PC is set up, you might--first of all--have to set it to display hidden files and folders.  Do this by clicking on the Tools menu, (to display that, if hidden, hold down the "alt" key on your keyboard), click on Folder Options, and then click on the "View" tab, and finally, click on the circle next to show hidden files, folders and drives.

     

    Once you locate the file, right-click it and select "Open With," then select Notepad.

     

    The file will be displayed as it looks in your image above, but you should be able to type or paste the added line at the bottom, right UNDER "silentautoupdate..."

     

    Then, click on File and Save.

     

    If it won't let you save it, you'll have to do what I did and save it in a new location, such as your desktop.  Then, it's simply a matter of deleting the original file and replacing it by dragging and dropping the new version into the same folder, where the old one was.

     

    If you still have problems, maybe one of the techies who post here can help.

     

     

    HTH,

    Ortho_Fan

     

    ---------------------------------------------------------------------- -----------------------------------

     

    By the way, looking over some of your other questions, here are the steps for disabling flash player hardware acceleration.

     

    1) go to this page -- http://www.macromedia.com/support/documentation/en/flashplayer/help/se ttings_manager02.html

     

    2)  Right Click on the box under "Global Privacy Settings Panel"

     

    3)  Scroll down and click on "Settings"  A new small box will appear.

     

    4)  If there is a check in the box next to "...hardware acceleration"  click on it to clear it.

     

    5)  Click the "Close" button.

     

    ------------------------------------------

     

    To disable hardware acceleration in Firefox:

     

    1)  Click on the "Tools" menu at the top of your browser's screen

     

    2)  Click on "Options" which is near the bottom of the list.

     

    3) Click on the "Advanced" tab, which appears at the top of the "pop-up" box.

     

    4)  If there is a check in the box next to "use hardware acceleration when available," click on it to clear it.

     

    5) Click on the "Ok" button to save your changes.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 7:20 AM   in reply to Ortho_Fan

    I did these last two steps and the hardware acceleration is disabled in both places--it already was disabled when I checked. But I am still getting constant crashes; the minute my game opens the flash player crashes, at least every 10 to 15 minutes. It is making it impossible to do anything.

    But I do not understand what you said in the beginning of this post. I went into my documents but there was no"C" to click on nor any main drive; and I don't understand which original folder to delete and dragging a new one....it's all Greek to me.

    Also under Tools there is no "Folder options", only "Options" which is not he same thing.

    I guess it's hopeless.

    What I don't get is Flash worked fine for a long time then suddenly not at all. I have tried other browsers and none of them will work with Farmville. Not at all. I feel so damned helpless!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 8:24 AM   in reply to Cristy13

    Well, before giving up completely, try this:

     

    1) Click on the Start menu  on your home page

    2)   Type FLASH in the search box

    3) One of the items listed should be a little folder icon with the word "Flash" next to it

    4) click on that to call it up.

    5) Hopefully, you'll see mms.cfg listed.

     

    HTH,

    O.F.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 8:48 AM   in reply to Ortho_Fan

    This is totally unbelievable. I typed flash in the start menu search box and

    there is no folder icon; only thing under Flash is a list of "Install" and one

    "Uninstall" with the flash player icon in front of them.

    Are we using two completely different systems or what???

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 9:05 AM   in reply to Cristy13

    It might have something to do with the way I have Windows 7 configured.  I use the "Classic View" shell, so it has the same look and many features of some of the older versions, going back to Windows 98.

     

    (But the question just occurred to me, what version are you using? )

     

    In any event, at this point, I think you probably need some help from this site's more experienced tech. experts, who might be able to help you locate the file through a back-door approach.  Also, if you know of any PC techies near you--friends, relatives, co-workers, fellow-students, etc.--you might have to call them into play.

     

    Sorry I couldn't help, but I wanted to add that the problem you are having is not unique.  Just in case you haven't seen this, it echoes many of the issues you are having--

     

    http://en.kioskea.net/forum/affich-154524-problems-with-flash-and-farm ville-on-facebook

     

    Good luck.

     

    Ortho_Fan

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 11:31 AM   in reply to Ortho_Fan

    Well, for right now I think I'm finally OK. This morning I couldn't get any

    browser to work with the game, but later I tried Chrome again and so far

    (knocking on wood with both hands) it is working great. No crashes at all, and

    it works faster than Firefox both on Facebook and in the game. So for now I'll

    stick with it, but I will save your emails in case I run into problems again

    (hope not!).

     

    I had thought that I had the version 11.4 of flash installed but I can only find

    version 11 on my computer now. That I don't get because I did have 11.4

    installed earlier today but I uninstalled in order to try again and it looks

    like it would only install 11 after that, can't figure out why.

     

    I also thought you had to install flash separately for each browser; I don't

    know if that is right or if you only need it installed once to use across all

    browsers. In any case I only seem to have it once.

     

    Anyway thanks for taking the time to work with me on this, I appreciate your

    efforts.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)