Skip navigation
Currently Being Moderated

Indesign CS6 hand tool gets stuck and can't use selection tool

Sep 7, 2012 1:20 PM

In Indesign CS6 using Mountain Lion, the hand tool appears and I can't select or work with any other tool. All I can do is move the document around. After trying the space bar and other key commands I restarted and it worked for a while. Then it happened again. I work on a Macbook pro, so when I removed the mouse and worked only with the trackpad there was no change. When I quit and reopened, no change. I then deleted prefs and restarted and it worked, but it's been happening from time to time. Anyone know any other fix without restarting or deleting prefs.

 
Replies
  • Currently Being Moderated
    Sep 7, 2012 1:30 PM   in reply to dslottdesign

    dslottdesign wrote:

     

    Anyone know any other fix without restarting or deleting prefs.

    Find the conflict that's causing it. This is not normal, so something else on your system is interacting.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 7, 2012 6:48 PM   in reply to dslottdesign

    Check your space bar one more time, it might be sticking. My MacBook Pro has a spacebar that sticks just a tiny bit every once in a while and it causes exactly the problem you are describing. The space bar is a short cut for the hand tool and while you can select other tools, it will always immediately revert to the hand tool as soon as you move your mouse back over the document.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 12, 2012 8:42 PM   in reply to dslottdesign

    I'm getting the same thing!! What the heck! Someone please help...I can't work!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 3:52 AM   in reply to Charles Dumont

    have you tried trashing the prefs?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 4:20 AM   in reply to dslottdesign

    Since you are the second report this is either a Mountain Lion-related bug or you have the same or similar local system conflict. Thos are not things we can fix from here.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 10:28 AM   in reply to dslottdesign

    Count me as a third - same problem... Intermittent and very frustrating.  The only reliable way to reset has been to quit the app and restart. I use ID 6-8 hours/day and this occurs 3-5 times per day.

     

    I'm working in Lion, however, not ML. MacPro (1,1) dual Xeon 3GHz, 12GB RAM, Radeon HD 5770.  I've not experienced the problem in any of the other CS6 apps, only ID.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 10:59 AM   in reply to cavedogstudio

    Could the three of you please report this as a bug: Adobe - Feature Request/Bug Report Form

     

    I'm not sure it is one, but it maight at least prompt someone at QA to take a look.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 1:46 PM   in reply to Peter Spier

    Done - thanks for your reply.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 8:20 PM   in reply to dslottdesign

    The same thing is happening to me. I'm on a MacBook Pro Retina, running bootcamp with Windows 7. While I'm on the Windows side I'm not able to select any of the tools. Keyboard shortcuts work, but I'm not able to select most tools with my mouse. I can't seem to trash my preferences, but even when I restart I'm still unable to select the tools.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 3:16 AM   in reply to eratcliff

    eratcliff wrote:

     

    The same thing is happening to me. I'm on a MacBook Pro Retina, running bootcamp with Windows 7.

    This is much more likely a case of using Large Fonts in the Windows interface: InDesign tools and panels don't respond to mouse clicks (Windows 7/Vista)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 22, 2012 11:29 AM   in reply to dslottdesign

    I hd the same thing happen and I'm on an imac in Mountain Lion. Thank goodness you guys posted this and I was able to trash my preferences. I will be reporting this as well. The more people who do that, the quicker they will be to fix the bug. By the way, in case anyone reading this doesn't know or remember, to delete preferences on a mac you hold down shift+control+option+command while starting InDesign and you will get a prompt asking if you want to delete the preferences.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 2, 2012 9:09 PM   in reply to sohcoh

    I tried the space bar trick and hit a few other keys before resetting preferences and it seemed to work. Thanks so much I was pulling my hair out!!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2013 6:46 AM   in reply to dslottdesign

    I am on a MacPro 2x2.4 Quad Intel Xeon, 8gb, 10.7.5 and using CC. I have this problem in all of the CC programs. My colleague is running Mountain Lion with CC and is also experiencing the same issue. This has been going on for a while. Also, besides the cursor not responding to any tool selection, the cursor will just dissapear and I have to click anywhere else but within my working document in order for the cursor to reappear. This is not acceptable Adobe. We pay a lot of money to use your programs and now with the new subscription plan we will be paying basically till we die just to make a living. Fix the bugs so that I can keep working efficiantly and in turn make enough money to eat and keep paying you.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2013 7:55 AM   in reply to Composite

    I've got a similar problem on a MacBook Air running ML and ID CC. But in my case I can't get the Hand or Zoom tool using the Spacebar, Cmd, Opt. variations.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2013 12:08 PM   in reply to dslottdesign

    Same thing happens on my Mac Pro running Mavericks. This is the third time in less than a week. Going to restart now. If that does not work, will throw away preferences. Really cuts down on productivity. As I am paying a monthly fee (as we all are now) this is a bit more irritating than owning the discs. Will report the bug.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2013 10:28 AM   in reply to dslottdesign

    Hi,

     

    What's trashing the prefs? I am experiencing a lot of issues and need a quick fix as I am in a super tight deadline, I have restarted the app around 10 times in the last 3 days, not fixing it. Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2013 10:38 AM   in reply to alinaalvarez00
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 18, 2013 5:57 PM   in reply to Peter Spier

    I tried removing my preferences, restarting my computer, running an update to 8.0.2, and restarting InDesign. I still can't use the page tools. My situation is using CS6 not via CC and running bootcamp with Windows 7 on a Mac. I haven't had any issues with Photoshop, but I'm completely dead in the water with InDesign. (EDIT) Peter, your comment on September 14th fixed this. Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 30, 2013 7:26 PM   in reply to dslottdesign

    I encountered this problem with a MacBook Pro (purchased 2013), running Win 7 on Boocamp.

    This article has the solution (helpx.adobe.com/indesign/kb/indesign-tools-panels-dont-respond.html) .

    I chose "Solution 2" (which is to turn off Aero Themes in Win 7) and it fixed this issue.

    "Solution 1" is to set the system font DPI to 100%. This was a non-starter for me given that have sight issues and can't see the font that small.

     

    On that note, I wish Adobe products would support accessiblity better and respect system settings for font size in their UI.

    Especially now that screens are getting larger, the fonts in CreativeSuite keep getting smaller and smaller proportionately.

    Please Adobe? Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 31, 2013 5:28 AM   in reply to beckypezely

    If it will make you feel any better, this issue is fixed in Windows 8 since

    there's no aero theme to turn off.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2014 10:39 AM   in reply to Peter Spier

    Count me as a fourth, or more... I will also report the bug. Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2014 4:10 PM   in reply to dslottdesign

    Not sure if this is the same issue... I have something similar happening in Illustrator and Photoshop once in a while. I'm on Windows 7, and I sometimes get stuck on the brush tool (Photoshop) or some unknown tool with a cursor I've never seen before in Illustrator. I can select other tools, but the cursor stays on brush and only performs the brush action. Restarting Photoshop fixes it.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points