Skip navigation
Currently Being Moderated

Deploying AAMEE 3.1 created MSI by double clicking it in UI mode

Sep 14, 2012 4:20 AM

Tags: #windows #aamee3.1

With the release of AAMEE 3.1, AAMEE created MSI supports both silent and UI based installation.

 

For UI based install of AAMEE 3.1 created packages, run the MSI as an administrator. If you are logged in as Admin user, you can double click it, otherwise right click the MSI and run as administrator. A minimalistic UI will be shown with just a progress bar. Any error during MSI install will cause a roll back and the user should check the logs to see what went wrong. You can also run the MSI in UI mode through this command line –

msiexec.exe /i <path of msi>

AAMEE still supports silent installation as the standard way of deploying the packages. Silent installation can be done only through the command line option –

msiexec.exe /i  <path of msi> /qn.

Make sure that the command line is invoked with admin privileges. For users using SCCM 2007 for deploying AAMEE created packages, make sure to check “Allow users to interact with this program” checkbox in Environment tab of the SCCM Program for UI based installation. The corresponding checkbox for SCCM 2012 is “Allow users to view and interact with the program installation”.

For uninstallation of MSI in UI mode, there is only a command line option –

msiexec.exe /x <path of msi>

For silent uninstallation, add the /qn switch with the above command line –

msiexec.exe /x <path of msi> /qn

This UI based installation is only supported by the packages created using AAMEE 3.1. If you are using AAMEE 3.1 beta or AAMEE 3.0 for CS6 packaging, please download AAMEE 3.1 from http://www.adobe.com/devnet/creativesuite/enterprisedeployment.html.

 

Feel free to mail me at skatariy@adobe.com in case you see any issues.

 

Thanks,

Saransh Katariya | Member of technical staff | Adobe Systems | skatariy@adobe.com

 
Replies
  • Currently Being Moderated
    Mar 8, 2013 7:01 AM   in reply to saranshkatariya

    I want to revisit this. You can also see my related posts here:

    http://forums.adobe.com/message/5073735

     

    I had contented myself that I would use a batch file and require users to right-click and run as admin on the batch file. This was so that I could get Acrobat 10 installed at the same time. However, now that I have Acrobat 11, and I can separate out the installers, I would like to get back to this "double-click" method. I've verified that my new package (without Acrobat) works using the msiexec command. However, it still doesn't work as a double-click.

     

    Here are the key lines from PDApp.log:

    3/8/2013 07:54:21 [ERROR] Setup - Error parsing command line arguments at - "DISABLE_CCM_DESKTOPSHORTCUT".

    Expected arguments are -

              --mode=silent

              --overrideFile="<FilePath>"

    3/8/2013 07:54:21 [FATAL] Setup - Administrative Privileges required to continue

    3/8/2013 07:54:21 [FATAL] Setup - End Adobe Setup. Exit code: -10

     

    However, I am an admin on the machine, just as I am on all the machines that I've tested this on. And when I use a batch file with the msiexec and right-click and run as admin, I don't have to put other credentials in, verifying that I am, in fact, an admin on the machine.

     

    Thanks for your assistance.

     

    Mark

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2013 7:16 AM   in reply to saranshkatariya

    I have the same problem as Mark, but with InDesign CS6.

    I get the same error on both desktop and from network share. This is as Administrator on Windows 7 x64 sp1 when trying the MSI from desktop:

    5/2/2013 15:46:25 [INFO] DeploymentManager - Bootstrapper launch location is :: C:\Users\larosc.HF\Desktop\hoh_indesign_cs6\Setup\Set-up.dat

    5/2/2013 15:46:25 [INFO] Setup - Build Version - 6.0.335.0

    5/2/2013 15:46:25 [INFO] Setup - Logging Level verbosity Set  to 4

    5/2/2013 15:46:25 [INFO] Setup - Start Adobe Setup

    5/2/2013 15:46:25 [INFO] Setup - TimeLog: Bootstrapper Start

    5/2/2013 15:46:25 [INFO] Setup - TimeLog: Start initial checks

    5/2/2013 15:46:25 [INFO] Setup - Action specified - "install"

    5/2/2013 15:46:25 [ERROR] Setup - Error parsing command line arguments at - "DISABLE_CCM_DESKTOPSHORTCUT".

    Expected arguments are -

        --mode=silent

        --overrideFile="<FilePath>"

    5/2/2013 15:46:25 [FATAL] Setup - Administrative Privileges required to continue

    5/2/2013 15:46:25 [FATAL] Setup - End Adobe Setup. Exit code: -10

    5/2/2013 15:46:25 [INFO] DeploymentManager - Build Version - 3.1.105.0

    5/2/2013 15:46:25 [INFO] DeploymentManager - Logging Level verbosity Set  to 4

    5/2/2013 15:46:25 [FATAL] DeploymentManager - The return code from the Bootstrapper Process is (1).Stopping the installation process.

    5/2/2013 15:46:25 [INFO] DeploymentManager - The install workflow is terminating.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points