Skip navigation
Belloq Quinn
Currently Being Moderated

Lighting effects seems to render only in bitmap

Sep 14, 2012 9:45 PM

Tags: #photoshop #problem #error #issue #image #plugin #effect #glitches #cs6 #lighting

it started about a week or so ago but when i tried using the lighting effects filter rather than showing  a shadowy gradient effect like it usually does it is either pue blakc or just shwos an unnafected picture and when i play with the lighting rig or change slider settigns like texture for example it flickers back and forth like it's broken

.http://imageshack.us/a/img577/5038/flickerscreenshot.png

 

but it works perfeclty in CS5 without a hitch.http://imageshack.us/a/img39/3383/properlighteffect.png

 

 

i tried searching to see if others had a similar problem but all i got was that CS6 either didnt coem with it installed or the app doesnt display correclty. i dont know what to do i dont want to keep goign to an older photoshop just to use it's basic features.

 
Replies
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Sep 14, 2012 11:00 PM   in reply to Belloq Quinn

    Can you verify that your CS6 is opening in 64-bit mode? Lighting effects in CS5 was not written for Mac 64-bit. CS6 had a revamp to 64bit support for Mac. This is the first thing I can think of asking you.

     

    Apart from this, I doubt your Graphic Card support for Photoshop.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Sep 14, 2012 11:34 PM   in reply to Belloq Quinn

    Open Finder. Navigate to Adobe Photoshop CS6, 'Get Info' for the app. You'll see if your application opens in 64bit mode.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Sep 15, 2012 12:35 AM   in reply to Belloq Quinn

    Open Photoshop CS6. Then Open Activity Monitor on your Mac. Search for Photoshop. One of the columns will show you 'Kind', where it will show you if its Intel (64-bit) or not. If it just shows Intel, your app is running on 32bit.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Sep 15, 2012 6:26 AM   in reply to Belloq Quinn

    I'm trying to reproduce the file you're working on. Can you help us understand the properties of your 2 other spot lights you have on the top of your canvas? Or, maybe, can you delete them and just try adding 1 light to reproduce your scenario and let us know if the issue still persists?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 12:13 PM   in reply to Belloq Quinn

    That looks like another GPU driver problem.

     

    Have you updated your driver from NVidia's website, and followed their directions for the update (to avoid bits of older drivers hanging around)?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 3:42 PM   in reply to Sudarshan Thiagarajan

    He's using Lighting Effects in CS6 -- not the old 32 bit plugin.

    And Photoshop CS6 is only a 64 bit application on MacOS.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 3:44 PM   in reply to Belloq Quinn

    Not very common.

     

    Are you on a laptop that might have switchable GPUs?  (GT 330M is usually a moble part)

    If so, have you tried disabling automatic graphics switching in the OS preferences?

     

    Which OS version are you using?

    Did you recently upgrade or update your OS?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 4:57 PM   in reply to Belloq Quinn

    I believe it's under the energy saver settings.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 5:13 PM   in reply to Belloq Quinn

    I don't know for sure, since I haven't seen that exact problem before.

    But it does appear to be a problem with the GPU drivers - and both those steps help stabilize and update the GPU drivers.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2012 8:16 PM   in reply to Belloq Quinn

    To update the drivers, you need to restart the computer.

     

    Turning off automatic switching should happen immediately.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points