Skip navigation
backpack45scb
Currently Being Moderated

Index Generation - output breaks in mid column when loaded

Sep 20, 2012 6:52 PM

Tags: #indesign #columns #space #index #break #generate #thin #en

I generate the index for a book and place it in pages with a master of two columns per page. It loads fine, but the page number references have too much space between them, so my index is larger than I want.

 

I change the page number separation to be comma followed by en space. I repeat the process with the new page separation, and about a column and a half in, I get an error indication and the index jumps to the next single column page.

 

If I repeat the process going into single column pages, it does work, but if I then apply the two column master page, the same problem. The behavior is as if the page number part of the index is non breaking.

 

I've attached two screenshots. The first is the original place where it stopped flowing into the column of a two column page. The second is where I just deleted a couple of digits from the leading number of the entry that didn't flow properly. A dozen or so lines then popped in.IndesignPC1.jpg

Second image follows:

IndesignPC2.jpg

Also, if you look at the second  image, it is splitting page numbers at the end of the column,

 

I had this same problem back in 2006. At that time it was suggested that the thin space, en space, etc wasn't recognized as a space so indesign looked at it as one long word. Seems like it should have been fixed since then.

 

Message was edited by: backpack45scb - added note about splitting page numbers across multiple lines.

 
Replies
  • Currently Being Moderated
    Sep 21, 2012 7:46 AM   in reply to backpack45scb

    En-spaces are non-breaking and I suspect that's where the problem lies. I fyou look closely you'll also see that the lists break between the number and the following comma in several places.

     

    Do you have any keep options applied to the paragraph style for the listings? My guess is you may have it set to keep the last 2 or 3 lines together, but noting for first lines. You might want to change that to keep all lines together if you don't want a listing to break across columns.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 21, 2012 4:19 PM   in reply to backpack45scb

    I'm not sure where you'll find it in the documentation, but all fixed-width spaces are non-breaking.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points