Skip navigation
CraigB1960
Currently Being Moderated

Horizontal crop rectangle not holding on vertical oriented photographs.

Jun 12, 2013 3:01 PM

Tags: #problem #lightroom_5

I am experiencing a problem with the crop rectangle on certain images in Lightroom 5.  Did not have this issue in LR4.

 

 

When I am cropping in a vertical photograph horizontally, the crop is successful, but when I move on to the next photography and come back it snaps back to the original crop.  It creates this "new" crop in the history, which I can go back to the last step and get back my crop.

 

 

Seems to be pretty consistent.  I'm using D800e Nikon RAW files.

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Jun 12, 2013 3:21 PM   in reply to CraigB1960

    Thanks for reporting this.  I was able to repro and have logged a bug.  It appears to be Windows-only (for me).  If you are on Mac, let me know your OS version so I can add that to the bug.

     

    Thanks!
    Becky

     

    ref #3577432

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2013 7:28 AM   in reply to +becs

    Becky,

     

    I'm on osx 10.8.4 and have not be able to reproduce this behavior  so far.  I will update if it changes.

     

    Update:I can reproduce this behavior.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 12, 2013 3:33 PM   in reply to CraigB1960

    Thanks Craig, I have updated the bug with your information. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 12, 2013 6:04 PM   in reply to +becs

    Happening to me on my mac pro, osx10.8.4

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 7:53 AM   in reply to CraigB1960

    Same problem here, OS X 10.8.3. This is seriously affecting my workflow - please patch ASAP!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2013 8:52 PM   in reply to CraigB1960

    OSX 10.8.4 - Crop is changing unexpectedly on images, vertical and horizontal. A serious problem, Lightroom is almost unusable.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2013 12:53 AM   in reply to surfacedream

    Mac OS X 10.8.4, happening all the time on us too.  Seriously regretting the upgrade right now.  Please fix as soon as possible.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2013 8:07 AM   in reply to CraigB1960

    I'm also regretting the upgrade. When will this be fixed?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 7:01 AM   in reply to CraigB1960

    Same problem

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 5:35 PM   in reply to CraigB1960

    I'm also having the horizontal crop of vertical image being lost issue.

    LR 5.0

    Win7 64bit

    RAW CR2

     

    VERY Annoying!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2013 8:13 AM   in reply to opusjeff

    To me it is happening only a few times and so randomly it is hard to anticipate. I can step back in history and recover my original corp. Mac Pro 10.8.4

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2013 3:00 PM   in reply to CraigB1960

    I'm having the same issue in cropping/rotating not holding. And like the post above, it's random....I can count on one to two photos in a set of say 30 to have this issue.  We provide different finishes on our photos as well, so we make copies of the pics and the copies have the same problem of not holding the crop/rotation.  This happens on both vertical and horizontal photos.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2013 7:43 AM   in reply to DCBOUDRE

    We really need an ETA on a fix for this.  It's hampering our workflow.  For us it's about 1 in every 5 photos that we try to crop/rotate.  I can't figure out what is common between them.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2013 11:17 AM   in reply to JeremyNeish

    You can be sure it *won't* be fixed before 5.1 (there will not be an intermediary quick-release, e.g. 5.0.1).

     

    My unofficial, but semi-informed estimate:

    ----------------------------------------------------

    At the earliest: mid-late August as a 5.1 pre-release (e.g. Release Candidate).

    At the latest mid-late September (again: not official - based on past release intervals).

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2013 4:59 PM   in reply to CraigB1960

    This is completely unacceptable!

     

    In addition to the crop bug, LR5 is running at a snail's pace for me, especially the spot removal tool.

     

    As a Cloud user, is there a way to revert to version 4? I can't find a way.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2013 9:48 AM   in reply to opusjeff

    I have made a video of the crop issue/bug, which demonstrates the problem: http://youtu.be/0AqijqKKTTM

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 7:51 PM   in reply to CraigB1960

    Thanks for reporting this.  I have the same problem.  And, it is consistent and reproducible.

     

    I am working with Canon 6D RAW files, on a 3 year old 27" iMac using OS 10.8.4, and Lightroom 5.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2013 9:07 AM   in reply to CraigB1960

    I'm having the same issue on a Windows 7 Thinkpad with JPEGs created from a Canon T2i. I just installed Lightroom 5 and had no previous catalog on this system. Every picture I have tried to crop from landscape to portrait reverts back to an oddly cropped landscape mode when I hit enter or select done.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 5:40 AM   in reply to CraigB1960

    LR5 keeps resetting the crop on my images, shot RAW on Canon 5D Mark III. Happens consistently on my iMac and Macbook Pro, both OS X 10.8.4

    This is undoing (=destroying) images which I believed to be safe in LR.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 8:20 AM   in reply to sonjabrenna

    Until Lightroom creates a fix, you could make a second copy, export to Photoshop, crop it and then save it back to Lightroom. Cumbersome but stable. Not helpful without Photoshop available of course.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 9:40 AM   in reply to mfbenedict

    You suggestions is  a good way to work around the issue temporarily, as long as one has only a limited amount of pics to edit. As you say, it's not a solution for a larger workflow. Today I am going through a job where I took portraits for corporate clients and I need to select* 2-3 of the best for each person to print - from hundreds of shots. I had previously spent hours and hours painstakingly in LR4 cropping them and now LR5 is resetting the crop almost every time I view a picture. This is not funny. I'll live, but in my opinion this is a core functionality, not a minor bug.

     

    (*Selecting means choosing the best pictures, soft-proofing with lab's ICC profile, make final color corrections and other adjustments accordingly, add border and export to jpg. That's why I need to be able to do it with LR.)

     

    This is going to take forever with the crops random resets!  Message was edited by: sonjabrenna

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 9:47 AM   in reply to sonjabrenna

    I agree that this bug and a couple other should have deserved a quick .01 release as they really affect the work flow and the workarounds are almost unusuable for large volume shooting.  Most of these SEVERE bugs were not in the beta.  We are going on 6 weeks since release of 5.0 so I agree with Rob Cole that you are probably going to have to wait till 5.1. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 9:56 AM   in reply to CraigB1960

    This is getting ridiculous! THIS IS A MAJOR ISSUE!

    Has adobe even acknowledged this yet?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 10:18 AM   in reply to sonjabrenna

    I completely agree with you. My suggestion is useless for a large volume of photographs. I am currently working on a series of shots that need Photoshop work unrelated to the cropping problem. Stepping in and out of Photoshop for one or two shots is fine. More than that wrecks your productivity. (And I encountered a new problem: the Lightroom image comes in to Photoshop CC as a big black nothing. The problem went away with a restart of Photoshop--for now.) We have come to depend on Lightroom for productivity and now we are paying the price--unless they fix this problem immediately! This is not glitch to be addressed in a future update. It needs to be handled NOW.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 11:12 AM   in reply to +becs

    I am on LR 5 with OS 10.8.4, 27" iMac with 16 gigs, and YES I have the same problem.

     

    I am curious, has Adobe been following this and the other issues with LR 5, and is there a plan to do anything about it? 

     

    LR 5 is basically unusable due to this and other bugs.  A quick-fix would be greatly appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 8:57 AM   in reply to CraigB1960

    After playing around with this a while, I noticed that my Navigator setting (top left) was Fill. When I changed it to Fit, my crops suddenly started to work properly. When I change it back to Fill, they revert to landscape.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 9:59 AM   in reply to Simcha Gralla

    That's wonderful. This will help Adobe fix it and help us cope in the meantime!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 12:17 PM   in reply to Simcha Gralla

    That doesn't work for me on a rotational crop of a vertical image.

     

    Try this:

    Using a vertical image, crop down to about 3/4 of image and rotate that crop about 15deg, keeping image centered vertically.

    Navigate to the next image, then navigate back to the first.

     

    My original rotation/crop loses it set crop and moves it, it "jumps" to a new LR-chosen crop.

    Fit or fill doesn't seem to help me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 1:02 PM   in reply to opusjeff

    I'm able to duplicate that with a crop rotation of a vertical image. My workaround only seems to help when making a horizontal image into a vertical one; those I can crop and rotate fine.

     

    Moral: Take only horizontal pictures :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 1:19 PM   in reply to CraigB1960

    I have not seen this problem in LR 5.  I don't use Nikon RAW though.

     

    PT

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 31, 2013 1:42 PM   in reply to CraigB1960

    Hi Craig,

     

    We are still working on this bug fix, so it did not make it into the release candidate.


    Becky

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2013 6:59 AM   in reply to +becs

    This is a major bug and really need a fast fix, it makes Lighroom 5 useless to me.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2013 7:09 AM   in reply to BenBullPhotography

    *TEMP FIX*

     

    I've been editing/cropping my raw file, then right-click 'edit in photoshop', 'save'... basically makes a TIF copy, but without the 'out of camera crop', so cant revert.

    Not ideal, but avoids reverting before exporting and upsetting your client!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 4, 2013 8:58 AM   in reply to BenBullPhotography
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 4, 2013 9:50 AM   in reply to CraigB1960

    I thought one of the benefits of a web-based subscription model was faster updates/fixes...  so much for that little bit of marketing spin!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 21, 2013 7:41 AM   in reply to opusjeff

    Possibly an extra piece of information on this bug. Yes, I do experience the crop shifting and I will insert a video to show it, I am using Lightroom 5.2 RC on a WIndows 64-bit computer. But my empirical observation, on my computer shows that the jumpy crop happens if the crop angle is over 6.2 degrees. It seems to stay put on rotation angles below that. Obviously I have not observed all possible angles but have tried some ranges to reach this conclusion, in other words my observation is based on sampling. You will see in the video that the crop rectangle is pulled to touch the bottom and the right edges, but after displaying the next image and returning to the previous one the crop rectangle jumps in an apparent attempt to center itself top to bottom. Although not shown in the video, if I reduce the crop rectangle it returns to the largest possible size, centered top to bottom after a visit to the next image and return.

     

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points