Skip navigation
Currently Being Moderated

Can not open Classic ASP files in upgraded CC version of Dreamweaver

Jul 9, 2013 9:55 AM

Hi All

 

Trying to simply open a classic asp file in my new version of Dreamweaver, won't work.

 

I had to reimage my machine that had my Creative Cloud subscription on it, but still had CS6 version on it. Did the diactivation etc so licencing all OK.

 

I have installed again on the new build but got the CC version as that is now the current version. Problem as so many people are finding CC don't support .asp files (or even the .aspx files)

won't even open the file.

 

I have tried converting the extentions in the disabled folder to the new format get a missing file error so can't do that.

 

So OK CC not for us, how do I get CS6 back you might ask. Simple from the response of the Adobe Chat support see below, I have to first pay a penelty charge to cancel my subscription and then BUY CS6 CD, sorry but thats what I bought 3 months ago, and I've already paid for it in the subscription for CS6.

 

If I could have a response from adobe at this ridiculus level of support that would be great, and if someone could tell this old engineer how to open his files (and not via notepad or VS2012, not in the mood for jokes) that would be even better.

 

 

For the many people who like me have used dreamweaver since the machromedia days a comment like "you will just have to buy the old version you had last week....' is just not good enough.

 

David, a very unhappy customer.

 
Replies
  • Currently Being Moderated
    Jul 9, 2013 10:23 AM   in reply to PitStop21

    Install the Legacy Extension

    http://blogs.adobe.com/dreamweaver/

     

     

     

    Nancy O.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 8:18 AM   in reply to PitStop21

    That's not really a sollution though.

     

    Is there a way to open .asp files in the newest version of DM yet?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 8:50 AM   in reply to PitStop21

    Hi PitStop21,

     

    I have tried steps below on my computer and was able to install the "ASP_JS_Support.zxp" extension. This has worked for me but I haven't tested the ASP pages yet. Make sure you backup your DW CC Configuration folder before trying these steps.

     

    1) Navigate to "C:\Users\username\AppData\Roaming\Adobe\Dreamweaver CC\en_US\Configuration\Menus".

    2) Open "Menus.xml" in DW or any other editor.

    3) Scroll to the bottom of the XML file.

    4) Copy and Paste the code below just before </menus>

    <menu name="_In-Context" id="DWMenu_Insert_InContext_Editing">

              <menuitem name="_Editable Region" file="Menus/ICE/ICEEditableRegion.htm" id="DWMenu_Insert_InContext_Editing_NewEditableRegion" />

              <menuitem name="_Repeating Region" file="Menus/ICE/ICERepeatingRegion.htm" id="DWMenu_Insert_InContext_Editing_NewRepeatingRegion" />

    </menu>

    5) Save the file and close DW.

    6) Try to install the "ASP_JS_Support.zxp" that you have converted using Extension Manager CS6.

     

    HTH

     

    Thanks

    Bhawna

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 3:50 PM   in reply to bgupta16

    Thanks for that, but how do you do the following?

     

    6) Try to install the "ASP_JS_Support.zxp" that you have converted using Extension Manager CS6.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 3:57 PM   in reply to FireworkCrazy

    OK, I've worked that out, but when I navigate to that folder there is a couple of folders in there but no files let alone one called menus.xml

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 8:59 PM   in reply to FireworkCrazy

    Have you checked in the DW CC Configuration folder? If its not there then probably something is wrong.

    1. Close DW CC.

    2. Navigate to "C:\Users\username\AppData\Roaming\Adobe

    3. Delete the Dreamweaver CC folder and launch DW CC again this should recreate that file.

    4. Now try the steps mentioned in my previous post again.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 3:30 AM   in reply to bgupta16

    Now, how strange!

     

    I deleted that folder and when I restarted dreamweaver it automatically showed asp files in the design and preview pane.

     

    Now, before i restarted it I also added .asp to  "edit > preferences > file types / editors > extensions"

     

    I wonder if this is what sorted it out. If so then I'm happy.

     

    I will try it on my other machine and see if it works on there.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2013 3:48 AM   in reply to FireworkCrazy

    Well that seems to work. Just adding .asp to the "file types / editors" as above.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2013 6:17 PM   in reply to PitStop21

    This is just stupid.  I have an entire website with pages that are a mix of .html, .php, and .asp extensions.  When I updated my template, only the php and html pages update.  The ASP pages do not. 

     

    If you don't want to keep supporting new updates to .ASP that's one thing.  But to completely remove all functionality?  Jesus Christ.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2013 10:39 AM   in reply to PitStop21
     
    |
    Mark as:
  • Currently Being Moderated
    Feb 5, 2014 8:27 AM   in reply to karindpowell

    All of this above is a bit confusing. I was helped through this process and was successful. Here are the steps below (Windows 8.1):


    1. Close Dreamweaver CC
    2. Go to Local Disk (C:)/Program Files (x86)/Adobe/Dreamweaver CC/configuration/DisabledFeatures
    3. Copy zxp files and paste them in a folder on your desktop.
    4. Open your extensions manager CC and go to File/Install Extension and Install everything.
    5. Open Dreamweaver and go to Edit/Preferences/File Types / Editors
    6. Add .asp to the left window and on the right window click the + button and go back to Program Files (x86)/Adobe/Dreamweaver and click on Dreamweaver.exe
    7. Don’t  change anything in the ‘open in code view’ below.

     

    That did it for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2014 2:08 PM   in reply to AlanBrown2323

    OK there is a solution to opening the .asp files in Dreamweaver whith a double click. The clue was here: http://forums.adobe.com/message/6091711#6091711 for PC users.

     

    HERE IS THE MAC EQUIVALENT: in the Finder, RIGHT CLICK any .asp file. select "Get Info"  Select "Adobe Dreamweaver CC" it may not show up at first, you will have the option to locate it in the Applications folder.

     

    DON'T FORGET to click the button below: "Change All" forcing ALL .asp files to open within Dreamweaver. *note: I tried everything else listed, including installing the "ASPNet_Support.zxp" extension found in "DisabledFeatures" in the "Configuration" folder, which did cause the icons inside of Dreamweaver to actually appear as DW docs. However try the finder option first it may be the quick fix.

     

    Here is the legacy extension insaller description: http://forums.adobe.com/message/5520693#5520693#5520693

     

    GetInfo.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2014 3:22 AM   in reply to PitStop21

    Yesterday I subscribed to Creatice cloud and saw with much regret that the new dreamweaver cc does not support ASP files.

    Today I closed the subscription

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2014 5:57 AM   in reply to fabrixnet

    DW hasn't supported ASP for several years and is not likely to add that support in any future release.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2014 1:16 PM   in reply to fabrixnet

    Microsoft hasn't supported asp files for years. With the steps above you can edit asp files on Dreamweaver CC

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points