Skip navigation
Currently Being Moderated

Why do apostrophes appear as  in the browser?

Oct 1, 2013 1:05 PM

In Muse I have text that reads "+£1.80 postage" but the browser displays "+£1.80 postage". Why the Â? I'm also getting "Giclée" instead of "Giclée". What's going on?

 
Replies
  • Currently Being Moderated
    Oct 1, 2013 2:01 PM   in reply to S. Jolliffe

    Hi,

     

    Do you see also this issue when you Preview in Muse or Preview in Browser?

    Or only when you upload to an FTP host?

     

    Abhishek

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 2, 2013 10:30 AM   in reply to S. Jolliffe

    Hi,

     

    Are you using the FTP functionality built into Muse or using your own FTP client? If the latter, there's a good chance that your FTP client is mangling the characters correctly encoded by Muse.

     

    Abhishek

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 2, 2013 5:17 PM   in reply to S. Jolliffe

    Hi,

     

    I don't know much about Cyberduck; maybe there is a specific setting that's causing the mangling.

     

    I'd still recommend using the built-in FTP functionality if you can. Did you enter "/public_html" as your Host Directory?

    Please try removing the slash, i.e., just "public_html" and let me know if that works.

     

    Thanks,

    Abhishek

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2013 3:35 PM   in reply to S. Jolliffe

    Hi,

     

    It sounds like your client's FTP server expects a different FTP mode setting (e.g., ASCII or Binary) than your own.

    Could I ask you to try FileZilla (https://filezilla-project.org/) to upload to your client's server, and let me know if that works?

     

    Thanks,

    Abhishek

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2013 10:13 AM   in reply to S. Jolliffe

    Hi,

     

    I'd suggest checking if there are any specific FTP settings recommended by your client's service provider. And/or trying FileZilla.

    I'm afraid I don't have any other suggestions at this stage; as you observed, the code produced by Muse is correct.

     

    Thanks,

    Abhishek

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2013 10:16 AM   in reply to S. Jolliffe

    You need to contact the hosting provider. The server is not properly configured to serve up Unicode (UTF-8) encoded HTML files.

     

    The reason re-typing the apostrophes in Muse _appeared_ to work is that what you've typed isn't actually an apostrophe. The key on the keyboard is a straight single quote (aka a foot mark). A typographically correct apostrophe curls toward the left (aka a closing single curly quote).

     

    This is a foot mark:   '

    This is an apostrophe:   ’

     

    At the font size you're using it's very difficult to tell the difference. Word automatically converts a typed foot mark into an apostrophe. Muse does not currently have that behavior, so a typed foot mark (aka straight quote) stays a foot mark.

     

    The straight single quote and the english alphabet are encoded the same in virtual every encoding system (as the 127 characters that are part of ASCII). Curly quotes, accented characters and alike are encoded differently in different encoding systems. When a text file is interpretted using the wrong encoding the result is what you're seeing.

     

    The server your client is using does not appear to be properly configured to serve up Unicode encoded HTML files.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points