Skip navigation
aikea
Currently Being Moderated

Disable code auto completion in Dreamweaver

Dec 25, 2007 11:22 PM

Every time when I type in an attribute dreamweaver insert two double quotes itself.

For example, if I type in "<body onl", the code hint will open, once I press TAB key, dreamweaver will automatically insert "onload" evenhandler for me. However, dreamweaver also insert a equal sign and two double quotes like this:

onload=""

and place cursor in the middle of the quotes. This looks like a nice feature, but every time I type a value I have to move the cursor out of the double quotation mark.

Because I am using a gaming keyboard, the arrow key is loacted at an very awkward location. I have to look for them every time I need them. That makes my typing extremely slow.

Even if I am using a normal keyboard, the arrow keys are always located afar from the main typing area.

I opened the Preferences but find there is only option for "Code hint" but not for the autocompletion. I want to use code hint to speed up coding but just want to get rid of that two quotation marks.
 
Replies
  • Currently Being Moderated
    Dec 26, 2007 4:16 AM   in reply to aikea
    aikea wrote:
    > I opened the Preferences but find there is only option for "Code hint" but not
    > for the autocompletion. I want to use code hint to speed up coding but just
    > want to get rid of that two quotation marks.

    The quotation marks are required for well-formed code. You either use
    code hints with autocompletion, or you turn off code hints. If you find
    using the arrow keys too much trouble, you could use forward delete to
    remove the closing quote, and type in your own. However, that seems to
    be just as much trouble as moving your hand to the arrow keys.

    --
    David Powers, Adobe Community Expert
    Author, "The Essential Guide to Dreamweaver CS3" (friends of ED)
    Author, "PHP Solutions" (friends of ED)
    http://foundationphp.com/
     
    |
    Mark as:
  • Currently Being Moderated
    Dec 28, 2007 5:57 AM   in reply to Newsgroup_User
    It's a good suggestion. Please let the dev team know....

    http://www.adobe.com/cfusion/mmform/index.cfm?name=wishform


    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "aikea" <webforumsuser@macromedia.com> wrote in message
    news:fl2tig$1vm$1@forums.macromedia.com...
    >I think adobe should remove this "quotation mark autocompletion" feature.
    >Every
    > time I complete an attribute value I have to use arrow key to quite the
    > quotation marks. I'd rather type in an end quotation mark myself and hit
    > space
    > key to start next attribute.
    >

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2011 7:29 AM   in reply to aikea

    Well it has 2 options you can do...with DW5.5,

    1. press Ctrl-U for Preferences (or goto Edit | Preferences)

    2. from Categories, select Code Hints

    3. The Options section is what you need to edit ...

        a. uncheck Enable code hints (this will stop the autocomplete of the single/double quotes but obviously removes code hinting)

        b. or change the delay to longer .. I set mine to 2 secs for now.. that way it you pause for 2 secs, THEN it will end the quote for you..

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 18, 2012 2:24 PM   in reply to Newsgroup_User

    Still a problem in 11.5/CS5.5 Sent another request to the Dev Team as follows; anyone please feel free to copy/paste as you wish:

     

    *******Enhancement / FMR*********

    Brief title for your desired feature: disable source edit quote mangling

     

    How would you like the feature to work? Let me turn off the "feature" where Dreamweaver (a) always inserts a second closing quote when I type a quote and (b) will not let me insert a quote or apostrophe when the next character is the same.

     

    Why is this feature important to you? It wastes time, is unintuitive, isn't at the user's discretion, and leads to coding errors. Turning off *all* code hints is not an acceptable solution. Code hints are great -- and the ones for jQuery may induce me to upgrade. But this quote mangling is and always has been a real annoyance. There's plenty of room in the code hint option dialog to let us turn it off.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 15, 2012 2:55 AM   in reply to aikea

    I am new to the Adobe Forums, but not new to Adobe software. is this the correct place to make request features?

     

    I want to support the requests made in this thread for there to be a tick box or some interface in the preferences for us to be able to turn the auto-quote marks off in Dreamweaver.

    I obviously don't want to have to turn off all auto-suggestion, just this one. Maybe a list of tick boxes where I can pick.

    Has this already been added and I am just not spotting it?

     

    I am at the point of investigating other dev software as this just doesn't seem intuitive, and is rather slowing me down.

     

    Most things in Dreamweaver are configurable which is great, but this seems to be one that isn't and is a problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 15, 2012 10:07 AM   in reply to Ethan Black

    Ethan, please see the "wishform" link above posted by Murray/Newsgroup_User. No idea if they ever do anything with the requests they get, but we can at least keep trying.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2012 11:38 PM   in reply to davidhbrown

    Thanks. Will keep trying

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points