Skip navigation
Currently Being Moderated

how do I get Adobe Elements 10 to recognize my printer?

Jun 4, 2012 11:37 AM

Tags: #64-bit #10 #7 #pse10

I just installed Photoshop Elements 10 and want to print a photo using my Canon 9000 Mark II printer. When I click "PRINT" it says first I have to install a printer. How do I install this printer so that Elements 10 recognizes it?  My operating system is Windows 7 64-bit.

 
Replies
  • Currently Being Moderated
    Jun 4, 2012 12:09 PM   in reply to luvsfotos

    There have been many reports about this problem with HP printers. I don't recall a report about Canon.

    There is a tech note re HP units:

     

    http://www.novadevelopment.com/search.html?search=greeting+card+factor y+deluxe&searchButton.x=34&searchButton.y=9

     

    Do check in Control Panel>Devices and Printers to be sure that your printer is the default.

    You may also want to check on the Canon web site for updated drivers.

     

    Please let us know how you make out with this issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 1:38 PM   in reply to luvsfotos

    Can you print a photo using MS Paint?

     

    Ken

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 10:54 AM   in reply to luvsfotos
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 1:36 PM   in reply to luvsfotos

    Have you installed the latest drivers for the printer from Canon's Web site?

     

    Ken

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 1:40 PM   in reply to photodrawken

    Recommended this in post #2. Not answered.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 3:13 PM   in reply to luvsfotos

    If it's a networked or wireless printer, you'll need to troubleshoot your connection parameters.

     

    Ken

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 3:52 PM   in reply to luvsfotos

    Did you reset the Editor's Preferences as suggested earlier?

     

    Ken

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2012 9:04 AM   in reply to luvsfotos

    The designation of a printer as "default" becomes unticked not infrequently. I don't know how this happems, but it has been reported on this board from time to time. That's why I pointed this out in my post #2. Please mark the answer as correct so that others surfing these pages may come upon the fix.

    Glad that you have it solved.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points