Skip navigation
Currently Being Moderated

Coldfusion 10 with IIS 7 Windows authenticaiton

Jun 20, 2012 11:39 AM

I enabled Windows authentication in IIS 7 for a site powered by coldfusion 10. After I logged in, a coldfusion page that dump all the CGI shows REMOTE_USER and AUTH_USER are empty.  The tomcatAuthentication has been set to "false" in server.xml. Does coldfuion10 support IIS Windows authentication? If yes, is there any document on how to configure it? Thanks.

 
Replies
  • Currently Being Moderated
    Jul 2, 2012 11:24 AM   in reply to hust93

    Did you ever figure this out?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2012 10:02 PM   in reply to hust93

    hust93 wrote:

     

    I enabled Windows authentication in IIS 7 for a site powered by coldfusion 10. After I logged in, a coldfusion page that dump all the CGI shows REMOTE_USER and AUTH_USER are empty.  The tomcatAuthentication has been set to "false" in server.xml. Does coldfuion10 support IIS Windows authentication? If yes, is there any document on how to configure it? Thanks.

    Hi hust93,

     

    Please refer to Kevlar's thread (where he posted the solution) here: http://forums.adobe.com/thread/1031711

     

    Thanks,

    -Aaron

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:38 AM   in reply to hust93

    You have windows authentication and anonymous authentication enabled at the server level and then on the folder you enabled windows authentication and disabled anonymous authentication and it still did not populate the CGI.remote_user variable?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2013 5:51 AM   in reply to hust93

    I just encountered the same problem. Did anyone ever find a solution to this? Switching to anonymous authentication and setting the restriction on folder level did not help here either.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2013 7:04 AM   in reply to hust93

    What browser are you using?  Some browsers are set to not forward credentials automatically, and instead, need to be configured to do so before the CGI-scoped variables will show up.  A while back when I used Firefox, you had to go into the about:config and search for these keys.

     

    Have a look here:

    http://sivel.net/2007/05/firefox-ntlm-sso/

     

    Now that I'm using Chrome, I don't think I had to go through a similar process with it.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2013 10:31 AM   in reply to Aegis Kleais

    MSIE, the same browser that worked with CF 9. Good thought, but this is definitely not a browser-related issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2013 4:54 PM   in reply to cielen.com

    Just to confirm, if you click on the site level in IIS 7 and goto AUTHENTICATION, it is enabled there right?  (vs. having maybe just enabled it at the server level, but the site has it disabled still)

     

    I know you said you're using IE, but is it possible to use Chrome and try the request?  Can you install the Web Developer Toolbar and then check under the REQUEST HEADERS to make sure that you see a large entry in the AUTHORIZATION header that is set to NEGOTIATE.

     

    If this entry is empty, then the browser is not sending any credentials to the server.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 1:10 AM   in reply to Aegis Kleais

    I think that we have tried every possible combination of authentication settings in IIS. Windows authentication was always activated on all levels and we have experimented with activating anonymous access on server, site and folder level in various combinations - including the one recommended in this thread - all to no avail.

     

    The MSIE browser that is used for testing is a standard browser configuration that is being used for accessing dozens of intranet applications all of which are accessed via integrated Windows authentication, many of them runing on ColdFusion 7/8/9 where cgi.remote_user is working fine but also MS Sharepoint etc. The only server where authentication is not passed through correctly is the one updated to ColdFusion 10. Experimenting with a different browser does not help because it definitely has to work with the standard browser configuration that is used throughout the enterprise.

     

    CF 10 is running on Windows Server 2008 R2/IIS 7.5 here. CF9 was running on the same system and Windows authentication was working fine (same browser, same IIS, same settings).

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 4:25 AM   in reply to cielen.com

    just to confirm: I have checked the request header and yes, authorization from the browser is sent correctly

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 6:36 AM   in reply to cielen.com

    And the server belongs to the same domain that the client browsing to it is connected to right?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 6:49 AM   in reply to Aegis Kleais

    yes. I wish it was that easy to solve The same server was running CF 9 before and everything worked fine until the upgrade to CF 10.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 7:41 AM   in reply to cielen.com

    In IIS, if you select the SITE and then AUTHENTICATION and then select WINDOWS AUTHENTICATION, in the right hand side, click on ADVANCED SETTINGS.  Is Kernel-mode authentication enabled?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 10:46 AM   in reply to Aegis Kleais

    Yes.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points