Skip navigation
Nixxx1959
Currently Being Moderated

Program errors

Jun 21, 2012 8:24 AM

I'm getting lots of "can't do.. becasue of program error" with layer masks and now eye dropper tool?

 
Replies
  • Currently Being Moderated
    Jun 21, 2012 8:28 AM   in reply to Nixxx1959

    What OS and photoshop version?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 8:56 AM   in reply to Nixxx1959

    Many problems in CS6 are linked to video drivers.  Not all the latest are the greatest.  What do you have?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 9:32 AM   in reply to Nixxx1959

    Don't know anything about that one.  Might check to see if you have latest dirver.  They are changing almost weekly to catch up to CS6 demands.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 9:59 AM   in reply to Nixxx1959

    Could you look in the Photoshop CS6 preferences folder and find the file PSErrorLog.txt - then paste the contents of that here?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 11:04 AM   in reply to Nixxx1959

    It's in the Photoshop preferences folder, that file is created (and appended to) whenever Photoshop shows a program error.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 12:00 PM   in reply to Nixxx1959

    No, I can't find either.  Only one that shows errors I know of is the Event Log.  Check OS Help for that.

     
    |
    Mark as:
  • Noel Carboni
    23,482 posts
    Dec 23, 2006
    Currently Being Moderated
    Jun 21, 2012 12:14 PM   in reply to Nixxx1959

    Nixxx1959 wrote:

     


    where is the Photoshop preferences folder?

     

    See this reference:  http://helpx.adobe.com/photoshop/kb/preference-file-functions-names-lo cations.html

     

    It says CS5, but do appropriate substitutions (6 for 5, 60.0 for 12.0) and you'll find the stuff for Photoshop CS6.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 12:27 PM   in reply to Noel Carboni

    Noel,

     

    Nixxx is looking for Photoshop CS6 preferences folder and find the file PSErrorLog.txt from post #7.

     

    Do you know where it is?

     
    |
    Mark as:
  • Noel Carboni
    23,482 posts
    Dec 23, 2006
    Currently Being Moderated
    Jun 21, 2012 12:33 PM   in reply to Curt Y

    If a PSErrorLog.txt file has been created, it will be here on a Windows 7 system:

     

    C:\Users\your_username\AppData\Roaming\Adobe\Adobe Photoshop CS6\Adobe Photoshop CS6 Settings

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 22, 2012 7:04 AM   in reply to Nixxx1959

    Not much on the web with this error.  Try resetting your preferences by starting PS and IMMEDIATELY holding down Ctrl + alt + shift.  If you beat the splash screen you will see a reset window.  Say yes.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 4:22 AM   in reply to Nixxx1959

    FU**!!! I have the same problem! And I even can't save my work made within a few hours!!!! But I can't reset prefs. I'll loose what I made! What to do?    

     
    |
    Mark as:
  • Trevor Dennis
    5,898 posts
    May 24, 2010
    Currently Being Moderated
    Jun 30, 2013 4:34 AM   in reply to Anri Orlow

    Are you still in trouble?  Has Photoshop frozen completely?  Looks like you can access other apps - like your web browser.  Tell us about the file that you are about to lose?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 4:43 AM   in reply to Trevor Dennis

    Yes, still in trouble. Photoshop works normally, but can't save anything except jpg. I had scratch drive set to D (D:\PSAutoRecover\Anrio). There was auto recover file, I opened it and there was some data form earlier stage of my work. I closed it, photoshop ask "save changes?" (I didn't make any changes though), I said "no" and file dissapered in original folder! Whatever I tried to do next, changing scratch drives, trying to save again, waiting for new automatic save - no, there's no any autosave file in any location it could be. In PSErrorLog.txt I have following:

     

    2013:06:30 14:35:26 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 14:45:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 14:54:38 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 14:56:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 14:56:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 14:56:44 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:04:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:05:59 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:06:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:09:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:11:25 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:11:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:13:50 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:18:38 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:23:26 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:28:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

    2013:06:30 15:33:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

     

     

    My system - Win 8 x64, PS CS6 13.0.1

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 4:48 AM   in reply to Anri Orlow

    And also I can't find this USheet.cpp anywhere.

    It's not first time I face with similar problem, errors appear very frquentlym even with simpliest operations as crealing regtangle for instance. Nothing helped than but restart. Now I can't restart as I'll loose all my work

     
    |
    Mark as:
  • Trevor Dennis
    5,898 posts
    May 24, 2010
    Currently Being Moderated
    Jun 30, 2013 4:59 AM   in reply to Anri Orlow

    How many layers?  Thisis the second time to day I have suggested this, but if you can save as a JPG, then it sounds file dependent.  Select all the layers, right click and chose Duplicate layers.  Use the drop down and chose New.  See if you can save that as a PSD.  I have used this trick a few times to get out of a messed up file.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 5:09 AM   in reply to Trevor Dennis

    Interesting... I delited one group and tried to save file. Wow! It works!! I found that one vector layer causes this problem, I deleted it and everything works! Thank you, great thanks! You really helped me!

     
    |
    Mark as:
  • Trevor Dennis
    5,898 posts
    May 24, 2010
    Currently Being Moderated
    Jun 30, 2013 5:15 AM   in reply to Anri Orlow

    Well the last time I had a similar problem, I tried really hard to isolate it to a single layer, but couldn't.  Moving 'all' the layers to a new document got me out of trouble though.

     

    If the shape layer was messing you up, you could have tried rasterizing it, saving, reopening, and change the rasterized layer back to a vector in the Paths panel.  Or Ctrl clicking to load the selection, and filling on a new layer, and then deleting the problem shape layer.  Sorry if that was 'bleeding obvious' - hmmm what comedy program did that come from?  Or was it just a put down as in "You should be on Mastermind, specialist subject 'The bleeding obvious'".    I'll get my coat. :-(

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 10:54 AM   in reply to Trevor Dennis

    Oh, it's s***. I make simpliest changes and this idiot says "could not save....". I add regtangle, only simple regtangle and I get error. It's a highest poit of stupidity!!!!!!!!!!!

    I feel i'll go back to CS 5.5, but it does not support retina...

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 10:55 AM   in reply to Anri Orlow

    Will re-installing solve the problem, what do you think?    

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 4:50 PM   in reply to Anri Orlow

    i have tryed to reinstall it and it worked , you can try it . else you must find a solution where the problem might be

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 3:28 PM   in reply to nez3398

    I reset settings and it helped. Oh...)

    Thanks for advices!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points