Skip navigation
Currently Being Moderated

(Illustrator CS6) Spacebar stops working seemingly randomly

Jun 21, 2012 9:53 AM

Tags: #bug #cs6 #spacebar

This is an infrequent issue I've had, but it has happened more than once in the last few weeks that I've been using CS6 on a regular basis:

 

On occasion, my spacebar will just stop working in Illustrator CS6, so I can't use the hand tool or zoom or… you know, type, basically making Illustrator unuseable. Now, I'm PRETTY sure it has nothing to do with my actual keyboard, because the spacebar will continue to work just fine in every other application even after it does this.

 

The only fix is restarting the computer. Just restarting the application doesn't do it. Deleting the preferences file and restarting doesn't fix it. It's really perplexing.

 

Now, I'm NOT certain about this, but I think it might occur after waking from sleep (but not immediately, so perhaps it's unrelated). If/when it happens next, I will attempt to see if I can reproduce the issue, but so far I have no idea why it happens; it just seems random.

 

I'm using a late 2008 MacBook Pro with 8GB of RAM, running Mac OSX 10.7.4 and Illustrator CS6 (16.0.0, in case people see this after an update has been released).

 
Replies
  • Currently Being Moderated
    Jun 21, 2012 3:52 PM   in reply to Gordon McAlpin

    Make sure your OS X Spotlight keyboard shortcut is turned off. (the default is command-space) 

     

    System Prefs > Spotlight.  (menu shortcut at bottom of window)

     

    There might be some other OS X keyboard shortcuts that are using the spacebar too.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 4, 2012 11:24 PM   in reply to Gordon McAlpin

    I am having this problem as well, but happening quite frequently.

     

    Also having Illustrator crashing a lot randomly as well.

     

    Tried 32bit as well - same issue.

     

    I've deleted settings as well - same issue.

     

    I've tried this with multiple files, old and newly created in CS6. Same problem.

     

    No issues with CS5.

     

    Win7 x64 SP1

    16GB RAM

    128GB SSD

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:10 AM   in reply to Gordon McAlpin

    I've run into this problem and having searched other forums, I found there was a conflict between Adobe and Chrome (at least in my case).  I hate having to shut down Chrome, but at the moment, that's the only fix I can find.  I want to find a way to disable Chrome's shortcut keys, but can't seem to find it.

     

    Good luck.

     

    Tim

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 11:52 PM   in reply to mememetx

    Not a Chrome user here.

     

    Was using firefox and tried with nothing else open at the time to replicate.

     

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2012 9:00 AM   in reply to VisualJazz

    There are some Firefox add-ons which will induce this problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2012 10:10 AM   in reply to Gordon McAlpin

    Gordon, others,

     

    Item 7 in Other options  is a list of usual suspects.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 7:39 AM   in reply to Gordon McAlpin

    I have the same Problem on 10.8. It was fine on 10.6.8.

    I use neither Chrome nor Firefox.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 9:01 AM   in reply to cmyck

    Are you using any Growl notification software?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 10:13 AM   in reply to Larry G. Schneider

    Nope. I think it's got to do with Safari.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2012 9:04 AM   in reply to Gordon McAlpin

    I'm having the same problem. I can't pinpoint a fix yet, but a workaround is to close all browsers. It seems to correct the issue for me...every time so far. I'm running on Mac-OS 10.6.8.

     

    My troubleshooting thus far (re: illustrator & photoshop CS6 - hand tool stops working) = conflict between browser and illustrator/photoshop...that's as far as I am. Sorry for the vague, non-tech response, but it's all I got so far

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 24, 2013 7:04 AM   in reply to Gordon McAlpin

    I have found out there is a conflict between Adobe and 1Password. Quitting 1Password brings back my spacebar.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2013 4:38 PM   in reply to Joerg Klaus

    Thanks for mentioning that, Joerg -- 1Password's what was causing the problem for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 11:19 AM   in reply to G Snyder

    Odd. I was not having this problem before, but today it happened in BOTH Manga Studio 5 AND Photoshop CS5 while working in both! I was only running Safari at the time and even though I have 1Password 3 installed, the app was not running at the time, but the Safari extension was. I've had this setup for a long time though, why would it start affecting two different apps this way now??

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2013 12:55 PM   in reply to bre-bro

    It was 1Password Chrome Extension in my cause: I installed the beta version of the plugin now the shortcuts are working again in Photoshop and Illustrator.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 12, 2013 9:44 AM   in reply to Gordon McAlpin

    For what it's worth, I had this problem -- not with the spacebar turning the cursor into a hand, but with the spacebar not producing a word space. I tried everything suggested here, and even uninstalled and reinstalled the app (CS 5.5, on a Mac Pro running 10.6.8). Finally determined it was ... the document, of all things. Copied the art/elements onto a new page, and suddenly could type again. Bloody hell, as the Brits would say....

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 5:40 AM   in reply to Mike Diehl

    was having exactly the same problem until today. i found it where is the conflict on my computer. was using fluid with the browserapp "teuxdeux", in teuxdeux you can write, grab and move text around. all was working fine until i move a word there. in this moment the spacebar stopped working on illu and indesign. closed the app, anything is working fine again.

     

    i'm not shure, but i guess it is a conflict with ajax features what is causing the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2013 10:23 AM   in reply to fsoubiran

    I just had teh same issue but with InDesign CS6 and it was a conflict with 1Password as well. Once I closed it the hand/spacebar started working again.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2013 10:14 AM   in reply to wistfullull

    I've finally figured out the cause of this infuriating bug! It happens if you use COMMAND-H to hide any other windows or software you have open. If you avoid doing this, you will not trigger the bug. So to minimize windows simply click the yellow window icon. Let me repeat this- if you use COMMAND-H to hide anything, it makes the space-bar hand tool trigger stop working.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 9:32 AM   in reply to tduane62!

    For what it's worth, I had the same problem today with AI CS6 on OSX 10.8.4. For me the space bar started working again when I quite Terminal (of all things!)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2013 2:01 PM   in reply to Gordon McAlpin

    In my case it was a conflict with the Spotify App. The space bar controls play/pause ...not sure how to disable it in Spotify or why when Illustrator has focus it matters.

     

    Glad I found this thread---thanks!

     

    ...but I hope Adobe fixes this, it's really frustrating as the hand tool and the magnifying glass are *integral* to my illustration workflow.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2013 12:26 PM   in reply to Joerg Klaus

    I had the problem (Spacebar Hand not working) in Photoshop CS6, and read here about 1Password - found I had it open - but not logged in in the background.

    Quit it and Hand works.

    I then opened 1Password and signed in, Spacebar still works.

    Maybe when it's in it's Unlogged in state there's a conflict?

     

    Whatever- for me 1Password was the culprit.

    Thansk to you all for a solution. It was driving me crazy.....

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2013 1:49 AM   in reply to Gordon McAlpin

    I had the same Probleme on PS and after reading all your answers i still had the problem also because i don't use chrome and 1 password so i closed alle applications also deactivated the spotlght shortcut on my mac and i still had the problem alfter closing everything that could be closed i just tried to close the
    ADOBE CREATIVE CLOUD APP in the system bar and it started immediatly to work so i relaunched the app activated again the shortcut for spotlight and everything is working fine now...

     

    I think the creative cloud app needs maybe a restart then you can still use it withoud any problems

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 3, 2013 8:50 AM   in reply to Francesco83MI

    Same problem. Spacebar grabber hand and zoom tool was not working in CC apps. Like

    Francesco83MI, this worked for me as well. Quit CC app and it immediately starts working again. I then restarted CC app and it still works.
     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2013 4:12 PM   in reply to Francesco83MI

    Adobe CC needs something more than restart...I suppose an update...I was tried everything but spacebar shortcut is still blocked on my windows 8.1

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 3, 2014 10:12 AM   in reply to Gordon McAlpin

    NONE of this worked for me. I have had this problem starting in CS6 and still in CC. The ONLY thing that works is restarting the whole machine. Which is overkill in this day and age. Reminds me of 1997 working with Crash 4… errr… I mean Flash 4.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2014 6:08 PM   in reply to Gordon McAlpin

    I have the same problem, but if I close my browser such as Chrome/Firefox/Safari out, it seem to work again.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2014 6:56 PM   in reply to Gordon McAlpin

    This issue drove me nuts and none of the suggestions in multiple threads helped (including shutting down all other applications, restarting and resetting preferences). I haven't managed to find a full solution to the problem but I did find a bit of a workaround which may help someone. I'm on Windows 8.1 BTW.  If I hold down the Alt key together with the spacebar the hand icon "grabs" and allows me to drag the canvas around.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points