Skip navigation
This discussion is locked
Currently Being Moderated

FAQ: What OS does Photoshop Elements run on, or Will PSE run on my computer?

Feb 10, 2014 3:31 PM

Tags: #photoshop #run #lion #mac #elements #install #windows #xp #vista #8 #7 #system #service #os #snow #leopard #support #installed #work #compatible #requirements #pack #tiger #mountain #sp

There are many different combinations of Photoshop Elements (PSE) and the Operating Systems (OS) it is supported on. Here is a table to help identify which versions of PSE are supported on which versions of Windows and Macintosh. By "supported", we mean that the application is designed and thoroughly tested to work on. Just because a platform is "unsupported" does not necessarily mean that it will not work. What it does mean is that you operate the application on that platform at your own risk. In most cases, a version of PSE is "unsupported" on a specific platform simply because it was released before that version of the OS.

 

The minimum system requirements (including supported platforms) for the current version of Photoshop Elements can be found here: http://www.adobe.com/sea/products/photoshop-elements/tech-specs.html

 

The minimum system requirements for all previous versions of Photoshop Elements can be found here:

http://helpx.adobe.com/x-productkb/policy-pricing/system-requirements- photoshop-elements.html

 

 

Version of Photoshop ElementsWindows XP
Windows Vista
Windows 7Windows 8

Mac OS 10.4.x

Tiger

Mac OS 10.5.x

Leopard

Mac OS 10.6.x

Snow Leopard

Mac OS 10.7.x

Lion

Mac OS 10.8.x

Mountain Lion

 

Mac OS

10.9.x

Mavericks

Photoshop ElementsX------††††

††

Photoshop Elements 2X------††††

††

Photoshop Elements 3X------††††

††

Photoshop Elements 4X---X--††††

††

Photoshop Elements 5 †XX1--

Photoshop Elements 6XX--XX----
Photoshop Elements 7 †X*X--

Photoshop Elements 8X*XX-XXX---
Photoshop Elements 9X*XX--XX---
Photoshop Elements 10X**XX#-XXX--
Photoshop Elements 11X**XXX--XXX##
Photoshop Elements 12X**XXX---XXX

 

* -  Requires Service Pack 2 or later

** - Requires Service Pack 3

# - Minimal product testing has been performed on this OS. No issues are known to exist.

## - The Comic Book Filters (Filter > Sketch > Comic/Graphic Novel/Pen and Ink) will cause Elements 11 Editor to crash on Mac 10.9.

1 -  Requires the 5.0.2 update

† - This version not available for Mac OS

†† - This version is designed to operate on a PowerPC-based computer. Starting with 10.4, the Mac OS supported both PowerPC and Intel processors. Continued support of PowerPC-based applications on Intel-based computers was made available through the use of Rosetta. In version 10.6, the Mac OS no longer supported PowerPC processors. Starting with version 10.7, Rosetta was discontinued, PowerPC-based applications no longer operate on this or later versions.

[NOTE: Photoshop Elements versions 1-3 ran on earlier version of the Mac OSX platform. For brevities sake, I've only included the 6 latest versions of that OS.]

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points