Skip navigation
DDH10
Currently Being Moderated

CS6 - cannot save due to program error

Jul 1, 2012 3:00 PM

Tags: #photoshop_cs6_beta

I CAN NOT SAVE ANYTHING IN PHOTOSHOP CS6.

KEEP GETTING THE MESSAGE "CAN NOT SAVE (TITLE & TYPE OF FILE) BECAUSE OF PROGRAM ERROR.

THIS HAPPEND ALL OF A SUDDEN. I'VE BEEN USING THIS FOR ABOUT THREE MONTHS.

THIS EVEN HAPPENS WITH OLD COMPLETEF FILES. CAN ANYONE HELP ME.THANK YOU

 
Replies
  • Currently Being Moderated
    Jul 1, 2012 3:00 PM   in reply to DDH10

    First, get the caps lock key on your keyboard fixed.

    Most people won't even read all caps (considered shouting, and rude in most languages).

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2012 6:53 PM   in reply to DDH10

    Program errors are logged in your preferences folder in a file called PSErrorLog.txt.

    If you could find that file and post the last 50 lines here, that might tell us something.

     

    Also, which OS version are you using?

     

    And do you have any system utilities that would affect file IO (backup programs, file sharing software, odd anti-virus software, saving to a file server, etc.)?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2012 10:08 PM   in reply to DDH10

    It would be in your Photoshop preferences folder (~/Library/Preferences/Adobe Photoshop CS6 Settings/PSErrorLog.txt).

    That file is created or appended to whenever you hit a program error.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 13, 2012 7:13 AM   in reply to Chris Cox

    Would like to add that we're also seeting this where I work and I'm also not able to find any PSErrorLog.txt file in ~/Library/Preferences/Adobe Photoshop CS6 Settings

     

    Could it be somewhere else?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2012 8:48 AM   in reply to Chris Cox

    I too am now receiving this dialog regularly. Has a solution been found? Here is my PSErrorLog.txt contents:

     

    2012:09:14 11:38:02 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:38:06 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:38:12 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:38:31 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:39:10 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:39:21 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:51:40 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:14 11:51:55 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:16 22:49:47 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:16 22:49:51 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:16 22:49:54 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:16 22:51:38 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 09:51:30 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 09:51:40 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 09:56:35 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 09:56:42 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 10:29:50 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 10:31:19 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 10:34:30 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 10:35:04 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

    2012:09:18 10:36:52 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120808.r.519/photoshop/mai n/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2012 9:32 AM   in reply to DDH10

    I am also able to consistently reproduce this error after loading a selection from a layer when cmd+clicking on the layer icon.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2012 3:10 PM   in reply to dezion

    In your case something bad is happening -- data that should be present isn't there.

     

    We need to get EXACT steps to reproduce the problem so we can debug it.

    With the steps you've given so far, I'm not seeing any problems.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 5, 2012 3:49 AM   in reply to Chris Cox

    I am getting the same error.

     

    It occures in these cases:

    • When I try to save document into PSD (using save as or save dialog) - save for web works OK
    • When I try to use X key to swich paint colors (colors change but its visualisation remains the same)
    • When I pick a color using a color picker

     

    There is only one error in error log "..\..\sources\USheet.cpp : 454 : REQUIRE failed"

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 5, 2012 8:03 PM   in reply to Tom Hnatovsky

    First, make sure you have the 13.0.1 update installed.

     

    And again, we need ALL the steps necessary to reproduce the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2012 4:38 PM   in reply to Chris Cox

    I tested it right now and made just a few actions:

    • Launched Photoshop CS6 Extended 64 bit
    • Clicked on Help and selected About Photoshop (have 13.0.1 version)
    • Closed about screen
    • Reopened a PSD file (From Files menu)
    • Clicked X key (got an error message about internal program error)
    • Created a rectangle
    • Clicked on save in Files menu (got an error message again)
     
    |
    Mark as:
  • Noel Carboni
    23,534 posts
    Dec 23, 2006
    Currently Being Moderated
    Oct 6, 2012 7:12 PM   in reply to Tom Hnatovsky

    Why do people think that saying "got an error message about internal program error" is detailed enough?   Do you think that's the only error message that could possibly be generated by Photoshop?

     

    Would it be so hard to quote the exact text of the message, or even take a screenshot and post it?

     

    In any case, here's what you do, Hnatovsky:  Reset your preferences to defaults.

     

    1.  Close Photoshop.

     

    2.  Start Photoshop and immediately press and hold Control - Shift - Alt.  If you get the keys down quickly enough - and you have to be very quick - Photoshop will prompt you to confirm deletion of your current preferences.

     

    3.  Confirm the deletion and Photoshop will start up with default preferences.  Chances are good your problem will be solved.

     

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2012 9:09 PM   in reply to Tom Hnatovsky

    Those steps alone don't show any errors for me.

     

    There's something else you're leaving out -- a third party plugin, timing, or something else you've overlooked.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2012 4:27 AM   in reply to Noel Carboni
    1. The error has been described in the first post of this thread
    2. Someone could have localized Photoshop environment and only guess what might be the text of the error in English (for me it is: "Nelze uloži <filename>, protože se vyskytla chyba programu" - simply the same as in the first post.. and the second message is just missing filename "Požadavek nelze dokončit, protože se vyskytla chyba programu.")

     

    Your suggested preferences reset helped me, thanks. It should be suggested by Adobe automatically.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 21, 2012 7:11 PM   in reply to Tom Hnatovsky

    Hi guys,

     

    This my post is not about the reason of the problem, but I just want to share my succesful experience just to save the affected file:

     

     

     

    Switch the visibility of all the layers off. When you have a bunch of invisible layers, the file can be safely saved. {You would be better to try it with a copy of the same file using that bottom icon of the History panel before definitely closing your orignal work. Just do a copy, switch the layers off, save that copy and try it to reopen. If all is OK, switch desired layers on and now you should be able to save the file nomally. All should be all right — your file is saved! But be prepared, this issue coud happen from time to time...}

     

    Hope this could be helpful…

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 4:55 AM   in reply to ChristianAaltonen

    I just encountered the same error,

     

    I'm on Windows 8, Adobe PS CS6.

     

    My fix was to disable the folder masks and it worked, allowed me to save

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points