Skip navigation
Currently Being Moderated

Merge to HDR Pro causes CS6 to Stop Working

Jul 7, 2012 4:22 AM

Having a problem which is easy enough to replicate when using Merge to HDR Pro ... either directly from within CS6, from LR4 or from Bridge it is causing CS6 to stop working.

 

What happens is that if you are using Merge to HDR then switch to another application causing Merge to HDR to lose focus eventually it will not recover and the Cancel/OK buttons are greyed out and not available. It never recovers from there.

 

Typical symptoms where Merge to HDR stops working (and therefore CS6) are the following:

- Any sliders that had been adjusted prior to this happening are available to change, others are not;

  - Any sliders that are greyed out can still be returned to their default value by double-clicking on the slider.

 

Photoshop has to be 'killed' before it can be used again.

 

These symptoms arerepeatable in the 32 bit version of CS6, the more files that are merged the quicker it happens. For example if you start with the "Photorealistic" preset and have 3 files open (opended using Camera Raw, Canon 5D mkII CR2 files therefore ProPhoto RGB; 16 bit; 5616 by 3744 (21.0MP); 300ppi)  it happens withing a couple of times switching to other applications and back but with 9 files open it will happen faster.

 

And it also happens with AdobeRGB (8bit), ProPhotoRGB (8bit) and sRGB (8bit).

 

Happens from both x64 and x32 systems.

 

The environment is follows:

 

Adobe Photoshop Version: 13.0 (13.0 20120315.r.428 2012/03/15:21:00:00) x64

Operating System: Windows 7 64-bit, Version: 6.1 Service Pack 1

System architecture: Intel CPU Family:6, Model:10, Stepping:7 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, HyperThreading

Physical processor count: 4

Logical processor count: 8

Processor speed: 2195 MHz

Built-in memory: 8173 MB

Free memory: 6153 MB

Memory available to Photoshop: 7231 MB

Memory used by Photoshop: 60 %

Image tile size: 128K

Image cache levels: 4

OpenGL Drawing: Enabled.

OpenGL Drawing Mode: Advanced

OpenGL Allow Normal Mode: True.

OpenGL Allow Advanced Mode: True.

OpenGL Allow Old GPUs: Not Detected.

Video Card Vendor: NVIDIA Corporation

Video Card Renderer: GeForce GT 540M/PCIe/SSE2

Display: 1

Display Bounds:=  top: 0, left: 0, bottom: 1080, right: 1920

Video Card Number: 1

Video Card: NVIDIA GeForce GT 540M

OpenCL Version:

Driver Version: 8.17.13.142

Driver Date: 20120515000000.000000-000

Video Card Driver: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Video Mode: 1920 x 1080 x 4294967296 colors

Video Card Caption: NVIDIA GeForce GT 540M

Video Card Memory: 1024 MB

 
Replies
  • Currently Being Moderated
    Jul 7, 2012 7:57 AM   in reply to BKKDon

    Thank you for the detailed post.

     

    The one thing that I did not see was your HDD setup, and especially how you have your HDD's allocated, with such things as Scratch Disks, etc. That might be useful knowledge.

     

    With Win7-64, the 8GB RAM is a bit light, as Win7-64 is a RAM hog, and Scratch Disks will most likely come into play, and especially with HDR.

     

    Now, if you do NOT switch out of PS, while doing an HDR Merge, does it then complete, i.e. is it only when it loses focus, that it hangs?

     

    What are your PS Memory and Cache settings?

     

    Do you have any active-scanning anti-virus, anti-malware, anti-anything running?

     

    Is Windows Indexing ON - though with Win7-64, it has become much less of a problem, than with older OS's?

     

    What are the Image Size of the HDR Images?

     

    Just thinking about some possibilities.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 8, 2012 8:27 AM   in reply to BKKDon

    I am not having lock up problems, but neither Photoshop CS6 or LR4.1 will process my HDR images from Nikon NEF files. I have the latest ACR installed on a Windows 7 machine.

     

    After researching this issue and seeing a few similar posts, I tried exporting all of an HDR sequence from NEF to TIF files, then running the Automate command. It worked fine on a nine shot bracketed set, converting the group into a single 32 bit image. I only tried the option to export my NEF files to 8 bit TIFs and not 16 bit files, but I have a feeling it would work.

     

    Hope this helps,

    M. Jackson

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2012 1:39 PM   in reply to jh_photos

    Hi

     

    I've hit on this issue tonight, and after a load of random clicking I managed to resolve it (Or at least find a workaround). This works for me on OSX at any rate - I hope that as the bug is present on both Win and Mac that this workaround might also apply to both....

     

    To get the buttons and sliders to re-enable, click into one of the number fields - I've never had them all greyed out - then toggle to another app and back again. This seems to unlock the buttons again.

     

    I've found that CS6 has a bunch of weird instabilities with toggling back in from other apps... All of them really annoying... come on Adobe, get it sorted...

     

    K

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2012 10:17 PM   in reply to KiersM

    I don't run HDR often, more often, Stitch. So I tried HDR tonight and could not make it fail, even running the one software that has given CS6 fits in the past while HDR test ran.

     

    No freezes.

     

    I'm running CS6 on Win7 64 bit, a more expansive machine with 12G RAM and a separate scratch, ATi and not nVidia but otherwise comparable.

     

    So, if it were me, I would start looking at the video card, drivers etc.

     

    No weird instabilities, annoying toggles and such. Nothing sordid to get sorted!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 7:12 AM   in reply to BKKDon

    But when you run through the routine, the image finished correctly? I probably would call it a freeze.

     

    In any case, mine finished with no grayouts etc. I could watch it while running another app. So I didn't see what you call losing focus.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 10:02 AM   in reply to KiersM

    Thanks for this; it was definitely helpful. I found that by clicking in number fields at random just disabled those sliders. What worked was clicking in the very first field (Edge Glow Radius), then switching to another app and back again.

     

    This weird problem should really be addressed by Adobe and probably will be in one of the next updates.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 12:27 PM   in reply to pixelboss

    So then, what happens to my system if Adobe "fixes the problem? It works fine here.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2012 4:58 PM   in reply to BKKDon

    Hi I am a little lost in this thread but have a similar problem. I installed photomatrix pro and after that photoshop will not make HDR from bracketed photos. it goes through the motions and then does nto open any merged composite. I have tried via bridge and from within PS6 - and if I try to use non bracketed photos the results are irretreavably hidious. My problem soulds like yours but I think I need more direct (simple minded) instructions. I run a mac book pro and PSCS6X. The only difference from before is the installation of photomatrix. Does PS6 have a way to batch process bracketed photos into a series of HDRs?? It is the only reason I got photomatric pro. thanks and aloha, Uhane

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2012 5:05 PM   in reply to uhanepono

    Hi Again, I just unistalled photomatrix pro from my system (using Itrash so there are no ghosts remaining on my system) and PS6 still will not process bracketed photos. I want to add I am using a T4i canon. with 3 exposure bracketing for an HDR timelapse. Is it the model? Baffled

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2012 8:23 PM   in reply to uhanepono

    I tried changing my settings and tried a number of different things nad diffent photos. I will have to reinstall photomatrix or go without HDR. They look great over there so I know it is not the photos. I am running a macbook pro and PSCS6 and jpgs. I have not tried raw files but just getting the jpgs would be enough. This is real show stopper!!!! and a real drag!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2013 7:32 PM   in reply to BKKDon

    I have the exact same problem (I run Windows 7 x64). I am running all the latest updates (as of today) on Photoshop 64 bits.

     

    So I am in the HDR merge window. If I switch focus to another app, then switch focus to the HDR window, only some of the controls on the HDR window are clickable/enabled/usable. Right now I had all controls grayed out (as if the HDR window did NOT have focus) except the very top drop down. Previous times I had all controls disabled/grayed out except the bottom two. The hardest to get to enable again are the Cancel and OK buttons at the bottom, which means you are stuck with that window unless you kill the Photoshop process through the Task Manager.

     

    This is NOT a freeze, as the form does regain focus and the controls that do get enabled again do work normally.

     

    I usually eventually get the form to be usable again, but it is after a lot of random clicking around and trial and error. To be honest I do not know if it is the clicking around that makes the window usable or the time that has gone by since it became unusable.

     

    In any case, this bug is still in the system as of today :-/

     

    Oh in case it matters (don't think it should, but here we go) my PC config:

    - Photopshop CS6 Extended 13.1.2 x64

    - Lenovo Thinkad w520

    - Intel Core i7-2820QM CPU

    - 16 GB RAM

    - C: - 500MB SSD

    - D: - 1.5GB 5400 RPM hard disk

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points