Skip navigation
Currently Being Moderated

"Use Preview Files" works in CS5.5 but is "Useless" in CS6

Jul 23, 2012 9:28 PM

Tags: #premiere #files #preview #cs6

I'm a heavy user of the "Use Previews Files" option when exporting files. This has worked great with Premiere CS5.5 but using the same method in CS6 no longer works and reverts back to rerendering the original files in the timeline and rerendering all the effects on them which is very time consuming since the original files are HD and are being downscaled in a DV widescreen timeline.

 

Anyone figure out how to get Premiere CS6 to correctly find the preview files when exporting using the "Use Preview Files" option?

 

In the meantime, I had to load all the preview files I had rendered back into a new timeline and reassemble them in the correct order. Once I did that, I exported this 1 hour 38 minute timeline to an MPEG-2 file which only took 19 minutes instead of the 7 hours it would have taken even with the "Use Preview Files" on and with a fully rendered timeline.

 

Again, it works great in CS5.5 so something changed in CS6 to make the "Use Preview Files" useless now.

 

Randy

 
Replies 1 2 3 Previous Next
  • Currently Being Moderated
    Jul 24, 2012 10:02 AM   in reply to Cavemandude

    Seems to be working fine for me.  An effects heavy test took 2:32 to export without using Previews, and only :15 using them.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 24, 2012 12:32 PM   in reply to Cavemandude

    There is sufficient difference between the export times to show that they are being used when the box is checked, even on such a short test.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 24, 2012 1:28 PM   in reply to Jim Simon

    Sorry to sidetrack this one a little, but what codec are you guys using for your previews, and do you have max quality etc set on the previews also?    We tend not to use them, but I'm getting tired of 7-8 hour exports for things that used to take only 45 mins on FCP7 (because we'd rendered as we went along).

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 2:11 AM   in reply to Cavemandude

    Just checking but ...Preview Files are exactly what the name states they are.

     

    That is ..they are a lossy departure from the native files. (They are files rendered out  with FX etc...that make playback easy on the system)

     

    So ..is it your intention to use the quality loss ( hit) from  the Preview files to create your export media?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 11:17 AM   in reply to Cavemandude

    shootemz, I don't think that preview files NEED to be lossy files ONLY used for previews.  In fact you can set them to something like uncompressed 10 bit, which would make them not lossy at all, and in fact totally suitable for speeding up a final export.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 2:45 PM   in reply to reToolednet

    And in my case, they do.

     

    Are you using QuickTime at all here?  My understanding is that because of QuickTime's 32 bit nature and the "band-aid" Adobe uses to handle them in a 64 bit environment, you can't do a direct file copy form QT to QT, you have to go through the encoder.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 2:53 PM   in reply to Jim Simon

    The lack of copy is not related to 64 bit vs 32 bit (as far as I know), but in fact limited to lack of something calls "smart render". Only a few very specific codecs let you smart render, i.e. pass your initial source, let's say prores directly into the final prores export without reencoding.  Of course, prores, IS NOT one of those supported formats.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 2:55 PM   in reply to reToolednet

    reToolednet wrote:

     

    The lack of copy is not related to 64 bit vs 32 bit (as far as I know), but in fact limited to lack of something calls "smart render". Only a few very specific codecs let you smart render, i.e. pass your initial source, let's say prores directly into the final prores export without reencoding.  Of course, prores, IS NOT one of those supported formats.

     

    Do you know which ones are?   Or perhaps have a link to such information?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 2:59 PM   in reply to ExactImage
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 3:00 PM   in reply to reToolednet

    Also, to contribute to the original poster's question, Use Previews DOES work for ME in CS6, despite NOT working in CS 5.5.  However, I have heard from others that it doesn't work on their systems either.  Definitely an area that needs improvement to improve export times.  Perhaps a true background rendering system would really speed up final exports when combined with this as well. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 6:51 PM   in reply to reToolednet

    The lack of copy is not related to 64 bit vs 32 bit

     

    I do believe it is directly related to using the QuickTime container, which is a 32 bit process running in a 64 bit environment.  Using AVI (such as DV, Uncompressed, Lagarith or UT) doesn't have this issue.

     

    Smart rendering is something else entirely.  This is where only changed frames are 'rendered', and any unchanged frames are simply copied.  PP has just received it's very first "smart rendering" capabilities, as that feature is widely defined.  "Smart rendering" is unrelated to "using preview files".

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 7:40 PM   in reply to Jim Simon

    Right this is unrelated but plays into the greater discussion of export times. Regardless quick times and use previews do work for me. But on a Mac.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 9:34 AM   in reply to Cavemandude

    Preview files sometimes don't work in CS5.5 if you don't know how to trigger the preview files to work.

     

    Right there I'd say this is a local issue.  There is no "trigger" required other than the Use Preview Files checkbox.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 1:47 PM   in reply to Cavemandude

    Again, excepting the QuickTime issue, there is nothing you have ever needed to do to "make it work" other than check the box.  If it ever hasn't worked for you, then something is probably wrong with your installation.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 2:56 PM   in reply to Cavemandude

    Please do share Randy.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 2:59 PM   in reply to Cavemandude

    You solved it...YAY...so why keep it a secret from those that tried to help... or others that may need the info ?

     

    Get with the community spirit thing.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 7:59 PM   in reply to Cavemandude

    So you're say that there are no bugs in Adobe CS6 and if anything doesn't work correctly it is due to something wrong with the installation?

     

    Not at all.  I'm saying that it works just fine for me, and always has, so it's not likely a bug.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 21, 2012 12:25 PM   in reply to Cavemandude

    Same issue.

    Randy, please share workaround.

    Can't do warp stabilizer with synthese edge withous worked 'use preview files' in CS6.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 7:44 AM   in reply to muzflowers

    Wow. Bad form, dude. I need this answer. I'm in a situation where I cannot use Beauty Box without the ability to make short preview files and use them during export, due to the fact that any sequence longer than 2-3 minutes will not fully render using Beauty Box without just freezing and quitting. You are 100% correct that this checkbox does not work by default. So now begins my search in preferences to figure this out. Glad you solved it. Sad that someone here would have offended you to the point of not sharing with the majority of good-natured folk here. It's also kind of sad that an Adobe emp. would not read this and figure it out for those of us who are ham-stringed by this nonsense.

     

    I appeal to your better nature and ask that you post the solution.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 9:52 AM   in reply to Stan Arthur

    I suspect the solution never came because there just is no other setting beyond the checkbox to make this work (assuming no QuickTime is involved).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 9:51 AM   in reply to Jim Simon

    It happens to work for me too, but it Didn't work for me in CS 5.5, so maybe a preference, maybe a mac pc thing, who knows...other than the guy who has solved it....

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 9:54 AM   in reply to Stan Arthur

    i don't use preview export myself, but i add in a vote for 'share the solution'

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2012 11:01 AM   in reply to Cavemandude

    Not work in my case.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 4, 2012 11:06 AM   in reply to Cavemandude

    Well Dude, I concur. This has worked for me. I just took a 30 minute 1080p sequence loaded with a mixture of stills with motion, clips with warp stabilizer, color correction and linked After Effects comps and rendered the entire work area, giving me a green line from what had been a mixture of yellow and red. The render didn't take as long as I expected, so that was nice. Then, at your suggestion, I disabled GPU acceleration and clicked "use previews" while exporting to MPEG-2 DVD with "Match Source Attributes (High Quality). The resulting export of a 30 minute sequence was about 10 minutes. For the record, my preview files are Matrox MPEG-2 I-frame at 100 Mbps which, to my eye, are outstanding and run slick as snot on my Z800 using the Matrox MXO2 MAX LE.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2012 1:19 PM   in reply to Cavemandude

    6.0.3 update does not fix this problem too.

     
    |
    Mark as:
1 2 3 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points