Skip navigation
Currently Being Moderated

Can I stop Dreamweaver CS6 from constantly polling the FTP server?

Jul 25, 2012 7:12 AM

Tags: #error #annoying #dreamweaver #cs6 #ftp

When I work in CS6 I just work directly off the FTP server. I don't work in a large team, check in and check out is a wasted feature for us. So I have the Advanced server settings to automatically upload files when I save them. This has been working pretty well with the exception that Dreamweaver CS6 seems to constantly poll the FTP server anyway. So often times I'll go to save and it will throw out an error that it can't upload the file right now because it's currently interacting with the server.

 

Inside Dreamweaver I have the FTP log tab open and it's just constantly looking at stuff on the server at random intervals. It's not downloading anything or reconnecting. I'm having no connection problems at all actually outside of this.

 

I've poked through settings and I can't find anything that says something like "Stop constantly checking the FTP server, it's still there, don't worry about it..."

 

Here's the error for whatever it's worth. I wouldn't even bother complaining about this except that it happens to me constantly throughout the day. If it was just once or twice I wouldn't care. The other annoying thing is that when the error occurs it does save the file locally which is pointless for my purposes also but since it flags it as saved I have to make a change in order to get it to save and upload. So a lot of times I'm just waiting for it to stop interacting with the FTP server for no good reason, adding a space, backspacing the space and then hitting save again. Seriously obnoxious, please tell me there's a setting to shut this behavior off.

 

dw-error.png

 
Replies
  • Currently Being Moderated
    Jan 31, 2013 3:33 PM   in reply to Volkscience

    OMG, I cant believe there is not a reply to this! I was just googling around for an answer to this same HUGELY irritating problem.

     

    Put simply, I want Dreamweaver to work like this: give me an option for a site config that says 'only create FTP connection on PUT or GET triggered by user' and not automatically by the software for whatever reasons the programmers came up with to keep things running in the background. Leave it the way it is, but write a way to turn that off. I dont want to ever see the Dreamweaver is currently interacting with a server window ever again, as even if I end up putting a file and then click on getting a file without put finishing yet, just queue the command, dont throw an alert....please!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 31, 2013 3:46 PM   in reply to davidweisenbarger

    Turn off auto FTP on Save.  I think this feature is dangerous.  One false move and you've got whacked files on your server with no backups to revert to.

     

    It's much safer, not to mention easier on DW resources, if you work locally. And only after you're completely satisfied that everything works, Ctrl+Shift+U to upload to server. 

     

     

    Nancy O.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 11:45 AM   in reply to Volkscience

    Yep this is the single feature that is driving me nuts in CS6.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 12:11 PM   in reply to kenny.bae

    Go to Site > Manage Site > Edit

     

    Click the Advanced tab

     

    Click "Remote Info"

     

    Uncheck "Automatically upload files to server on save"

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2013 7:29 AM   in reply to Volkscience

    As Nancy said it's a dangerous option to enable. Here's an example -

     

    1. You want to create a new page based on an existing page so you open the existing page and make changes to it.

    2. When finished you absent-mindedly save that page with File > Save instead of File > Save As.

    3. Blammo - both your local AND remote copy of that original page are hosed.

     

    It's one of the few options in DW that I would NEVER use.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2013 7:33 AM   in reply to Volkscience

    I have always used my local site as a testbed for new ideas/scripts/techniques and, once happy with the results, upload to the server. I save too many times during the development of a page to continually stop my work flow for an upload to the server every time I hit Ctrl + S.

     

    I have a relatively slow upload speed on one of the networks I use most often and that dialogue box would get ultra annoying. I find it best to just turn it off and upload when I'm ready. Hitting the Put or Synchronize button isn't nearly as disruptive to me.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 10, 2013 10:59 AM   in reply to MurraySummers

    It's one of the main reason I love DW, and I've been using various versions for the past 7 years.

     

    Also this "solution" you and others keep spouting does not address the real issue, the "server busy" error happens regardless of whether its uploaded on save or manually.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 6:23 AM   in reply to Volkscience

    The "upload file on save" feature is the one thing that keeps me going back to Dreamweaver- otherwise I would just use a text editor. Murray don't be shy to use this feature as it will substantially improve your coding performance. Additionally, you should save an entire backup of your files before you begin coding and make use of the "remote" and "testing" FTP options as well.

     

    On the server busty note I have the same issue and can't even access Dreamweaver. Such a time waster.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 17, 2013 12:25 AM   in reply to Volkscience

    I'll tell you the real answer - because Adobe Dreamweaver's FTP integration is, and has always been, horrendous.   Here I am - working with Dreamweaver in 2013, having worked with Dreamweaver since the year 2000... yes - that is 13 years.  And 13 freaking years later I am still having the SAME Dreamweaver FTP issues since back then!!

     

    Like today - let me tell you my workflow. 

     

    1. Open Dreamweaver - knowing that this is going to be yet again another painful day because of the FTP situation
    2. Make a few changes to a single file
    3. Connect - it connects instantly
    4. Upload my file.  I'm (relatively) happy.
    5. Work on my file for the next 10 minutes.
    6. Keyboard Shortcuts to save, then upload my file.
    7. ....
    8. Window pops up - Waiting for server
    9. ...
    10. Still waiting for server
    11. Trys to reconnect.
    12. ...
    13. Waiting for server
    14. I cancel.  Disconnect... then guess what...
    15. Window pops up - Waiting for server.
    16. I close that window immediately
    17. Reconnect - its fine
    18. Upload my file immediately.

     

    I have to do this EVERY FREAKING TIME I need to upload a file.   It is beyond rediculous that this wasn't solved in 2002, but no - ELEVEN years after that it still behaves the same!!!!

     

    I know I'm not alone - just google "Dreamweaver FTP Waiting for server", or "dreamweaver ftp dropping", or anything else like that, and you'll find no end of people in pure frustration. 

     

    The only solution that I have found that may actually help ease the pain (doesn't solve the problem unfortuantely) this is something I just found today. 

     

    Go to Preferences > Site settings where you can change FTP connection option : Disconnect after x minutes idle

     

    I have changed that to 1 minute.  Shouldn't have to, but that's all that can be done.

     

    Please Adobe - start from the ground up with CS7 and completely rewrite FTP in Dreamweaver.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 17, 2013 6:28 AM   in reply to Volkscience

    This problem is not related to the Upload on Save setting. It's general FTP and happens regardless of whether that setting is on or off.

     

    Does anyone know if Dreamweaver CC fixes this?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2013 1:35 PM   in reply to Gary Sprung

    Don't hold your breath Gary.  I've been waiting for 13 years.  All we want is something that performs as well as Filezilla.  Can't be too hard, surely?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 9:19 AM   in reply to JaydenLawson

    I just use an external ftp client. No problems

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 10:21 AM   in reply to shunithD

    I asked around and this is the solution I was provided with.

     

    Do one of the following:

     

    - Disable Automatically upload files to server on save (Advanced tab of Manage Sites dialog)

     

     

    - In Edit > Preferences > Site, set preferences for the following:

     

    Enable FTP connections and set the disconnect time (30 minutes).

    Set FTP timeout to 30 seconds

    Enable FTP transfer options and set the value to 30 seconds.

     

    Let me know if this helps.

     

    Thanks,

    Preran

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 6:08 PM   in reply to Preran

    Thanks Preran.  I'll give these settings a go over the next couple of weeks.  Please do pass on to the relevant parties that the FTP feature of Dreamweaver has always been terrible, long before Adobe aquired Macromedia.  It seems it hasn't ever had an full overhaul, which it desparately needs.  As a web developer, I have been frustrated no end with this for years, and I know many others are the same.  @shunithD just said he uses another FTP client - and so do I when I need to transfer many files reliably.  But that's not a good solution when we're using Dreamweaver's other features, like Synchronize - which I love.

     

    Please send this to the dev team that are developing the next iteration of Dreamweaver.  It's time for a fresh development of FTP in Dreamweaver.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Nov 4, 2013 9:04 PM   in reply to JaydenLawson

    Without saying your issue isn’t real. I've been working with DW for about the same stretch and I've never had these types of problems.

     

    Could it have to do with your internet or server connection type? But you say it works with FileZilla. So I’m perplexed?

     

    Maybe I’ve just been getting lucky with the connection types DW is best set to work with?

     

    My SOP:

    • - I always ask those who manage the remote server I’m connecting to what DW settings they recommend.
    • - I turn off auto upload features entirely.
    • - I always use CTRL-SHIFT-U to save and put the current file I’m working with. This usually prevents any undesirable interaction with the remote server.
    • - If I want to bulk upload files, I select the folder or just the set of files I want to upload and then use CTRL-SHIFT-U.

     

    This is all I’ve ever had to do.

     

    I will add however, DW can be an unrelenting pest when it has difficulty connecting to the remote server!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 9:49 PM   in reply to kwgonline

    Thanks for your concern, but I have had this experience for over a decade, on probably a dozen different machines (Mac and PC), on at least a half-dozen different Internet connections (probably more), connecting to at least 20 different servers of varying system environments.

     

    The one constant is Dreamweaver.

     

    Ps. my SOP is identical to yours, except that I do not usually check with those managing the server what settings they recommend, because I never have the same issues with Filezilla - so I know that it is Dreamweaver.  Because of my long experience with Dreamweaver, I rarely upload files in bulk, because I know of the issues it so often has.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 12:55 AM   in reply to JaydenLawson

    I too have over a decade of experience with Dreamweaver,  managing dozens of websites on an ongoing basis. There definitely have been periods where FTP was seriously problematic, even after the updates to CS6 where it was supposed to have been fixed. I was able to resolve the issue on my main production machine by doing two things:

     

    1. Temporarily disabling my firewall and anti-virus programs.
    2. Adding the "ResolveRemoteURLToIPAddress" string to "Remote Download" in my Registry, and setting it to FALSE.

     

    #1 indicated to me that my security software could be freaking out about Dreamweaver's level of access, and might have gotten its hooks into the software in ways that compromised that access, thus causing delays in file transfer and sync operations.

     

    #2 was initially added to disable Dreamweaver's Resolve To IP Address feature, which caused it to hang sometimes when opening existing documents. This feature is on by default in the PC version. I'm not sure if DW interacts with the server just on document open, or whether it's something that occurs on an ongoing basis. If the latter, then it could be causing a lot of "interacting with a  server" frustration for a lot of users. More here: http://helpx.adobe.com/dreamweaver/kb/hang-opening-document-dreamweave r-cs5.html

     

    Dreamweaver is not as efficient for file transfers as a standalone FTP app, because it is programmed to keep track of all files and folders at all times, and to take notes of the same. It is for this reason that I always have an FTP program open when I work. That said, the Registry fix, in conjunction with testing several combinations of firewall and anti-virus apps allowed me to find a solution that pretty much put an end to my DW FTP problems.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 6:17 AM   in reply to kwgonline

    I too have had these FTP problems with Dreamweaver for years. I saw the constantly-polling issue as well as the inability to handle problems with a server connection.

     

    A big issue for me is the Compare With Remote Server (or with Testing Server) function. The FTP or SFTP process for that frequently fails. See also my post: http://forums.adobe.com/message/5369669#5369669.

     

    I recently upgraded to Dreamweaver CC. I don't see the constant polling issue, but the Compare With... feature is still often broken.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 12:30 PM   in reply to Gary Sprung

    The simplest solution is to use an external (independent) ftp client.

     

    Set all folders to date... and then you know which are the latest files to update. Also, protects you from horrendous mistakes!

     

    Yes, it is an extra step. or two, but it saves a lot of heartburn.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points