Skip navigation
Currently Being Moderated

Coldfusion 10 and Ebay Web Service WSDL

Jul 31, 2012 4:11 AM

Tags: #java #wsdl #web_service #ebay #coldfusion_10

Hello everyone,


we recently upgraded from Coldfusion 8 to Coldfusion 10 and we found a business-stopping bug:


In Coldfusion 10 Administrator console go to DATA & SERVICES -> Web Services.

There add a web-service with WSDL link

Other input values have no affect in this issue.


You will then receive a Coldfusion error:

Template: /CFIDE/Administrator/extensions/webservices.cfm

Diagnostics: javax.wsdl.Operation.getExtensionAttributes()Ljava/util/Map; null

The error occurred on line 141.


Same error if you try to instantiate an ebay web service object with given WSDL from inside the cfscript.


This is a serious show stopper since ebay API no longer work with Coldfusion 10 and we were forced to rollback to Coldfusion 8.


Any help would be highly appreciated!


P.S. other non-ebay WSDLs seem to add fine to CF10.

  • Currently Being Moderated
    Aug 1, 2012 1:04 AM   in reply to DmitriD

    CF10 is upgraded to new Axis2 engine and it is used by default. Would that be cuasing an issue?


    There is a setting in admin where you can change the webservice enginer version to 1. Can you try and check if it helps resolve the issue for you?

    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 1:09 AM   in reply to hemant_k

    Hemant, I can understand that CF using Axis2 vs whatever CF9 used (Axis1, I guess?) would impact how CF publishes its own web services, but this shouldn't impact calling third party web services, surely?  How does that make sense?




    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 9:50 PM   in reply to Adam Cameron.

    Adam, Consumption of the web service will also be impacted. The version decides which framework is used for generating the client side stubs.


    DmitriD, could you please post the code used for testing. Where did you try to set the version? For consuming you should set the version in CFInvoke or CreateObject(). If you change the server level wsversion, it is used while publishing only.



              ws = createObject("webservice","", {wsversion="1"});





    I tried the above code and it is working fine for me. Please check and let me know.




    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points