Skip navigation
Currently Being Moderated

CS6 being very slow, since upgrading to Mountain Lion, 2 days not using it

Jul 31, 2012 8:06 PM

Tags: #lion #slow #cs6 #imac #mountain

CS6 being very slow, since upgrading to Mountain Lion, 2 days not using it and design jobs sitting a waiting and costing me. Why is this happening?

 

I click, I get the wheel showing its working to catch up, I click, I get the wheel showing its working to catch up,I click, I get the wheel showing its working to catch up,I click, I get the wheel showing its working to catch up...............

 

Everything was fine until I upgraded to Mtn. Lion on my iMac.

 

I bet if I downloaded some other edit software I wouldn't be having this problem, matter of fact that's an idea.

 
Replies 1 2 Previous Next
  • Noel Carboni
    23,513 posts
    Dec 23, 2006
    Currently Being Moderated
    Jul 31, 2012 8:39 PM   in reply to P8PRCUT

    Have you tried all the different GPU options in the Photoshop - Preferences - Performance dialog (making sure to restart Photoshop for each test)?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 12:44 PM   in reply to Noel Carboni

    We have seen some problems with fonts and the OS font cache in Mountain Lion (MacOS 10.8).

     

    Beyond that we haven't heard of anything that would cause a slowdown.

    It is possible that some third party plugins won't be compatible with 10.8, so you might try disabling any third party plugins you have installed.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 31, 2012 10:09 PM   in reply to P8PRCUT

    Well, you have something wrong on your system that other people aren't seeing.

    But I don't have your system to know what went wrong -- maybe a haxie, maybe a bad driver, maybe just problems with your disk.

     

    Also, do make sure you didn't copy any obsolete Adobe plugins into the CS6 plugins folder -- the folder is just for third party stuff now (the Adobe plugins are in Required).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 12:43 PM   in reply to P8PRCUT

    PSDX is from Photoshop Touch (on the iPad).

     

    Another user was running low on RAM on their system, and changing preferences to use 128K tiles instead of 1024K reduced her memory usage and improved performance.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2012 3:32 PM   in reply to P8PRCUT

    OK, then we need to figure out where all that time is going on your system.

    While Photoshop is acting slow, can you sample it from Activity Monitor.  The log will be a bit long, so it might be better to email it to me: ccox (at) adobe \dot\ com.

     
    |
    Mark as:
  • Noel Carboni
    23,513 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 5, 2012 3:33 PM   in reply to P8PRCUT

    There is no 32 bit Mac version of Photoshop CS6.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 5:26 AM   in reply to P8PRCUT

    Hello everyone, I have the exact same problem "CS6 being very slow since upgrading to Mountain Lion"

    tried everything mentioned above, it boots fine! but when i open any image "even extra small one" it loads very slow especially when I switch between tools. I installed cs5 it's working fine.

     

    Thanks much,

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 2:34 PM   in reply to ihabarneh83

    I am also experiencing very slow response from Fireworks CS6 on Mountain Lion. Interacting with items on the canvas seems ok, but any time I attempt to expand a palette or click on a menu item, the app takes several seconds to respond.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 3:48 PM   in reply to KyleWendt

    In which can you need to post in the Fireworks forum, where they can help you with Fireworks.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 5:46 PM   in reply to Chris Cox

    did you solve the photoshop issue please?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 9:19 PM   in reply to P8PRCUT

    Guys, I suffered the same problem for 4 days.  I am on the new MBP Pro Retina Display + Mountain Lion 16GB Ram, etc...

     

    I first thought it was to do with retina display however no, that is not the case.

     

    SOLUTION (sounds odd but works):

     

    The only way I found to fix it, is setting photoshop to use the East Asian text engine instead of the Middle East one. (Prefs -> Type -> East Asian). Then restart Photoshop.

     


     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 9:21 PM   in reply to rjsgroupdubai

    Please either email me on rishi@rjs.ae or post if this solution worked for you. I'd like to hear your feedback as I have been struggling for days... and after this fix, suddenly all problems disappeared.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 23, 2012 12:52 AM   in reply to P8PRCUT

    I never experienced a problem yet using CS6. Actually, I like the specs of this latest version and I'm very satisfied when using it.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2012 8:08 AM   in reply to rjsgroupdubai

    This solution has saved me 100500 nerves. Thanks!

    Now i can work comfortably on my mac mini 816 (Mountain Lion with 16gb ram too).

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 23, 2012 4:29 AM   in reply to rjsgroupdubai

    Any other solution? I have the same problem, but can't use this solution since I actaully use the midlle eastern text engine (I need to be able to write Hebrew).

     

    Right now my PS is so slow it's unsuable- I get a beach ball after every action, even adding a layer.

     

    Mac Pro Quad 2.66, 10 GB RAM

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 23, 2012 9:41 PM   in reply to xslf_

    Sorry, there is no other solution, I have tried everything and thats why I posted that this is the ONLY way to fix it.  Until, Adobe comes out with a regional fix, then you are not able to write in Hebrew. 

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2012 7:40 AM   in reply to rjsgroupdubai

    I've had similar performance issues since installing Mt Lion on a Mac pro with CS6.  Namely when using the brush function, INCREDIBLY slow performance, to the point it's unusable.

     

    I've tried everything down the list from performance and GUI settings, to deleting caches and pref, to reinstalling.

     

    Nothing seems to help at all.  I'd thought turning GUI off would do it...but no dice.

     

    CS5 works perfectly fine.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2012 1:06 AM   in reply to graemenyc

    I have the exact same problem on two different macs with different configurations and I tried using the east asian text engine and it worked. But I need to write in Arabic and RTL languages, so this is not a complete soloution.

     

    I'm waiting for Adobe to acknowledge and address this problem.

    Hopefully not too much longer.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2012 2:38 AM   in reply to P8PRCUT

    CS6 Photoshop running extremely slowly since Mountain Lion - Already running on East Asian Text, so that fix isn't working for me.

    Illustrator also throwing up some unusual problems with file corruptions.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 12, 2012 1:44 PM   in reply to Chris Cox

    I found a solution and the scource of the problem!! (the problem is both adobe and apple)

     

    My situation:

    I have the same problem on the Macbook Air 2011 and Macbook Pro Retina 13".

    Same response since Mountain Lion, and since the Photoshop CS6 beta (including latest updates),

    and my -lame- solution so far is installing as English International and not middle east, and running on parallels' winXP for fixing texts....

     

    The real problem:

    The problem is that Apple's Mountain Lion handles multilingual fonts in a new/different way,

    and that Adobe did the same its own way in the MiddleEast support on CS6 since they fused with Quicksoft.

     

    The solution is to remove fonts:

    1) Close Photoshop and open Font Book.

    2) go to File->Export collection - so you can backup all your fonts (it will remove the one adobe installed too)

    3) Add back to Font Book only 'Miriad Hebrew/Arabic' and 'Adobe Hebrew/Arabic' from your backup.

    4) Check if it works fine and then close photoshop again. (try a few documents. it's okay if the first 1-2min react the same).

    5) If it works, add only the fonts you bought (like fontbit/masterfont for hebrew). Maybe freeware/downloaded fonts risk to slow photoshop back.

     

    It works for me (finally). I hope it works for you too.

    I hope adobe will fit themself to the new OS since Apple will never go back. We need fonts....

    I tryied to reinstall all adobe fonts back but it didn't resolved the problem... so only 'miriad' and 'adobe' is okay.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 12, 2012 6:19 PM   in reply to BorisMel

    Someone is trying to track down the problems with the MiddleEastern composer and fonts on MacOS 10.8.

     

    All the extra time is being spent in MacOS API calls, indicating a problem in those APIs.

    But we still don't have details and will probably need to work with Apple to see why those APIs are taking *bloody forever* to return results.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2013 7:10 PM   in reply to P8PRCUT

    Same problem, no solutions. Adobe plz hurry up, an update

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 29, 2013 4:43 AM   in reply to P8PRCUT

    Dear Adobe.

    Photoshop is impossible to use after the Retina update under OS X 10.8.

    It is so slow, so it's impossible to use. I am not exaggerating to make it sound dramatic. It really is that bad.

    That cheap but very competent competitor Pixelmator is blazing fast in comparison.

    Please fix it.

    My only fix so far (which is not really a fix) is to open Photoshop in low resolution.

    Go to Finder, cmd+i to bring up info on the Photoshop app. Click on Open in low resolution. Open it again.

    Speed is then decent, but I like the retina display. So please fix this nagging bug... really fast.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 29, 2013 12:35 PM   in reply to Studio Palegolas

    It could be a problem with the Middle East composer, as mentioned previously.

    Otherwise something else on your system is slowing it down -- other users are not seeing the performance problems that you mention.  Causes could be third party plugins, OS bugs, third party utilities (antivirus, font managers, utilities that modify OS drawing behavior), etc.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 29, 2013 2:08 PM   in reply to Chris Cox

    How about giving us the means of generating a system log that is meaningful to you and then you do the digging? It's your software so you're in a much better position to find and solve the issue than me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 29, 2013 4:00 PM   in reply to Studio Palegolas

    The Photoshop Help ->System Info log helps with most things.

    But many OS utilities don't show up so easily.

     

    You are in a much better position to troubleshoot your system than we are.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2013 5:36 AM   in reply to Chris Cox

    I tried to switch over to Middle east composer just to try it, and boy then it took the slowdown to new heights.

    No software is perfect. It can always be fixed. But to just sit back and point elsewhere doesn't impress me very much.

     

    Should I send you the my log? Is it a good place to start?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2013 10:21 AM   in reply to Studio Palegolas

    Yeah, we think the ME composer is running into some OS issues (some calls take WAY longer than they should), but we're still debugging the issue.

     

    You have something on your system that is slowing down Photoshop, that is not present on other user's computers.  So you need to help figure out what is different about your system that is causing a problem that other users are not seeing.

     

    Post the System Info log here.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 31, 2013 10:42 AM   in reply to rjsgroupdubai

    Thank you so much for suggesting that! I was having the same problem, basically a beach ball every few seconds when any document was open. Couldn't even hardly adjust Photoshop's preferences (with an image open in the background), because it would constantly hang and all the option controls were intermittently (most of the time) unresponsive. This is an a new iMac (late 2012 model); used Migration Assistant to move from my old 6-year-old Mac Pro, but reinstalled CS6 on the new machine just to be safe. It was like I was running CS6 on a computer from the 1980s. None of the performance settings helped, and I don't have any custom plugins installed. But the moment I changed the text engine to Middle Eastern, ta-da! Like magic it made everything run 1000x better.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 11:26 AM   in reply to Chris Cox

    I took my time and did some testing. I don't have any 3d party filters or anything. The photoshop install is clean. I even reinstalled it. The system is also pretty clean. I decided to search within Photoshop instead - and I think I found a solution that works at least on my machine.

     

    Preferences / Performance / turn off Use Graphics Processor --> restart Photoshop.

     

    Ironically disabling this option (that is meant to increase performance) made photoshop perform like it should again.

    Painting tools and most tools now run extremely smooth. And now changing the text engine options has no impact on performance.

     

    Retina MacBook Pro

    2.6 GHz i7

    16 GB RAM

    OSX 10.8.2

    Graphics card: Geforce GT650M

     

    Team: I hope you find the issue.. Graphics Card accelleration could be handy when it's working properly.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 11:35 AM   in reply to Studio Palegolas

    That means that something is wrong with the GPU or drivers on your system.

     

    Other users with the same hardare aren't seeing it run slow.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points