Skip navigation
Rory_M
Currently Being Moderated

Modal Popup Window

Jul 31, 2012 10:44 PM

I'm trying to get a simple modal popup window working via the Arbitrary HTML facility in Muse but am having problems.

 

I've tried this one http://www.ericmmartin.com/projects/simplemodal-demos/ and this one http://www.html-form-guide.com/contact-form/simple-modal-popup-contact -form.html without any luck.

 

Has anyone else had any success? Is there chance of a widget to do this?

 
Replies
  • Currently Being Moderated
    Aug 1, 2012 5:52 AM   in reply to Rory_M

    Hi Rory_M,

     

    I'm not sure how you host your Muse project but if you host it with BC then these solutions won't work because BC is not allowing you to run server side code. If you host it on your own web server then you should run PHP, and just make sure that you put in the "Insert HTML..." function what it needs to render the forms and to function.

     

    I hope this help,

    Cristian

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 6:42 PM   in reply to Cristian Radu.

    I have worked out how to set up a modal popup within Muse the only gripe I have is the trigers have an active state so when the site is live there always has to be one trigger that is active even though the modal popup isn't actually active. As you can see in the image below I have a rollover state on the 3 boxes so when you rollover the colour overlay dissapears, but because the active state is always on on the trigger it isn't behaving the way I want it to. Is there a way around this? I have also tried to set the trigger to no fill and place it on top of a seperate container but when I do this the rollover state doesn't work at all.

    Screen Shot 2013-11-05 at 12.34.55 PM.png

    Screen Shot 2013-11-05 at 12.38.43 PM.png

    Any help would be greatly apreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 3:47 AM   in reply to SMack

    Hello,

     

    Did you use the composition>Lighbox widget to achieve this in Muse?

    If yes, then check theoption that says "Hide All  initially" and it should work fine.

     

    hideall.png

     

    Hope this helps.

     

    Regards,

    Sachin

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2013 3:59 PM   in reply to Sachin Hasija

    Wow great thank you so much this worked a treat. Now I'm guessing once you've clicked on the triggers whichever image is the last one you've viewed that will remain active after you close the Modal Popup? Is there a way around this so all of the triggers remain inactive at all times?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2013 6:28 AM   in reply to Sachin Hasija

    Hi,

     

    I've got the latest version of Muse, and I can't find this "Hide All  initially"...

     

    I want to trigger the lightbox with a button I did in Photoshop, and I having a hard time, because it seems the thumbnails are always showing.

     

    How can I do it, can you help me?

     

    Thx!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points