Skip navigation
KCKTara
Currently Being Moderated

I can't change my font from the character menu, how do I fix this?

Aug 1, 2012 8:10 AM

Tags: #illustrator #problem #font #character #type #cs2 #disappear #aiprefs

Basically, the only way I can change my font is through the Type>Font menu up top (and by right clicking), but the list in the character palette and the control bar are empty. I can type in the name of the font I want and it will complete it, but even then it doesn't change anything. It is really inefficient for me to have to scroll through all the fonts every time, especially when I have no idea what font I want (or if the one I want is at the bottom of the list).

 

It started doing this just out of the blue a few months ago, before then it was working fine, no idea what set it off. I can't print from Illustrator either, maybe it's part of the same problem (that started earlier).

 

My version is CS2. Windows XP. I don't think that my boss is going to upgrade either in the near future. It's a small company, we don't have IT help.

 

I've done some searching and have already tried:

-uninstalling the old Illustrator 9 that was on here

-deleting the aiprefs file

-deleting the entire folder it was in

-deleting all of the Adobefnt*.lst files I could find

-restarting Illustrator, the computer several times

 

I haven't tried reinstalling Illustrator yet. Don't know where the CD is, so it's a last resort.

 
Replies
  • Currently Being Moderated
    Aug 1, 2012 8:57 AM   in reply to KCKTara

    Tara,

     

    I presume you deleted the AIPrefs file and the folder with Illy closed.

     

    In some strange cases, it is necessary to Move the folder rather than delete it.

     

    There may be an issue with Font cahces, and certain usual suspects among other applications have a bad reputation of disturbing and confusing Illy.

     

    You can see a list of them, and some other possible troublemaking things, in Other options.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 12:04 PM   in reply to KCKTara

    Tara,

     

    Do you have the option of restoring your PC to a state before things went wrong?

     

    Unfortunately, the Cleaner Tool, which makes sure you get rid of everything after uninstalling, was only introduced in CS3.

     

    If you get the ID = -108 error again, the solution to that particular nastiness is as follows:

     

    1) Open the C:\Program Files\Common Files\Adobe folder and look for a folder called TypeSupport;

    2) Create a namesake folder on your Desktop;

    3) Move all the contents to the namesake folder.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 1:55 PM   in reply to Jacob Bugge

    Did you delete your font caches?  I don't know what error -108 is, but the rest of the issue sounds like either corrupt font caches or a corrupt font.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 2:58 PM   in reply to KCKTara

    Tara,

     

    TypeSpt was the one; its name has changed with versions. I looked it up in my archive of old threads because -108 haunted the forums for quite a while, and I found an old post where it seemed to have been the other spelling for CS2.

     

    Still pondering.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2012 12:13 AM   in reply to Jacob Bugge

    I just install Adobe InDesign CS2 and i get back my Illustrator font list back, Really i dnt know how but it wroks

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points