Skip navigation
Currently Being Moderated

Photoshop CS6 Brush Lag

Aug 12, 2012 5:24 PM

I've tried several fixes for this including disabling CL, changing cache settings, and reducing drawing mode from adavanced to basic. Nothing is working.

 

These are my specs..

 

Adobe Photoshop Version: 13.0 (13.0 20120315.r.428 2012/03/15:21:00:00) x64

Operating System: Windows 7 64-bit

Version: 6.1

System architecture: AMD CPU Family:15, Model:10, Stepping:0 with MMX, SSE Integer, SSE FP, SSE2, SSE3

Physical processor count: 6

Processor speed: 2693 MHz

Built-in memory: 6143 MB

Free memory: 4351 MB

Memory available to Photoshop: 5374 MB

Memory used by Photoshop: 83 %

Image tile size: 132K

Image cache levels: 4

OpenGL Drawing: Enabled.

OpenGL Drawing Mode: Basic

OpenGL Allow Normal Mode: True.

OpenGL Allow Advanced Mode: True.

OpenGL Allow Old GPUs: Not Detected.

Video Card Vendor: ATI Technologies Inc.

Video Card Renderer: ATI Radeon HD 5800 Series

Display: 1

Display Bounds:=  top: 0, left: 0, bottom: 1050, right: 1680

Video Card Number: 1

Video Card: ATI Radeon HD 5800 Series

OpenCL Version:

Driver Version: 8.980.0.0

Driver Date: 20120611000000.000000-000

Video Card Driver: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,ati umd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdv a,atiumd6a.cap,atitmm64.dll

Video Mode: 1680 x 1050 x 4294967296 colors

Video Card Caption: ATI Radeon HD 5800 Series

Video Card Memory: 1024 MB

Video Rect Texture Size: 16384

Photoshop scratch has async I/O enabled

Scratch volume(s):

  C:\, 919.2G, 807.9G free

 

Another option suggested I disabled GL but the advanced interface did not have the open GL option visible in the same location as the guide.

 

I did not have brush lag until I started using the air brush. I did increase canvas size and make the file much larger but the lag did not happen until after I switched brush types. It is possible that I did not notice the lag until I switched.

 
Replies
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 12, 2012 5:41 PM   in reply to theoriginaltoxiccrayons

    How big is the canvas (in pixels horizontally x vertically)?

     

    What mode and data depth (e.g., RGB, CMYK, grayscale; 8 bits/channel, 16 bits, etc.)?

     

    How big is the brush in pixels?

     

    What brush is selected?

     

    You mentioned the airbrush option enabled.  What are the other settings? 

     

    Ideally, a screenshot showing the whole desktop environment when you're brushing will be helpful.

     

    Can you quantify the lag?  As in, "I click in the upper-left corner of the image, then shift-click in the lower-right corner, and it takes the brush x.y seconds to stroke across the image."  Be as accurate as you can; a 0.5 second lag is way different than a 5 second lag.

     

    Be aware that very large brushes have to manipulate a huge number of pixels and can slow things down.

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 12, 2012 8:08 PM   in reply to theoriginaltoxiccrayons

    Thanks for the detailed info.  Yes, that's unambiguously WAY slower than what I'm seeing.  I even pushed it up to 300 pixels and it just keeps up, no matter how quickly I brush around, with all the Brush settings maxed.  Something's definitely amiss on your setup.

     

    I don't see too much wrong in your specs; your display driver is up to date.  An 83% Photoshop RAM limit might be a bit high for a 6 GB system, but I can't see how it would slow things consistently. 

     

    I do see that you have not moved up to Windows 7 service pack 1.  Adobe does say they require SP1 for Photoshop CS6.  Did you avoid updating to SP1 for a reason?

     

    Do you see the same slow speed if you temporarily disable the [  ] Use Graphics Processor setting (making sure to restart Photoshop after and before testing)?

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 12, 2012 8:13 PM   in reply to theoriginaltoxiccrayons

    As a workaround, does the speed increase if you set the Spacing value (in the Brush Panel, in the Brush Tip Shape options) up a little bit?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 12:24 AM   in reply to Noel Carboni

    I was having issues with laggy drawing and turning off the "Use Graphics Processor" completely fixed it.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 1:08 AM   in reply to unclejenkins1

    That means that the slowdown was due to a bug in your video card driver.

    Have you updated your video card driver from the GPU maker's website recently?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 11:48 AM   in reply to Chris Cox

    Yeah, I always keep my GPU drivers up to date. It's a pretty decent card too, a Radeon HD 6750 (1GB).

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 12:10 PM   in reply to unclejenkins1

    AMD has had some driver issues recently. Try the 12.8 drivers, or 13.2 beta 5 or later (which fix most of the known issues).

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points