Skip navigation
Currently Being Moderated

How do I turn off snapping to some sort of invisible grid in InDesign?

Aug 27, 2012 12:55 PM

Tags: #guide #snapping #grid

In the last few upgrades of Indesign something has stumped me. When I move or scale objects there is snapping to some sort of invisible grid. This happens when I move or scale something with my mouse but not when I move something with the the up and down arrow keys (I set the keyboard increments to a very small setting and that works). I've tried troubleshooting this problem by playing with the settings for guides and grids under the "view" menu, changing preferences for units and increments and guides and pasteboards, anything I can think of. Nothing turns this snapping off and it is impossible to do percision alignment when scaling because I can't scale with the up and down arrow keys, only the mouse and other input devices. I have been using InDesign for a long while so I am a relatively advaced user but I haven't been able to figure this one out.

 
Replies
  • Currently Being Moderated
    Aug 27, 2012 12:58 PM   in reply to Pamaro22

    Have you tried turning off "Snap to Document Grid" already?

     

    Also, what unit of measurement do you work in?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2012 1:27 PM   in reply to Pamaro22

    Is it possibly snapping to another object?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2012 2:05 PM   in reply to Pamaro22

    Does it also happen in a new file?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2012 2:26 PM   in reply to Pamaro22

    Is it possible that you had pixels as your unit of measurement in the old document?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2012 2:36 PM   in reply to Pamaro22

    OK, that'a a bit perplexing, but not impossible. Please recheck the old file to be sure snap to grid is not checked.

     

    Is this a file from a previous version of ID, or converted from som other layout program?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2012 3:22 PM   in reply to Pamaro22

    Sorry, I totally missed that part of your answer.

     

    Yes, if you have selected pixel as your unit of measurement, objects will snap to the pixel grid. It is entirely possible to have objects be placed outside of this grid, but when moving them around they will snap to the grid.

     

    How did you go about changing the units of measurement for the document? If you aren't you should try (with rulers on) right clicking on the box in the top left hand corner where the rulers meet and selecting a different unit of measurement. I usually work in picas.

     

    Screen Shot 2012-08-27 at 3.20.52 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2012 9:38 PM   in reply to Pamaro22

    Well I'm glad you resolved that. I'm not sure about that question though. Is there a reason that you need to have items not snap to the pixel grid? I feel like the grid is there for a good reason.

     

    Does anyone else know of a workaround other than switching to other units?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2012 3:45 AM   in reply to Alec Molloy

    I agree. If working in pixels there is an implication that all objects should have whole-pixel dimensions only and should sanp to the pixel grid since you cannot dispaly half a pixel or two pieces of different pixels in the same location on a screen.

     

    That said, switching to points will get you exactly the same size realtionships in ID without the snapping.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 1, 2012 10:28 PM   in reply to Peter Spier

    Thanks, everyone, this ws a very interesting thread.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 9:59 AM   in reply to Alec Molloy

    …Here I am, several months later experiencing the same problem. Based off this thread I can now change the unit of increment that an object snaps to. But I don't want my objects to snap to any increment. Is there any way to turn this feature off so my objects snap only to guides and/or the document grid?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 10:39 AM   in reply to bud_r

    Bud, the only unit that will cause elements to snap in increments is pixels. If you use picas or points you don't have to worry about this.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 11:20 AM   in reply to Alec Molloy

    This is true in most of my documents, but there are a few floating around this office that snap to each corresponding unit, points, inches, or pixels. It's very strange. I'd love to find a way to turn this off without having to make a new document and pasting all the content in to it.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:22 PM   in reply to bud_r

    Did you check to be sure snap to document grid is turned off?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 6:14 AM   in reply to Peter Spier

    yes

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 6:22 AM   in reply to bud_r

    See Remove minor corruption by exporting. Maybe that will help.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2013 8:57 PM   in reply to bud_r

    Hi there, not sure if this is an issue but if you go into Layout - Layout Adjustment, and click Enable Layout Adjustment, and change the Snap zone to 0mm, it might fix your problemScreen shot 2013-07-01 at 11.50.51 AM.pngScreen shot 2013-07-01 at 11.51.00 AM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 6:57 AM   in reply to TinekeRose

    I have encountered this problem today. I turned off "Smart Guides" and now nothing is snapping and letting my place it anywhere I like. Hope my method helps!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2014 10:55 AM   in reply to JennaSenso

    Hello! I was having a similar problem. I tried everything suggested above but it didn't work. Finally I just typed in the location of where I wanted the image to be placed:

    Dimensions.png

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2014 12:47 PM   in reply to Shaala

    As noted above, if you really are working for screen, the implication is you need to snap to even pixels. If you are not, switch to a different unit of measure for the rulers and the snapping will go away.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points