Skip navigation
Currently Being Moderated

"Authorize" on Flickr export plugin doesn't open browser

Aug 30, 2012 9:21 AM

Tags: #lightroom #catalog #export #plugins #metadata #flickr #lightroom_4 #lightroom4

I'm trying to authorize Lightroom to export to my Flickr account, but when I click "Authorize" nothing appears in my browser.

 

I am using Lightroom 4.1, and upgrading to 4.2 RC1 didn't resolve the issue. I've tried clearing my temporary files and re-installing Lightroom. I tried deleting my catalog and starting again. My default browser is currently Chrome, but when I make IE the default, I see the same behavior.

 

Any suggestions on getting Lightroom to show me the authorization dialog box so I can export to Flickr?

 
Replies
  • Currently Being Moderated
    Aug 30, 2012 9:55 AM   in reply to ajgnet

    Do you have your Browser Opened and Logged into Flickr when you click [Authorize]?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 10:18 AM   in reply to ajgnet

    Do you get this window? If not, it may be that you have checked this box and then hit the Do Nothing button at some time in the past.

     

    8-30-2012 12-13-42 PM.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 10:30 AM   in reply to ajgnet

    Working backwards from here the Previous action that invokes this screen is a Authorize button on your Flickr Page. Do you ever see that?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 10:49 AM   in reply to ajgnet

    No new blank tab appears in Google Chrome?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 11:02 AM   in reply to ajgnet

    Is your Browser (including the non-default IE) set up to work in offline mode?

    Is Firefox installed?

    Firewall?

    Internet Security Software?

     

    I just tested two Win 7 Machines and they both work fine.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 29, 2012 3:55 PM   in reply to ajgnet

    This is how I fixed it:

     

    1. Go into your flickr services page: www.flickr.com/services/

    2. Click on the link "Apps You're Using"

    3. You will see a list of apps you are using and should see Adobe Photoshop Lightroom.

    4. Click "Remove permission?" next to Adobe Photoshop Lightroom and revoke this apps permissions.

    5. In Lightroom configure the Flickr publish service: click on the "Authorize" button and your browser will popup again as usual. Authorize and return to lightroom. All fixed

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 2, 2013 9:59 AM   in reply to ajgnet

    [Edit: skip down to my other reply to this thread.  The problem was that the system clock and time zone were incorrect.]

     

    I am experiencing the same symptom.  In the Flickr Publish service configuration dialog, the Authorize button pops up a dialog that explains "Lightroom needs your permission to upload images to Flickr," but when I click that dialog's Authorize button, it appears to do nothing (no browser, no error message, etc.). 

     

    I am currently running Windows 8 Pro 64-bit and Lightroom 4.3 64-bit.

     

    Here's a history of this problem. 

     

    I was using Windows Vista 64-bit with an updated Lightroom 3 (version 3.6?).  I was publishing to Flickr using the built-in Flickr publish plugin.  That worked flawlessly, and I never had a problem.

     

    I then upgraded to Windows 8 Pro 64-bit.  Unfortunately, I did not test Lightroom 3 at this point.

     

    I then upgraded to Lightroom 4.3 64-bit. 

     

    After these upgrades, I tried to publish two photos to Flickr using my existing Flickr publish configuration.  I believe that I got some error the first time, which I did not write down.  I wasn't sure that the Flickr publish service would upgade correctly, and I did some searching online. 

     

    I'm familiar with the Flickr APIs, and I thought that after the upgrade, I probably needed to re-authorize the plug-in.  I went to my Flickr account in my browser and revoked Lightroom's permissions.  I may have also clicked "Remove Authorization" in the Flickr publish plugin's settings page.  After that, I started hitting the problem described above.  When I click the Authorize button, I never get a browser pop up.

     

    I then tried a few things. 

     

    1) I verified the registry entries had the values described in this thrad: http://forums.adobe.com/message/3121076#3121076

    2) I removed the old Flickr publish service that had been migrated from Lightroom 3.6.

    3) I uninstalled Lightroom 3.6.

    4) I ran the "repair installation" for Lightroom 4.

    5) I ran lightroom.exe -register as the administrator.

    6) I ran Lightroom 4 as the administrator.

     

    Between each of those steps, I rebooted the machine.  When the machine came back up, I opened Lightroom 4 and clicked the Flickr publish service's "Set up" button.  I then when to the plugin manager and reloaded the Flickr plugin.  Finally, I clicked "Authorize" in the Flickr plugin's settings.  Every time, I get the same behavior.  "Not authorized" in the settings dialog changes to "Authorizing..." while it shows me a dialog.  I click the Authorize button in that dialog.  I briefly see a different message in Flickr publish service settings page (Waiting for response...).  Then it changes to "Not Authorized."  I never see a browser or an error.

     

    With each experiment, I tried with both IE and Firefox set as my default browser.  I get the same behavior with both browsers. 

     

    I verified that running "start lightroom://www.flickr.com" from the Windows command prompt opens Lightroom 4.3.  Therefore, I believe that the registry settings for the lightroom URL protocol are correct.

     

    I have never used the Facebook publish service in the past, but I cilcked on the set up button for that plugin.  When I click Authorize on Facebook, it launches my browser (or opens a new tab) for Facebook.  Therefore, it looks like Lightroom plugins are able to launch the browser.

     

    It seems like there's something wrong with the Flickr publish service plug-in itself.  I'm not sure how to get any additional diagnostic information from the plugin.  I'd be happy to try something else, but at this point, I'm out of ideas for troubleshooting.

     

    Message was edited by: t_bryan

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 2, 2013 9:57 AM   in reply to ajgnet

    Check your system clock. See also: http://forums.adobe.com/message/4960935

     

    Friedl's Flickr plugin reports the error better, but if your system time is too far off (check both the time and time zone), then the Flickr API authentication can fail.  Unfortunately, the builtin Lightroom Flickr publishing plugin silently fails in that case. 

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points