Skip navigation
Currently Being Moderated

Strange Problem with 3D Camera Tracker's screwed up Bullseye, Create Text or Solid and Camera

May 8, 2013 2:37 PM

After I create a 3D Camera Tracker Solve I get no bullseyes target, but I can see all the tracker points. When I right click to create the "Create Text and Camera" I also get nothing no Text or Text field. I've been following several tutorials to the "T" and I still get nothing. What's strange is this was working fine last month when I was using the Creative Cloud trail free for 30 days.

 

On further trail and error I noticed something very, very weird. I noticed after I made the "Text and Camera" there was a  red pixel blinking within the triangulation of the 3 points. I zoomed in all the way to 1600% into the red blinking pixel and noticed it was the Text field's Cursor. When I inspect the Text layer's "Scale" it stated that the Text is already sized at 3000. WTF? Even zoomed in at 1600% it's only the size of my pinky finger nail. If I enter a ridiculous Size amount such as 1,000,000 I can finally see it on the screen and to top it off the 3D orientation is totally off from the plane chosen from the triangulation of the 3 points. The orientation is also totally wrong in a different plane then the 3 tracking points.

 

Please help I can't follow any tutorials because something is terrible wrong. This is way beyond me. Everytime I watch any tutorials I'm stuck because of this. I'm going to attach some photos to better illustrate these problems.

 

Ps. I also noticed when zoomed in at 1600% I could finally see the Bullseye which made me realize the connection. so again like the Text Field issue if I max out the Target size to 10000% I can finally see the bullseye target. Even sized at 10000% the target displays only at approx. 2" This is totally wierd.

 

thanks for your time, betamax.

 

 

TextCamera_WTF.jpg

 
Replies
  • Currently Being Moderated
    Sep 3, 2012 9:09 PM   in reply to BETAMAXandtheMCP

    Your footage is crap for any sort of 3D tracking, that's the simple harsh truth here, at least based on the pic you provided. Sorry to say so, this is loco and cannot work the way you want it. The tracker simply interprets your absence of structural details as a huge scene, possibly compounded by your camera move. That aside, any 3D tracking solution is arbitrary - it is a mathematically plausible reconstruction of the scene, not necessarily a physically exact representation of the real thing, even more so in an uncalibrated track such as this. You can try with other options, but the truth of the matter is it will probably never work. Your only option is to use a solution that supports manual tracker placement to re-construct e.g. the stairs and railing as "reference geometry".

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 4, 2012 1:09 AM   in reply to Mylenium

    You need to make sure that you reset 3D Camera Tracker before you start a track. Make sure that the Track Point Size and Target size are at 100%.

     

    Your Track Points should look like this:

     

    Screen Shot 2012-09-03 at 10.35.20 PM.png

     

    If they don't then either there's too little detail (not enough points to track) or the values for Target and Track Point are wrong. Your shot doesn't have a lot of detail to track but if you pick the right track points you should be able to get something to work.

     

    Once you pick a target by either selecting points or moving around the shot until you find ones you like, click then position the pointer in the center of the target and click and drag to set the position of your layer, then Alt/Option click to scale the target to the right size.

     

    Any new solid created with the 3D camera tracker will be the same size as the Target at 100% scale. Text works a little differently. You need to set the text size in the Character Panel before you create Text or Text and a Camera from 3D Camera Tracker.

     

    I usually set some temporary type in the frame that's a little larger than the the text I want in the scene. I then delete the temporary text layer and create the 3D text layer from 3D Camera Tracker. I then check the scale property, reset it to 100%, then set my final size with the Character Panel.

     

    This workflow has worked for every shot that I have successfully tracked so far. It should work for you.

     

    Here's a 1 minute look at 3D camera tracker.

     

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2012 12:47 PM   in reply to Rick Gerard

    BETAMAXandtheMCP,

     

    Did you ever get the camera tracker problem fixed?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 12, 2012 1:31 AM   in reply to Rick Gerard

    I'm having the same issue with the bulls eye... i do not see it, yet, i can't even select the tracker points. The only way i can see the tracker points is if the checkbox is selected to render it.  Please help get my bulls eyes. Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 12, 2012 7:23 AM   in reply to bluezaza

    Did you watch the sample video? The Camera Tracker plug-in must be selected in the Effects Crontrol Panel to see anything live in the comp window.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 12, 2012 11:36 AM   in reply to Rick Gerard

    i have The Camera Tracker plug-in selected in the Effects Crontrol Panel and the footage selected.  i get a nice solve with average error 0.37 pixels.  Like i said, i can see and manipulate the Track Point only if Render Track Points is checked.  I'm not able to highlight any of the points, yet select them with my mouse.  I've watched the above video and it is no help.  thanks for the quick reply. 

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 12, 2012 1:46 PM   in reply to bluezaza2

    I have used alot of 3D  Camera Trackers (The Foundry, Syntheyes and AEs). I have found the most recent version AE Camera Tracker used on an HP Z820 to be hit or miss.

     

    When I do a track then see no evidence of tracking points or targets, in order to get it to work I have to delete the clip, add the clip into the comp again and then reapply the 3D tracker. Then it usually works. This happens in the most recent version of AE CS6. Did not see thie problem in 6.0

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 1:48 PM   in reply to bluezaza2

    Try turning off open GL acceleration in your Comp Window. That's the only thing that I can think of that may keep the tracking markers from showing up.

     

    Check out this 15 second clip. If you're doing this and the tracking markers don't show up then it's a display, display driver, or open GL problem. OR you may not have Active Camera selected in the Comp Panel.

     

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 3:43 PM   in reply to Rick Gerard

    ok, so i think i found the problem.  Since i want to use CS6, i have to get a better graphics card.  INSANE! autodesk MAYA works fine but for CS6 my Nvidia card does not have "Shader Model".  This is kind of ridiculous, but hey, these companies are all working together to vacuum my bank account!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 3:54 PM   in reply to bluezaza

    No, I dont think that is the solution I have the GTX570 which is a real powerful card that works just fine fine with everything and with Camera Tracker up until 6.02. Dont buy that new card just yet. 

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 4:36 PM   in reply to lasvideo

    Are you sure you have Active Camera selected in the Composition Window?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 4:46 PM   in reply to Rick Gerard

    If you are addressing me, Rick. Yes. Like I said, Ive done extensive work with it, Sysntheyes and The Roundry version.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 6:18 PM   in reply to lasvideo

    Nope, adressing bluezaza

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 8:36 PM   in reply to Rick Gerard

    Yes Rick, i'm selecting and clicking on EVERYTHING! lol....Active camera is selected.

    what do you think about the graphics card issue?

    and lasvideo, i wasn't referring to your problem when i said "i found the problem."

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2012 9:14 PM   in reply to bluezaza

    OOOHH SNAP!! got it!! i loaded another footage, an unedited footage into AE and BAM! It works!! i guess the origianl footage that i was trying to track did not like to be tracked.  The original footage was dumped from Final Cut... probably wrong format.  Anyway, thanks for all the help, i've got my bullseye!! yay!!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 7:10 AM   in reply to bluezaza

    Dont be to sure. I have tried the same piece of footage several times. The first several it was fine, then no tracking markers, then it was fine again. Im glad you are up and running again.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2012 11:57 PM   in reply to BETAMAXandtheMCP

    Hey BETAMAXandtheMCP,

     

    For a personal project I had been experiencing the same issue. I was tracking a very simple scene with almost no motion and distinct textures, but getting tracking points so small that I had to resize them to 9990% their size to see them.

     

    Seeing as most of my video was one big plane in the background with a subject in the foreground, I went into the advanced section and changed my Solve Method to "Mostly Flat Scene". This almost instantly gave me tracking points that I could work with.

     

    I'm not sure if this solution is right for you as I am by no means an AE expert (I stick to print and digital publishing), but maybe playing around with these settings might solve your issue.

     
    |
    Mark as:
  • Currently Being Moderated
    May 6, 2013 12:11 PM   in reply to BETAMAXandtheMCP

    EASY FIX!!! I had the same problem.  Make sure the 'Toggle Mask and Shape Path Visibility' switch in the comp window is set to 'on'. The tracking points will become selectable and the bullseye will show up. Easy as that!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2013 3:25 AM   in reply to jonash

    AHHH thank you. Such an easy mistake to make!! Was getting worried I needed a new graphics card, glad I skipped to the end of the forum first!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 30, 2013 2:11 PM   in reply to HarryHoag

    how do you do this? im having the same problems, there is no track points showing:/ can you reply asap im halfway through a edit:/

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 30, 2013 2:30 PM   in reply to pumpgaming

    Select the Camera tracker in the ECW and then you should see the targets.

     

    Carefully watch the short video I posted above.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 30, 2013 2:45 PM   in reply to Rick Gerard

    is there a skype or facebook twitter or something i talk to you on so i can stream my computer screen to show you?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 30, 2013 3:55 PM   in reply to pumpgaming

    you are asking a lot...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2014 3:36 AM   in reply to bluezaza

    Found this thread, but I'm still having some issues. 

     

    In my project I'm trying to use the 3D camera tracker on some footage.  No matter what I do the target and the tracking points don't show up. The tracking points only appear when the "render tracking points" button is ticked on.  I then tried my usual test footage that I always use to practice tracking and what not. Still no dice.  BUT, when I opened a new project and tried my test footage everything was fine. 

     

     

    Any ideas what may be going on?

     

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2014 9:44 AM   in reply to DStrangeBoston

    Hi DStangeBoston. As jonash said before, make sure all your viewport layer controls are turned on. Click the options button on the top right of the composition window and click "view options..." Make sure it's all on.

     

    Hopefully that will fix it for you. That's what happened to me when I had this problem, I was on a machine where someone had previously turned them all off. It's absolutely infuriating not being able to see the markers and not figure out how to turn them back on! It's not an obvious button, Adobe should put a notification up if there off and you're trying to use the camera tracker.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2014 9:05 PM   in reply to HarryHoag

    Thanks for the reply Harry.  It's still not working.  It must have something to with the project I'm working in or something. 

     

    You're right it is frustrating!! Lol

     

     

    I went to the view options where you said and toggled the switch at the bottom of the comp window. 

     

     

    Any ideas? 

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 14, 2014 5:19 AM   in reply to DStrangeBoston

    Make sure you have the 3D camera tracker effect selected in the effect controls window. Then press Ctrl + Shift + H

    This will bring up the layer controls AND the camera tracking points.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2014 9:34 PM   in reply to Meiereika

    I need help! everytime i motion track ,it didnt work so i had to split the scenes and add 3d camera tracker to each seperate portion of it. So after i did , i right clicked the points and added the null object and so on. But when i went to change the size or whatever,it would loose its point and not move,as if it wasnt camera tracked at all. I cannot find anything to help me on this

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points