Skip navigation
adob357
Currently Being Moderated

How do I keep illustrator from doing unwanted snapping?

Sep 11, 2012 9:51 AM

Tags: #illustrator #problem #cs6 #snap

I have been experiencing the problem of elements not aligning properly.

I will try to do a fine tune alignment manually, however, I have discovered that the program does not allow me to accurately align any elements. They all seem to snap off alignment by 0.5 point/pixel.

 

I tried to turn off snapping at all levels, however, it still continues to misbehave. Perhaps I missed a switch somewhere.

 

I do not remember other versions of the program acting this way, so, it seems unusual.

 

Is there a way to around this, or is there some hidden control to fix this problem?

 

Thank you for your input.

 
Replies
  • Currently Being Moderated
    Sep 11, 2012 9:53 AM   in reply to adob357

    Is Align to Pixel Grid turned on? Look in the Transform panel and click it off.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 11, 2012 9:58 AM   in reply to adob357

    In the transform panel flyout menu uncheck the option for Align New Objects to Pixel Grid. Additionally, select any objects you already have on your artboard and in the Transform menu uncheck Align to Pixel Grid.

     

    align_to_pixel_grid_transform.png

     

    When you started your project you might have chosen the Web preset, in which case the option becomes automatically selected.
    align_to_pixel_grid_new.png

     

    Hope this helps!

    Michael

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2013 5:38 PM   in reply to adob357

    Is there any way to change this default after the document was created? We have a few documents that must have had "align to pixel grid" set when created but was an oversight... I suppose a workaround is to create a new document and copy all the contents from one to another, but that workaround can get arduous if there are many layers and layer effects.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2013 7:54 PM   in reply to viveredesign

    If you're having trouble when you copy layers from one file into another, ie the layers all collapse into layer 1 of the new file, just turn on "paste remembers layers" from the layers flyout menu. Then when you paste all of the layers will come over intact.

     

    Hope that helps,

     

    Michael

    http://www.learnadobesoftware.com

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2013 11:17 AM   in reply to viveredesign

    To enable or disable this option in an already-created document, you toggle the setting in the Transform palette's flyout menu, "Align New Objects to Pixel Grid"

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 19, 2013 8:51 AM   in reply to mjarrott

    Is there any way to change the web preset so you don't automacitally have "align to pixel grid" selected on any new document?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 19, 2013 9:24 AM   in reply to Jfavero

    Is there any way to change the web preset so you don't automacitally have "align to pixel grid" selected on any new document?

     

    edit the new document profile

    http://blogs.adobe.com/adobeillustrator/2009/05/startup_profiles_a_gre at_tool.html

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points