Skip navigation
Currently Being Moderated

Dreamweaver CS6 - FTP changing my file permissions on upload???

Sep 19, 2012 11:38 AM

Tags: #dreamweaver_cs6

Upgraded to cs6. All programs work perfect for me exceopt Dreamweaver.

 

I have never expierenced this challenge however no matter what file(s) I upload dreamwever is chanign the file permissions.

 

For instance if I upload an image to the sever the image won't appear. I check permissions and they are set to 0.  Same with files.

 

I have to now go in to each item I upload and change permissions to 644 or 755 depending if its a file or directory.

 

This is a Dreamweaver exclusive problem as it does not happen when I use Filezilla and Im working on 6 different servers.

 

ONLY when I upload files with Dreamweaver CS6 do the file permissions change on upload. Cs5.5 no problem.

 


Any ideas?

 

Aloha!

 
Replies
  • Currently Being Moderated
    Oct 17, 2012 11:31 AM   in reply to dreamteammedia

    i am getting this same error and end up needing to do the same corrections.

    i am also on DW-CS6 using macbook 10.7.5

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2012 11:40 AM   in reply to dreamteammedia

    I have been having this problem for some time now.

    CS6

    version: 12

    build: 5842

     

    When I upload a file to the server, it sets permissions to 644 and my manager can not alter that file until I reset the permissions.

    What a pain in the ....

     

    If I am not around noone can continue work I have touched. This is not conducive to a good workflow.

     

    rad1964rad

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2012 3:12 PM   in reply to rad1964rad

    Hello,

     

    are you using Dreamweaver CS6 to upload files to a Business Catalyst site ?

    We currently don't support file permissions in Business Catalyst and we return either 666 for regular files or 766 for folders.

    The behavior you are describing is indeed strange since our FTP server prohibits setting file permissions, so even if Dreamweaver would attempt to change them it wouldn't be possible.

     

    Can you please describe in detail what are the steps to reproduce the problem ? Does it occur on all datacenters on only on some ?

     

    Thank you,

    Iulian.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 18, 2012 7:35 AM   in reply to Radu Iulian

    Hi Lulian,

     

    Thanks for your speedy response.

     

    I agree its a really strange problem.

    I run a web development hosting company which gives me an advantage on

    troubleshooting but it still took a while to figure this one out between me

    and a server tech reviewing server logs..

     

    This is dreamweaver CS6 connecting to an apache server with shared hosting

    account running the latest software updates.

    I am connecting using the basic FTP settings in dreamweaver with passive and

    optimized unchecked.

    I have been using DW for years like this without issue until now.

     

    This happened on a few different hosting companies for different clients we

    have.

     

    The steps are simple we are just connecting with the hosted account web

    folders through ftp and upload and download web files.

    When we do this it is altering the permissions on the files and the folders

    to 0 and many files are not transferred and we have to reset the permissions

    on each.

    -not sure what you mean that ftp server prohibits setting permissions since

    we can simply right click on the folder/file in dreamweaver and set the

    permissions on the local or server side files.

    For example a clients website is running fine but we have updated some

    simple content on the index.html page.

    We do our updates and connect using dreamweaver through ftp and upload the

    file.

    Usually the file doesn't make through the ftp and the index.html is actually

    deleted off the server and the folders permissions have somehow been changed

    to 0.

    We will change the folders permissions back and repeatedly try to upload

    that file.

     

    Now we switched to the ftp client "yummy ftp or transmit" and everything is

    transferred without a hitch.

     

    This is a common occurrence after I read several posts on your adobe message

    boards on this exact error which led me to this email address.

    Like many of them I am forced to use a dedicated ftp client which has no

    issues but is not how I want to continue my workflow.

     

    Thanks again and tell me if you need anything else.

    I am anxious to resolve this error in dreamweaver and get back to business.

     

     

    Paul WIlliamson

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 18, 2012 8:33 AM   in reply to freak88

    Hello,

     

    for issues related to Dreamweaver you can post in the Dreamweaver forums, which are found here (http://forums.adobe.com/community/dreamweaver).

     

    Unfortunately I can not help you debug the Dreamweaver file permissions issue since this is the Business Catalyst forum. We offer an unified hosting platform for creating online businesses together with a FTP/SFTP server that is used by Dreamweaver and other FTP/SFTP client applications, but we don't have access to Dreamweaver's code base.

     

    Best regards,

    Iulian Radu.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 18, 2012 12:07 PM   in reply to Radu Iulian

    Sorry Lulian,

     

    I am not sure how this made it to you.

    I thought I was talking with Adobe.

    My badŠ

     

    Best regards.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 3, 2013 11:52 PM   in reply to dreamteammedia

    This issue is fixed in 12.0.3 update for perpetual users and 12.1 for subscription users.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2013 6:45 AM   in reply to N D SRIVATSA

    Hi all,

     

    I just became a subscriber two days ago to Creative Cloud. Successfully installed DW CS6.

     

    I have used DW CS5 for years without problems. However, now - even though 'test' says AOK for a client's ftp access - simple html files are not uploading to the server.

     

    I read this thread yesterday, went into Adobe Application Manager and installed an update to DW CS6 but am still not able to have files move up to remote server (even though test connection works).


    Please help advise what I can do to problem solve this issue. Is it DW CS6, is it Mac OSX operating system (Lion Version 10.7.5) is it hosting company (how can that be if when I test connection in DW - test is AOK?)

     

    Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2013 7:45 AM   in reply to dreamteammedia

    I've wrestled with the umask on my server for about 2 years. I finally modifed the sshd config file to set the default for the whole server. SSH/SFTP kept changing the permissions to the default, in spite of what I had set at the shell level. Here's a tutorial for RH/Centos/Fedorda

     

    http://forum.directadmin.com/archive/index.php/t-43656.html

     

    -Dave

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points